Help with CHDKPTP remote shooting on A700 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

Help with CHDKPTP remote shooting on A700

  • 4 Replies
  • 400 Views
Help with CHDKPTP remote shooting on A700
« on: 14 / January / 2022, 18:46:41 »
Advertisements
I am trying to use an A700 under PC control. CHKD is installed on the camera and working. CHDKPTP is installed (as well as LINUSB drivers) and it works. When the camera is in playback mode CHDKPTP connects and sees the files in the camera.  When I slide the camera switch to shooting mode the camera vanishes from CHDKPTP. Sliding the switch back to playback makes it reappear. Is this because the A700 cannot do remote shooting or is there some setting I need to change?

*

Offline reyalp

  • ******
  • 13793
Re: Help with CHDKPTP remote shooting on A700
« Reply #1 on: 14 / January / 2022, 18:51:46 »
I am trying to use an A700 under PC control. CHKD is installed on the camera and working. CHDKPTP is installed (as well as LINUSB drivers) and it works. When the camera is in playback mode CHDKPTP connects and sees the files in the camera.  When I slide the camera switch to shooting mode the camera vanishes from CHDKPTP. Sliding the switch back to playback makes it reappear. Is this because the A700 cannot do remote shooting or is there some setting I need to change?
You should use the chdkptp 'rec' command or GUI button, rather than the physical switch on the camera.
Don't forget what the H stands for.

Re: Help with CHDKPTP remote shooting on A700
« Reply #2 on: 14 / January / 2022, 19:06:36 »
Thank you for the quick reply. When I hit the "rec" button in the gui it says "ERROR: not connected" even though the "Files" tab still works and linbus is still listed in the top right drop down.

*

Offline reyalp

  • ******
  • 13793
Re: Help with CHDKPTP remote shooting on A700
« Reply #3 on: 14 / January / 2022, 20:00:48 »
Thank you for the quick reply. When I hit the "rec" button in the gui it says "ERROR: not connected" even though the "Files" tab still works and linbus is still listed in the top right drop down.
I'm fairly sure that "not connected" error can only appear if it's actually not connected.
The dot at the top left where it says host: ... cam: ... should be green when connected. The camera will be listed in the dropdown even if chdkptp isn't connected.

So first, make sure you've plugged the camera in while it's in playback mode, and hit the "connect" button to connect.

If clicking rec button while connected does actually generate the "not connected" error, does anything other happen? That is, does the camera respond in any way like shutting off or extending the lens, or are any other message printed?
Don't forget what the H stands for.


Re: Help with CHDKPTP remote shooting on A700
« Reply #4 on: 14 / January / 2022, 20:54:40 »
All solved.  Thanks so much.  The real problem was that I was trying to change to shooting mode with the camera's switch.  You solved that problem with your first reply.  My continuing problem was simply caused by forgetting to press "connect" after messing with things and disconnecting

SOLVED: Use the "Rec"/"Play" buttons within CHDKPTP to switch modes, not the switch on the camera.

 

Related Topics