Why isn't this script working? (PowerShot SX410 IS) - Script Writing - CHDK Forum

Why isn't this script working? (PowerShot SX410 IS)

  • 1 Replies
  • 142 Views
Why isn't this script working? (PowerShot SX410 IS)
« on: 26 / August / 2022, 17:13:50 »
Advertisements
I'm trying to write a script to set the zoom speed to maximum while recording. (I don't mind the zooming noise.) But I can't get much farther than this. Any help would be appreciated. (And yes it is encoded as ANSI/ASCII)
Sent from my Canon PowerShot SX410 IS

*

Offline reyalp

  • ******
  • 13792
Re: Why isn't this script working? (PowerShot SX410 IS)
« Reply #1 on: 26 / August / 2022, 22:45:52 »
I'm trying to write a script to set the zoom speed to maximum while recording. (I don't mind the zooming noise.) But I can't get much farther than this. Any help would be appreciated. (And yes it is encoded as ANSI/ASCII)
As I mentioned in the other thread, the set_zoom_speed function only controls the speed used when you zoom using the set_zoom function. It does not affect the speed used in response to key presses.

So if you did
Code: [Select]
set_zoom_speed 100
set_zoom 100
It should zoom at full speed to zoom point 100.

However, if you want to manually zoom at high speed, this doesn't help. You might be tempted to try to write a script that calls set_zoom in response to key presses, but this wouldn't really work either, because you can only tell set_zoom to zoom to a particular point, rather than zooming until some event tells it to stop.

edit:
I should also mention that set_zoom_speed takes a value in percent (1-100), but for most cameras, there are only two or three speeds. So for max speed, you'd want 100, and for slow 1. A few very old cameras do support additional speeds.
« Last Edit: 26 / August / 2022, 22:49:42 by reyalp »
Don't forget what the H stands for.

 

Related Topics