HELP! video settings not working on SD800 using allbest-ixus850_sd800-100e-50 - AllBest's Builds - CHDK Forum supplierdeeply

HELP! video settings not working on SD800 using allbest-ixus850_sd800-100e-50

  • 8 Replies
  • 4097 Views
Advertisements
Hi,

First off, thanks for the great firmware!

I've been playing with allbest-ixus850_sd800-100e-50 on my SD800 (firmware 1.00E), and I noticed that the video settings don't work.  The raw settings and other things work fine, but I've tried all the bitrate/quality settings, and I can't get the camera to record using anything other than the standard 2MB/sec video compression.  Also, the optical zoom setting doesn't function.

I also have a SD700, so for comparison I tried allbest-ixus800_sd700-100b-50 on that, and the video compression settings work fine, so I don't think I'm using it wrong.

???
Thanks for any help!
Cheers,
Dave

*

Offline ewavr

  • ****
  • 1057
  • A710IS
I've been playing with allbest-ixus850_sd800-100e-50 on my SD800 (firmware 1.00E), and I noticed that the video settings don't work.  The raw settings and other things work fine, but I've tried all the bitrate/quality settings, and I can't get the camera to record using anything other than the standard 2MB/sec video compression. 

Yes, I see bug there. Try this test version - http://ewavr.nm.ru/chdk/for_test/allbest-ixus850_sd800-100e-51.zip

Also, the optical zoom setting doesn't function.

I don't see bug there  ??? But first test bitrate settings.

edit: Another bug found, re-uploaded.
« Last Edit: 28 / May / 2008, 17:21:50 by ewavr »

Hi,

Thanks for the fast response!  I tried your test build, but unfortunately, it appears the problem is still there.  I also checked again on the optical zoom, and that still isn't working either.

Cheers,
Dave

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Well, I found third bug (I don't know how camera can work with this bug  :)), file is re-uploaded.
If problem is still here, movie_rec.c will be rewritten from the beginning (tomorrow).
« Last Edit: 28 / May / 2008, 19:11:40 by ewavr »


That seems to work!  The optical zoom is working too.

Thanks very very much!

Cheers,
Dave

ewavr:

could you provide the link for the sd800 fix?  the present link does not work.  or are the problems fixed in allbest-ixus850_sd800-100e-51-407.zip

thank you.

:)
« Last Edit: 30 / May / 2008, 19:55:22 by js2020 »

*

Offline ewavr

  • ****
  • 1057
  • A710IS
or are the problems fixed in allbest-ixus850_sd800-100e-51-407.zip
Yes, fixed. Download site.

thanks

 :D


The optical zoom now works, really useful fix! :-)

There's still a bit of a bug there, though (testing on allbest-51-408) - optical zoom works fine until you zoom in digitally beyond the optical zoom range, but after that it's impossible to zoom out optically again.

 

Related Topics