Can anyone confirm if ND filter state is working on Allbest build 51 for SD870? - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Can anyone confirm if ND filter state is working on Allbest build 51 for SD870?

  • 5 Replies
  • 2479 Views
Advertisements
I'm using an SD870, trying to force the filter to be out in order to get an effect f-stop of f/2.8 so that I can use fast shutter speeds in bright conditions.  Any help will be much appreciated!

The ND filter state options in the "Extra Photo Operations" menu don't seem to be working.

I also tried the following script, which had no effect on f-stop or exposure:

@title ND filter test
rem listen to hear ND filter sing in and out
rem
sleep 2000
set_nd_filter 0
sleep 2000
set_nd_filter 1
sleep 2000
shoot
sleep 2000
set_nd_filter 2
shoot
sleep 2000
set_nd_filter 0
sleep 500
end


« Last Edit: 28 / May / 2008, 17:30:09 by Michael L »

*

Offline fe50

  • ******
  • 3099
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Hi Michael,
i can fully confirm this for SD870 fw 1.00C with the latest Allbest 51 (trunk406) !

The ND filter setting in ExPhotOp has no effect at all, in scripts the set_nd_filter is also without effect (all tests done in manual mode).

I can always hear the ND filter swing in/out when moving the cam direct to a lamp, i can also see it (in the reflexions of the lenses) - but i can't control it, neither with the settings nor in a script.

Only in fireworks scene mode the ND filter is always out (not set) - also with direct light - and swings always in (is active) when half pressing the shutter.

I always get F8.0 when the ND filter is in (active) and F2.8 when it is out (inactive), in fireworks mode i always get F8.0.

The camera autonomous enables/disables the ND filter when moving into light (except the fireworks mode), regardless of any settings or script instructions, also while running the ND test script.

Thanks very much for confirming that the ND filter state settings are not working.  It seems like you've found a way to force f/8 (fireworks mode).  What I need is a way to force f/2.8.

Hopefully the developers will be able to make whatever changes necessary so that the ND filter state settings will work in the CHDK menu and in scripts.

*

Offline fe50

  • ******
  • 3099
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Michael,
made a short ND filter test with my Ixus55, there it works (tested in auto mode).

The behaviour is the same as on SD870, but the pics are different as they should be (one darker) !

The ND filter is not directly controlled by the set_ statement, only prepared: with shoot the filter swings in/out as prepared with set_nd_filter; you can't hear it moving with set_nd_filter, only when shooting.

On SD870 with the same script the pics are identical, also identical EXIF data - so definitively the ND filter on the SD870 doesn't work.

...Do we have another DryOS camera with working ND filter for comparing the sources ?


Good investigative work, fe50.  The SD870 is the only DryOS camera I have.  Maybe someone else has one that they can check.

The DryOS and Digic III cameras are somewhat different from the other cameras, so features may not be functional without being tweaked.  When I first got my SD870 last week there was no USB remote capability.  When I pointed it out and provided some related info, Fingalo added it to the build very quickly.

I hope it will be just as simple to add the ND filter state capability.
« Last Edit: 29 / May / 2008, 00:58:16 by Michael L »

*

Offline fe50

  • ******
  • 3099
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Quote
When I first got my SD870 last week there was no USB remote capability
Hi Michael, i know, i've done this in my private source copy & posted the diff, fingalo put it into the trunk the same day...
Quote
I hope it will be just as simple to add the ND filter state capability
I hope this, too - i've not the time to check this by myself the next couple of days...


 

Related Topics