revamping get_exp_count, need help - General Discussion and Assistance - CHDK Forum supplierdeeply

revamping get_exp_count, need help

  • 27 Replies
  • 8373 Views
*

Offline Jucifer

  • *****
  • 251
  • [A710IS]
revamping get_exp_count, need help
« on: 04 / June / 2008, 08:51:26 »
Advertisements
edit: Hold the presses, the data used by "total shoot" display can't be used. It can be the next value, though, if it increases on every exposure.

If you want get_exp_count to return the actual number of taken exposures on your cam (check the list below), I need to know the parameter data number the counter is at. It should be easy to find:
- (optional) place a file named vers.req on SD
- (optional) in play mode press func/set and click disp several times until you see "total shoot" and a number (e.g. 1075, see 1.jpg)
- goto debug menu
- check "show parameter data" (see 2.jpg)
- exit menu
- find the number of total shots (can be quite close what "total shoot" claims; can be way off, as in my case) and make sure it's increased by 1 on every shot and updated without mode changes, the number needed is to the left (e.g. 1 2, see 3.jpg)
    (- there's also a counter that's increased by 16 on every exposure, that's used by the current get_exp_count (unreliable in some cases))
(- if necessary, search through several paramsdata pages (debug menu) until found)
- post the parameter data number to this thread/me

The number may be 1, but it's better to check...
Better use 2...


Parameter data needed for:
a450
a460
a530
a540
a550
a560
a570
a610
a620
a630
a640
a650
a700
a710
a720
g7
ixus55_sd450
ixus65_sd630
ixus700_sd500
ixus70_sd1000 (quietschi)
ixus800_sd700
ixus850_sd800
ixus860_sd870
ixus950_sd850
s2is
s3is
s5is (DataGhost)
tx1 (cybercom)
« Last Edit: 04 / June / 2008, 16:05:03 by Jucifer »

*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: revamping get_exp_count, need help
« Reply #1 on: 04 / June / 2008, 09:16:31 »
Hi Jucifer

same as on a710is on my ixus70_sd1000. param 1

btw, sometimes the number of total shot is reset to 0, but i don't know why

cheers quietschi

*

Offline Jucifer

  • *****
  • 251
  • [A710IS]
Re: revamping get_exp_count, need help
« Reply #2 on: 04 / June / 2008, 09:26:25 »
btw, sometimes the number of total shot is reset to 0, but i don't know why

Also my cam has reset that counter. Have no idea...
Thanks for the fast reply. :]

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: revamping get_exp_count, need help
« Reply #3 on: 04 / June / 2008, 09:28:51 »
it should be reset when the internal battery is low on voltage.
funny i wanted to start a similar thread, not neccessarily for exp_counter though, but for a kind of "information menu". where you see total shoot count, last error, camera owner etc.


Re: revamping get_exp_count, need help
« Reply #4 on: 04 / June / 2008, 10:31:20 »
TX-1:

Parameter 1 reflects the vers.req shoot number, but does not update if additional shots are taken until Mode Switch is changed.

Parameter 2 is a slightly different number than vers.req, but does increment with every new picture taken.

HTH,
~~~~~~~~~~~~~~~~~~~~~

<")%%%><<

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: revamping get_exp_count, need help
« Reply #5 on: 04 / June / 2008, 11:11:36 »
IXUS 700 - this parameter not exists (#0 always=1; #1 ='Canon'; #2=Model name), vers.req file not recognized.
For other cameras it can be found using IDA (how? I will update this message after returning to my computer).
« Last Edit: 04 / June / 2008, 11:15:32 by ewavr »

*

Offline Jucifer

  • *****
  • 251
  • [A710IS]
Re: revamping get_exp_count, need help
« Reply #6 on: 04 / June / 2008, 11:26:58 »
cybercom,
thanks for pointing that out.
Param 2 is way off on my cam, but increases on every shot, param 1 doesn't increase.

ewavr,
take your time. :]

Re: revamping get_exp_count, need help
« Reply #7 on: 04 / June / 2008, 11:49:48 »
Hi Jucifer,

OK, here's one number that increases by 16 each time I take a shot:

53748224


A number that increases by a different amount every time:

1212526247



But that's it.
Using Canon PowerShot A620 & A560


Re: revamping get_exp_count, need help
« Reply #8 on: 04 / June / 2008, 11:52:09 »
OK, param 1, I just saw, increases by 1 each shot and is reflected when I change the mode.  That is currently 6643.

[EDIT] One more thing, the

(optional) in play mode press func/set and click disp several times until you see "total shoot" and a number (e.g. 1075, see 1.jpg)


this option doesn't work on my camera.  I can see the firmware revision and one more page that shows Adj Ver001.022 but below that says "ZoomLensError".
« Last Edit: 04 / June / 2008, 11:54:35 by rawhead »
Using Canon PowerShot A620 & A560

Re: revamping get_exp_count, need help
« Reply #9 on: 04 / June / 2008, 12:01:41 »
@rawhead:

make sure the file is called vers.req not ver.req & see if that makes a difference...
« Last Edit: 04 / June / 2008, 12:05:04 by cybercom »
~~~~~~~~~~~~~~~~~~~~~

<")%%%><<

 

Related Topics