Time lapse on A460, focus lock breaks in script - Script Writing - CHDK Forum  

Time lapse on A460, focus lock breaks in script

  • 4 Replies
  • 2918 Views
Time lapse on A460, focus lock breaks in script
« on: 15 / June / 2008, 16:32:44 »
Advertisements
Hi all, thanks for help in advance...

I wanted to write a simple script to record cloud formations. Problem with my script is that
the camera wants to refocus after every shot. Is there a way to lock focus other then press "half_shoot"?
Or am i just doing it wrong? I'm a programmer, but i'm reluctant to go into source at this point.

Oh yeah, i forgot to mention i tried with SDM-CHDK (StereoData Maker) 1.70 and
allbest-a460-100d-51-421, same result.
Here is the script i'm using:

@title IntShot (press)
@param a Interval (Minutes)
@default a 0
@param b Interval (Seconds)
@default b 15
@param d Times (1)
@default d 0
@param e Times (10)
@default e 1
t=a*60000+b*1000
l=e*10+d

if t<5000 then let t=5000

print "Focus in 3s.."
sleep 3000
press "shoot_half"
sleep 4000
for n=1 to l
click "shoot_full"
sleep t
next n
release "shoot_half"
end
« Last Edit: 16 / June / 2008, 04:20:55 by tkeino »

Re: Time lapse on A460, focus lock breaks in script
« Reply #1 on: 15 / June / 2008, 17:54:28 »
Just a guess, but I think maybe you have to replace 'click "shoot_full"' with 'press "shoot_full"' and 'release "shoot_full"'.

Re: Time lapse on A460, focus lock breaks in script
« Reply #2 on: 16 / June / 2008, 02:46:07 »
Thanks, i did try that, and i tried following 'click "full_shoot"' with 'press "half_shoot"' too.
Neither worked.

Re: Time lapse on A460, focus lock breaks in script
« Reply #3 on: 16 / June / 2008, 03:55:39 »
Oh yeah, i forgot to mention i'm using SDM-CHDK (StereoData Maker) 1.70.
Also tried allbest-a460-100d-51-421, same result.
« Last Edit: 16 / June / 2008, 04:20:23 by tkeino »


Re: Time lapse on A460, focus lock breaks in script
« Reply #4 on: 16 / June / 2008, 09:15:05 »
Try to use the "manual mode" on the camera.

This is scripts (time laps) that have been working for me (A460). You can try this


rem Johan Van Barel 07-07-2007
rem Interval for Canon A640

@title Interval
@param a Number of Pics
@default a 2
@param b Interval (Min)
@default b 0
@param c Interval (Sec)
@default c 10
@param d Initial Delay (Sec)
@default d 1

if a<2 then let a=2
if b<0 then let b=0
if c<0 then let c=0
if d<0 then let d=0
t=b*60000+c*1000

print "Pics:"; a
print "Total Time:", t*(a-1)/60000; "Min", t*(a-1)%60000/1000; "Sec"

sleep d*1000

print "Pic 1 of", a
shoot
for s=2 to a
    print "Wait",b;"Min",c;"Sec"
    sleep t
    print "Pic", s, "of", a
    shoot
next s

end

__________________________________

rem Author - Keoeeit
rem USE WITH CAUTION
rem do not run for many hours or days
@title Interval Shooting Non-stop
@param a Interval (Minutes)
@default a 0
@param b Interval (Seconds)
@default b 5
@param c Interval (10th Seconds)
@default c 0
 
t=a*60000+b*1000+c*100
 
if t<100 then let t=5000
 
n=1
 
print "Interval shooting."
print "Until you interrupt it."
print "Use with caution."
 
sleep 1000
 
goto "shot"
 
:shot
  print "Shot number", n
  shoot
  n=n+1
  sleep t
  goto "shot"

 

Related Topics