supplierdeeply

ND Filter for SD870 /IXUS860 seems to be working

  • 13 Replies
  • 3300 Views
*

Offline fe50

  • ******
  • 3088
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: ND Filter for SD870 /IXUS860 seems to be working
« Reply #10 on: 13 / July / 2008, 10:22:44 »
Advertisements
Attached to this post there's a diff file ("trunk443_with_SD870_NDFilter_by_chris07.diff") against trunk 443 to integrate this...

Changes: +working ND filter by chris07

(perhaps EWAVR reads this post... ::) )


*

Offline fe50

  • ******
  • 3088
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: ND Filter for SD870 /IXUS860 seems to be working
« Reply #11 on: 13 / July / 2008, 20:14:38 »
Thanks for integrating it in the trunk, EWAVR :D

From Allbest #51 build 444 on the ND filter for the SD870 is working correctly.

Download is available from the latest Autobuild.

Re: ND Filter for SD870 /IXUS860 seems to be working
« Reply #12 on: 15 / July / 2008, 03:29:12 »
Hi fe50,

did you check with your Ixus 50 if the manually set ND Filter changes F2.8 to F8.0? Or does this only work if the filter is set automatically by the Ixus (and not by CHDK)?
IXUS 860IS (SD870)

*

Offline fe50

  • ******
  • 3088
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: ND Filter for SD870 /IXUS860 seems to be working
« Reply #13 on: 15 / July / 2008, 06:38:37 »
did you check with your Ixus 50 if the manually set ND Filter changes F2.8 to F8.0? Or does this only work if the filter is set automatically by the Ixus (and not by CHDK)?
Hi Chris,

yes, they change the F-stop directly !

On the Ixus 50 it is the same as with the SD870, i think it's so on all cams with the ND filter...

On half pressing the shutter the ND filter swings in / out when it is overwriten by the CHDK menu or in a script, you'll see the result directly on the display (get's darker when in...), the Canon OSD shows its (wrong) "standard" F-stop independend from this...looking to the pics & the histogram i would say it's always F-MIN (F2.8 ) with ND filter out & F-MAX (F8.0) with ND filter in.
*EDIT: F2.8-F8.0 is on SD870; on the SD400 it is 2.8-5,6 (CHDK value, no Canon value visible, datasheet say F2.8-4.9).

The CHDK OSD shows correctly the "real" state of the ND filter (and so indirectly the F-stop) that will be active on the next shot.

- Canon OSD & EXIF always show the Canon default value, e.g. F2.8 even when the ND filter is in
- ND filter In / Out changes between F2.8 and F8.0 (SD870) / F4.9 (Ixus 50)
   (on SD870 Canon shows aditional F steps between 2.8-8.0, but i think this is only a software thing...)
- The ND filter swings in/out when focusing or on shooting (shoot in a script), normally it is out except the camera is held into a bright light...

*EDIT: The aditional shown F-stops between MIN / MAX depends on the zoom.


« Last Edit: 19 / July / 2008, 08:03:15 by fe50 »


 

Related Topics