IXUS750/SD550 - Now working, for firmware 1.0F PAL! - page 3 - General Discussion and Assistance - CHDK Forum

IXUS750/SD550 - Now working, for firmware 1.0F PAL!

  • 61 Replies
  • 27629 Views
*

Offline Hacki

  • ****
  • 358
  • SX100
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #20 on: 19 / July / 2008, 06:40:04 »
Advertisements
Cool, any chance you could post the binary so those with 1.00G can have a play? 

There you go: http://mighty-hoernsche.de/chdk/ixus750.tbz2

Includes my diskboot.bin, ps.fir & source (100f & 100g are identical in that archive, i dont know if my changes to 100f are running correctly on a cam which actually has the 100f firmware)

- Correct modemap
- MODE_PLAY & MODE_REC correctly recognized
- SD Override enabled. (Zoom in & out one time before using, otherwise the cam will crash - i dont know if it can harm your hardware, so better be careful)



*

Offline diju

  • *
  • 4
  • IXUS 750
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #21 on: 21 / July / 2008, 07:06:17 »
Works like a charm, so I stopped working on it.

I'd suggest to put hackie's 1.00G build into SVN

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #22 on: 21 / July / 2008, 08:07:58 »
it already is in the svn, in the juciphox branch though ( Changeset 451 - chdk - Trac ). according to hacki the zoom during video function isnt bugfree yet (*might* be dangerous to use it). i would merge it to the trunk when this bug is killed i guess.

*

Offline Hacki

  • ****
  • 358
  • SX100
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #23 on: 21 / July / 2008, 08:18:31 »
according to hacki the zoom during video function isnt bugfree yet (*might* be dangerous to use it)

I cant remeber saying that, but obviously you're right - it seems like the Zoom gets stuck if zoomed in during capturing a video - i cant zoom out afterwards, even when switched back to manual mode.. (shooting still images) 





*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #24 on: 21 / July / 2008, 08:34:00 »
ah ok, i mixed it up with
Quote
- SD Override enabled. (Zoom in & out one time before using, otherwise the cam will crash - i dont know if it can harm your hardware, so better be careful)
but by accident i found a new bug, hehe ;)

*

Offline NU

  • *
  • 4
  • Canon SD550 - NTSC
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #25 on: 21 / July / 2008, 10:36:02 »
Hi All,

Thanks for all your hard work porting the CHDK code for the SD550!

Hacki, could you post a built version of the 1.00G NTSC again? I've loaded-up the code that you posted at:
http://mighty-hoernsche.de/chdk/ixus750.tbz2
onto my 1.00G, but it looks like the diskboot.BIN and ps.FIR files that you've included in the root of your archive are built for 1.00F. I see the 1.00G source under the /sub folder, but I have no way of compiling it.

Any help getting access to a built version of the 1.00G CHDK firmware would be appreciated.


Thanks,
NU

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #26 on: 21 / July / 2008, 10:42:48 »
you can try a fresh build from here: http://www.saunalahti.fi/nirsku/chdk/CHDK-ixus750_sd550-100g-0-452.zip
not the "plain" chdk though, it's the collaborative build.
« Last Edit: 21 / July / 2008, 10:44:29 by PhyrePhoX »

*

Offline NU

  • *
  • 4
  • Canon SD550 - NTSC
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #27 on: 21 / July / 2008, 22:04:24 »
Thanks for your reply and the 1.00G build, PhyrePhoX. I loaded it up onto my SD550 and everything BUT the scripts work. I've tried to get interval.bas, ult_intrvl.bas and timelapse.bas. Every time I try to run a script to take multiple shots, it takes one and the script freezes. If I switch the camera mode (ex. from Manual to Auto), the script resumes.

Any tips would be appreciated.


Thanks,
NU


*

Offline NU

  • *
  • 4
  • Canon SD550 - NTSC
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #28 on: 21 / July / 2008, 22:26:48 »
Ok, so it looks like I have the following firmware on my SD 550:
Canon PowerShot SD550
P-ID:3116 NT
Firmware Ver GM1.00F
E18
Jul 7 2005

I've tried loading all of the F and G builds and the intervalometer scripts all seem to freeze. After I initiate a script, my camera takes the first shot and then it just shows the last focus point on the display. I've got the image review option off in the normal menu, so that shouldn't be messing with my scripts.

Does anyone have any suggestions on what I should try next?


Thanks,
NU

*

Offline imh

  • *
  • 6
  • Ixus 750
Re: IXUS750/SD550 - Now working, for firmware 1.0F PAL!
« Reply #29 on: 22 / July / 2008, 04:16:04 »
Ok, so it looks like I have the following firmware on my SD 550:
Canon PowerShot SD550
P-ID:3116 NT
Firmware Ver GM1.00F
E18
Jul 7 2005

I've tried loading all of the F and G builds and the intervalometer scripts all seem to freeze. After I initiate a script, my camera takes the first shot and then it just shows the last focus point on the display. I've got the image review option off in the normal menu, so that shouldn't be messing with my scripts.

Does anyone have any suggestions on what I should try next?


Thanks,
NU

Hi, had the same issue, anything with the shoot command in freezes (you'll also have to turn off review in the main camera menu)  I amended the scripts to not use shoot and use click "shoot_full" and seemed to work. Here's my version of the intervalomter script.



Code: [Select]
rem Author - Keoeeit
rem Written for S-Series
rem Should be okay on others
rem Use Endless mode with caution
rem See documentation for important info
@title Ultra Intervalometer
@param a Delay 1st Shot (Mins)
@default a 0
@param b Delay 1st Shot (Secs)
@default b 0
@param c Number of Shots
@default c 5
@param d Interval (Minutes)
@default d 0
@param e Interval (Seconds)
@default e 0
@param f Interval (10th Seconds)
@default f 5
@param g Endless? No=0 Yes=1
@default g 0

p=a*60000+b*1000
t=d*60000+e*1000+f*100
if c<1 then let c=5
if t<100 then let t=100
if g<0 then let g=0
if g>1 then let g=1
if p<0 then let p=0
z=t*c
y=p+z

print "1 Cycle Time:", y/60000; "min", y%60000/1000; "sec"

goto "interval"

:interval
  if p>0 then gosub "pause"
  print "Shot 1 of", c
  click "shoot_full"
  for n=2 to c
  sleep t
  print "Shot", n, "of", c
  click "shoot_full"
  next n
  if g=1 then goto "interval" else end

:pause
  n=(a*60)+b
  for m=1 to n
  q=n-m
  print "Intvl Begins:", q/60; "min", q%60; "sec"
  sleep 930
  next m
  return


 

Related Topics