Works USB Remote button in A570 Is ? n/t - AllBest's Builds - CHDK Forum  

Works USB Remote button in A570 Is ? n/t

  • 38 Replies
  • 14687 Views
Works USB Remote button in A570 Is ? n/t
« on: 18 / December / 2007, 01:35:57 »
Advertisements
.

Re: Works USB Remote button in A570 Is ? n/t
« Reply #1 on: 18 / December / 2007, 03:34:03 »
unfortunately remote button doesn't work on a570 for the present moment
« Last Edit: 18 / December / 2007, 05:02:23 by Allbest »

*

Offline Jim

  • *
  • 32
Re: Works USB Remote button in A570 Is ? n/t
« Reply #2 on: 03 / January / 2008, 21:04:02 »
Any update on the remote button for the a570IS?  Definately required for experiments I am working on.

Re: Works USB Remote button in A570 Is ? n/t
« Reply #3 on: 07 / January / 2008, 07:01:20 »
for the time being is not....


Re: Works USB Remote button in A570 Is ? n/t
« Reply #4 on: 07 / January / 2008, 13:01:39 »
If anybody with a camera currently not supporting remote can make some simple tests, then there is a good chance of making a version for the camera. Do the following steps:
- In 'debug parameters' menu activate 'show misc. values'
- exit alt mode.
- Now the screen will show 4 lines of hexadecimal values.
- Connect your USB cable to camera and computer (as you do when downloading pictures from the cam).
- The camera will enter download mode and one of the 4 values will change, indicating the USB 5V.
- Connect and disconnect a few times to be certain what value is changing.
Report the 4 values before and after connection here, then we (I) can make a build for you to download and test.
(Jim, just found out that my ISP lost 30000 peoples email from 1 jan, if you got my email and answered it was lost!.)

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Works USB Remote button in A570 Is ? n/t
« Reply #5 on: 07 / January / 2008, 15:17:04 »
For A570 (not mine!)

#define USB_MASK (0x40000)

and it applies to

usb_power=(physw_status[2] & USB_MASK)==USB_MASK;

Author says: "I have verified it on my A570IS v1.01a.  "

« Last Edit: 07 / January / 2008, 15:18:53 by ewavr »

*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: Works USB Remote button in A570 Is ? n/t
« Reply #6 on: 07 / January / 2008, 16:45:07 »
Quote
- In 'debug parameters' menu activate 'show misc. values'
- exit alt mode.
- Now the screen will show 4 lines of hexadecimal values.
- Connect your USB cable to camera and computer (as you do when downloading pictures from the cam).
- The camera will enter download mode and one of the 4 values will change, indicating the USB 5V.
- Connect and disconnect a few times to be certain what value is changing.
Report the 4 values before and after connection here, then we (I) can make a build for you to download and test.

Okay, here's what debug misc shows on my A570IS 1.00e using Allbest build 16.
I used the playback mode, because in camera rec mode values 1: and 2: are a too lively to keep track of.

No USB, playback mode empty SD card:
1:201cd040 (the first digit is not always the same but doesn't change)
2:fde09cc0 (alternates quite rapidly with the value 'dde09cc0')
3:effe (alternates quite rapidly with the value 'effd')
3:effe (alternates quite rapidly with the value 'effd')

(Yes, there are two lines labeled '3:' on the display, is this a bug?)

USB cable plugged in and connected to a PC (running Linux), playback mode empty SD card:
1:201cd040 (the first digit ('2') is not the same after a reboot but doesn't change with USB cable insertion)
2:fde09cc0 (alternates quite rapidly with the value 'dde09cc0')
3:4effe (alternates quite rapidly with the value '4effd')
3:4effe (alternates quite rapidly with the value '4effd')

ie the two lines labeled '3:' change from effe/effd to 4effe/4effd.

They do change this way in camera mode as well, not just playback.

Re: Works USB Remote button in A570 Is ? n/t
« Reply #7 on: 08 / January / 2008, 17:40:16 »
I have put test builds for G7, a570 and ixus700/sd500 on http://hem.passagen.se/fsmmal/chdk2.html.
I have added remote button to these, anybody interested please test.


*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: Works USB Remote button in A570 Is ? n/t
« Reply #8 on: 08 / January / 2008, 18:26:28 »
Thank you fingalo for the effort.

I tried the a570 1.00e build, but couldn't get the camera to react to USB.

I tried both the example scripts on your page, plugged and unplugged the cable several times (the other end was connected to a computer).

Enabling or disabling "Enable remote (USB)->" on the script settings page had no effect. While the script was running, the debug misc values still changed the way I described earlier.

Re: Works USB Remote button in A570 Is ? n/t
« Reply #9 on: 09 / January / 2008, 19:09:33 »
Sorry, found an error  ;)  and have adjusted the A570 files.

 

Related Topics