Canon IXUS 900 Ti / Powershot SD900 1.00C Port

  • 255 Replies
  • 56576 Views
  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #130 on: 25 / January / 2009, 15:02:29 »
    Advertisements
    I'm having the following problem:
    • If I set the AEL (with or without AFL), scripts like Ultra Intervalometer freeze up after first picture is taken.
    • If I set the AFL only, no problem.
    Any other have the same problem?

  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #131 on: 29 / January / 2009, 01:09:27 »
    Just working with the last beta.

    The only problem i have is that if i take more than one RAw (CRW), then when i try to convert to DNG, it appears that only a little quantity of the pictures taken have info, and most of them appear in blank, or middle capted ...

    Any idea what it happens?

    Those that appear right, if i process them in Photoshop and compare with the processed JPg from the camera ... are quite impressive, although they have some noise... i'll try N.R. for next pictures.

    Regards,

    Angel
    « Last Edit: 29 / January / 2009, 01:11:04 by the_enyel »

    *

    Offline pixeldoc2000

    • ****
    • 355
    • IXUS900Ti 1.00C, IXUS300HS 1.00D
      • pixel::doc homebase
  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #132 on: 29 / January / 2009, 14:03:21 »
    ND filter works fine. I was disappointed there is no real aperture, but oh well. has anyone tried the in camera raw .dng develop ?
    badpixel.lua script does not finish correctly on my cam.
    I think this happens because the script makes 2 images and compare raw files (one is always corrupted on my camera).
    Garbage in <-> Garbage out  :(


    I'm having the following problem:
    • If I set the AEL (with or without AFL), scripts like Ultra Intervalometer freeze up after first picture is taken.
    • If I set the AFL only, no problem.
    Any other have the same problem?
    Haven't tested it...

    Just working with the last beta.

    The only problem i have is that if i take more than one RAw (CRW), then when i try to convert to DNG, it appears that only a little quantity of the pictures taken have info, and most of them appear in blank, or middle capted ...

    Any idea what it happens?
    This was answered before...
    Yes, i know about the raw image corruption... but didn't have the time to look for this issus yet.

    Those that appear right, if i process them in Photoshop and compare with the processed JPg from the camera ... are quite impressive, although they have some noise... i'll try N.R. for next pictures.
    I've noticed this too!
    Looks like canon firmware does quite some processing to reduce noise (and color correction) for JPG images...

    *

    Offline pixeldoc2000

    • ****
    • 355
    • IXUS900Ti 1.00C, IXUS300HS 1.00D
      • pixel::doc homebase
  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #133 on: 01 / February / 2009, 13:53:25 »
    UPDATE

    Beta v19 released. Look at my first Post for download links and change log.


  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #134 on: 02 / February / 2009, 22:13:34 »
    found the force manual flash under extra photo operations, seems to work ok, this is new to CHDK
    must be part of chdk-shell 2.0
    « Last Edit: 02 / February / 2009, 22:15:14 by hnikesch »
    It is better to burn a roll of film than curse the darkness Equip, S100 w/CHDK, SD900 w/CHDK, SD990 w/CHDK & Pentax K2000, Pentax Kr
    Flickr:

  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #135 on: 02 / February / 2009, 23:30:14 »
    pixeldoc2000: thank you for your continuous support.

    v19:
    I tried the set_backlight function but it freeze the SD900.

    Could you look into that?

    Here is a dev thread about the required stubs.
    http://chdk.setepontos.com/index.php/topic,2744.msg25702.html#msg25702

    and a test script (metronom.lua):
    http://chdk.setepontos.com/index.php?action=dlattach;topic=2744.0;attach=2729

    TIA
    -Mike

    *

    Offline pixeldoc2000

    • ****
    • 355
    • IXUS900Ti 1.00C, IXUS300HS 1.00D
      • pixel::doc homebase
  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #136 on: 03 / February / 2009, 13:18:55 »
    found the force manual flash under extra photo operations, seems to work ok, this is new to CHDK
    must be part of chdk-shell 2.0
    I've also tested it, looks like it works fine!
    This feature has been added to chdk source in trunk #698 (SVN).
    CHDK-Shell is a gui frontend to compile chdk source on windows.

    pixeldoc2000: thank you for your continuous support.

    v19:
    I tried the set_backlight function but it freeze the SD900.

    Could you look into that?

    Here is a dev thread about the required stubs.
    http://chdk.setepontos.com/index.php/topic,2744.msg25702.html#msg25702

    and a test script (metronom.lua):
    http://chdk.setepontos.com/index.php?action=dlattach;topic=2744.0;attach=2729
    Thankx!
    Hm, same issus here...
    Looks like script locks the keyboard (chdk itself does not freez),maybe it messes up the keyboard task...
    OK, i'll look for it tonight!

  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #137 on: 03 / February / 2009, 13:47:18 »
    Looks like script locks the keyboard (chdk itself does not freez),maybe it messes up the keyboard task...

    I think it's a bit more than just the keyboard. If you try to take a picture [in your script] after calling set_backlight, nothing will happen.
    The only working thing (that I can see) is the power on/off button  :D
    « Last Edit: 04 / February / 2009, 06:37:17 by MikeXM »


  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #138 on: 12 / February / 2009, 08:59:56 »
    I've a question regarding the ixus 900ti.  Does the current beta version of chdk v19 work with the usb remote control shutter relese circuit i've found metioned on this site which uses a watch battery, switch and mini usb plug. 

    If so what voltage is required and has anyone found or made a wireless version which has a small usb fob to connect to camera and remote button fob to activate the shutter from a distance.  Rf would be better then IR as then you can hold the remote behind your back and be in the photo and it not be seen.

    I came across this site and chdk software researching remote capture for my new ixsus 900ti camera as I've found reports that the remote capture feature which I have used with my old ixus 400 is no longer supported.  I've not confirmed this yet but is this the case and if it is why have cannon stepped backwards. 
    « Last Edit: 12 / February / 2009, 09:01:39 by ricoghardforth »

  • Publish
    Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
    « Reply #139 on: 12 / February / 2009, 12:43:55 »
    I tried it with a single button cell per the CHDK site but no luck I have not tried a higher voltage yet
    « Last Edit: 12 / February / 2009, 19:17:36 by hnikesch »
    It is better to burn a roll of film than curse the darkness Equip, S100 w/CHDK, SD900 w/CHDK, SD990 w/CHDK & Pentax K2000, Pentax Kr
    Flickr:

     

    Related Topics