Canon IXUS 900 Ti / Powershot SD900 1.00C Port - page 5 - General Discussion and Assistance - CHDK Forum  

Canon IXUS 900 Ti / Powershot SD900 1.00C Port

  • 262 Replies
  • 145050 Views
Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #40 on: 26 / November / 2008, 13:25:05 »
Advertisements
My camera is:
Canon DIGITAL IXUS 900TI
P-ID:3115   PAL
Firmware Ver GM1.00C
Jul 24 2006   18:57:34

I could not test the port with my camera, as I could not download it. It just goes in circles offering me to download the file, shows the link, says the download has started, but no actual downloading ever starts.
Please, upload the file somewhere else.

I can't do any programming, but I'm willing to test and report. I could donate something to the beer clear water fund though. :)

All the best,
Vladimir

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #41 on: 26 / November / 2008, 13:37:59 »
Canon DIGITAL IXUS 900TI
Firmware Ver GM1.00C

I could not test the port with my camera, as I could not download it.

Attached to this post (executables only).

*

Offline pixeldoc2000

  • ****
  • 356
  • IXUS900Ti 1.00C, IXUS300HS 1.00D
    • pixel::doc homebase
Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #42 on: 26 / November / 2008, 18:37:36 »
Sorry, but i forgot to mention beta v4 port does nothing fancy besides switch Direct Print Led (Blue) on.
This version still does not boot yet.
Source and binary firmware is included.

UPDATE
As requested by "tailgate" via pm i've uploaded the current source. Grab it here: chdk_sd900_100c_trunk579_pd_beta_v4_20081125.7z - 3.09MB.

Maybe together we will get this port to work... Looking forward to some usefull input  ;) .

NOTE:
  • trunk579\platform\generic\main.c
    i've disabled some functions, even this stuff should be correct, but i can't test it yet.
  • trunk579\platform\ixus900_sd900\sub\100c\boot.c
    i've commented where camera stops...

Keep on CHDKing folks!

THIS IS NOT OF ANY USE IF YOU ARE NOT A DEVELOPER.

I've uploaded it to share it with other developers.

I could not test the port with my camera, as I could not download it. It just goes in circles offering me to download the file, shows the link, says the download has started, but no actual downloading ever starts.
Please, upload the file somewhere else.
Sadly today looks like the same here. Can't download it... So it uploaded it somewhere else. Hopefully this will work properly...

I can't do any programming, but I'm willing to test and report. I could donate something to the beer clear water fund though. :)
You are welcome, but: i don't want to wash my hands, i want a drink!
so...
I can't do any programming, but I'm willing to test and report. I could donate something to the beer clear water fund though. :)

Canon DIGITAL IXUS 900TI
Firmware Ver GM1.00C

I could not test the port with my camera, as I could not download it.
Attached to this post (executables only).
Thank you very much!
Maybe you could have a look at it sometime ? I know, this isn't very nice without the camera at your hands, but maybe it's just a small but brutal error or maybe i've missed an important thing...

Mirror Megaupload: chdk_sd900_100c_trunk579_pd_beta_v4_20081125.7z.

Keep on CHDKing folks!
« Last Edit: 26 / November / 2008, 18:48:15 by pixeldoc2000 »

Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #43 on: 27 / November / 2008, 00:03:52 »
great to hear your still tinkering away at this,

i would try again with the beta but have recently lost ability to write to a sd card that is not inside the camera.

im interested to see if i can have it actually do something this time
canon powershot sd900 ti
canon digital ixus 500
canon powershot s400
flickr


Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #44 on: 27 / November / 2008, 04:02:11 »
Thank you, ewavr and pixeldoc2000. I have successfully downloaded the files and will test it just as I get home.

Sorry, but i forgot to mention beta v4 port does nothing fancy besides switch Direct Print Led (Blue) on.
This version still does not boot yet.
...
THIS IS NOT OF ANY USE IF YOU ARE NOT A DEVELOPER.

I've uploaded it to share it with other developers.
Well, that's perfectly okay with me, a non-developer. I would certainly benefit of what you, guys, do, so I just hope I can be of some use to you as a tester or something.

You are welcome, but: i don't want to wash my hands, i want a drink!
so...
I can't do any programming, but I'm willing to test and report. I could donate something to the beer clear water fund though. :)
Alright. I'm glad you don't have a shortage of drinking water. :)

Stay fine,
Vladimir

*

Offline pixeldoc2000

  • ****
  • 356
  • IXUS900Ti 1.00C, IXUS300HS 1.00D
    • pixel::doc homebase
Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #45 on: 27 / November / 2008, 13:09:47 »
great to hear your still tinkering away at this,
Now it's a personal thing between me and my cam...  >:(

i would try again with the beta but have recently lost ability to write to a sd card that is not inside the camera.
try to use Beta v1, not v4. look at first post Canon IXUS 900 Ti / Powershot SD900 1.00C Port . Maybe your SD-Card is messed up/broken?

im interested to see if i can have it actually do something this time
??? ?
« Last Edit: 27 / November / 2008, 13:15:17 by pixeldoc2000 »

Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #46 on: 27 / November / 2008, 17:20:25 »
try to use Beta v1, not v4. look at first post  Maybe your SD-Card is messed up/broken?

no no, i mean i got burgled. they took my laptop which was my only dedicated sd card reader. meaning i could modify the information on it without it needing to be inside the camera, connected by usb.

??? ?
i tried... a month or two ago to load up your beta. and nothing happened. just saying im interested to see if the current version will blink the light on mine yet.

canon powershot sd900 ti
canon digital ixus 500
canon powershot s400
flickr

*

Offline pixeldoc2000

  • ****
  • 356
  • IXUS900Ti 1.00C, IXUS300HS 1.00D
    • pixel::doc homebase
Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #47 on: 21 / December / 2008, 04:42:35 »
UPDATE

finaly i was able to get chdk to boot!!!

boot.c corrected ... (what a stupid mistake)
Code: (c) [Select]
void boot() {
    long *canon_data_src = (void*)0xFFB6DA40;   // ROM:FF810104
    long *canon_data_dst = (void*)0x1900;   // ROM:FF810108
    long canon_data_len = 0xCC00;   // ROM:FF8100F8
    long *canon_bss_start = (void*)0xE500;   // ROM:FF810130
    long canon_bss_len = 0xA4D10 - 0xE500;   // ROM:FF810134 (MEMISOSTART - canon_bss_start)
    long i;
fixed some more stuff...

kbd.c is not correct and disabled...

chdk starts, shows its bootlogo but keys do not work yet!

more to come soon, if i get kbd.c fixed...

Download Beta v5. Look at my first Post.
« Last Edit: 28 / December / 2008, 05:53:32 by pixeldoc2000 »


Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #48 on: 22 / December / 2008, 09:01:22 »
great news, good luck
It is better to burn a roll of film than curse the darkness Equip, S100 w/CHDK, SD900 w/CHDK, SD990 w/CHDK & Pentax K2000, Pentax Kr
Flickr:

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Canon IXUS 900 Ti / Powershot SD900 1.00C Port
« Reply #49 on: 22 / December / 2008, 16:19:29 »
nice progress pixeldoc, keep up the good work :)

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal