Ixus 40 / SD300 v1.00k - beta version available :) - page 10 - General Discussion and Assistance - CHDK Forum

Ixus 40 / SD300 v1.00k - beta version available :)

  • 102 Replies
  • 48853 Views
Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #90 on: 02 / March / 2009, 10:37:51 »
Advertisements
In CHDK bugtracker DNG support for ixus40 was requested, but bugtracker is down now.
Can somebody, who have this camera:
 - install build #715 or later
 - shoot RAW and upload RAW-JPEG pair somewhere (good focused and good exposed)?

Hi ewavr, I've tried my best in this weather ... Here are the results:
http://www.zshare.net/download/564084991ae8a1f1/
Hope that helps?
Thanks a million!


*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #91 on: 02 / March / 2009, 13:08:21 »
Thanks, DNG support is added for ixus40 in #716 (all DNG setting are copied from latest DNG4PS2).

note: due to strange file capt_seq.c for this camera, creation time in DNG EXIF may differ from JPEG EXIF (for >1s exposures).

Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #92 on: 02 / March / 2009, 17:24:19 »
Thanks, DNG support is added for ixus40 in #716 (all DNG setting are copied from latest DNG4PS2).


wow, that was quick! Thanks a lot! However ... it seems I cannot open my new DNG files in Adobe Camera Raw (CS4). Could that be possible? Anybody else with the same difficulties?

If I use DNG4PS2 instead, everything's fine (but that doesn't exist for my mac, or at least, there is no version that converts ixus 40 images yet ... damn complicated)

Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #93 on: 02 / March / 2009, 17:34:09 »


*

Offline fe50

  • ******
  • 3134
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #94 on: 02 / March / 2009, 18:01:34 »
Tested the DNG with PS3 & PS4 (Windows version): EOF error on both.
Paint.NET, XNView & Google Picasa opens the DNG without any messages...

UFRaw 0.15 gives an "unexpected end of file" error, too - but then it shows the image, here's the UFRaw log:

ufraw_open: w:2344 h:1752 curvesize:0
EXIF data read using exiv2, buflen 844
Warning: Directory SubImage1, entry 0x0111: Strip 0 is outside of the data area; ignored.

Loading Canon  image from C:\Dokumente und Einstellungen\xxxxxxxx\Desktop\Downloads\DNG\CRW_0007.DNG ...
Black: 31, Maximum: 1023
C:\Dokumente und Einstellungen\xxxxxxxx\Desktop\Downloads\DNG\CRW_0007.DNG: Unexpected end of file
Scaling with black 31, multipliers 0,315392 0,330489 1,000000 0,328192

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #95 on: 02 / March / 2009, 18:09:18 »
However ... it seems I cannot open my new DNG files in Adobe Camera Raw (CS4). Could that be possible?

Oops! DNG file is too short. Must be fixed in #717.
Hmm, I see that camera name is not present in DNG file. But I cannot fix it without camera. Strange camera, strange CHDK port for it.

edit: Maybe best tool for DNG validating is Adobe dng_validate (for Mac & Win, with sources) - part of Adobe SDK.

edit2: DAMN! Final fix - in #718.
« Last Edit: 02 / March / 2009, 18:25:02 by ewavr »

Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #96 on: 04 / March / 2009, 17:02:53 »
ewavr, you rock! Now this works! Thank you sooooooooo much!  :D

Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #97 on: 09 / June / 2009, 08:09:39 »
I have ixus40_sd300-100k-0.9.8-766-full and I'm unable to save photo in RAW (The blue led blinks but I get only JPG, no RAW :( ).

And another RAW problem.. I tried to enable the DNG RAW mode and it asked to run the badpixel.lua script to generate the badpixel.bin file.

The script displays "Please wait, do not panic...". I waited for a minute or two and turned off the camera. No badpixel.bin file was generated.

Does anyone have problems with this firmware version too?

Can anyone please post the 718 version for the K firmware here? (Cannot find it with Google..)
« Last Edit: 09 / June / 2009, 08:25:58 by EforeZZ »


*

Offline fe50

  • ******
  • 3134
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #98 on: 09 / June / 2009, 08:28:01 »
I have ixus40_sd300-100k-0.9.8-766-full and I'm unable to save photo in RAW (The blue led blinks but I get only JPG, no RAW :( ).
Use a card reader; check all folders on your SD card, dependent from your CHDK settings the RAW files are stored in a different folder as the JPGs (e.g. 100CANON or 000CANON); it's adjustable in the CHDK RAW menu, menu item "RAW File in Dir with JPEG".

Quote
And another RAW problem.. I tried to enable the DNG RAW mode and it asked to run the badpixel.lua script to generate the badpixel.bin file.
The script displays "Please wait, do not panic...". I waited for a minute or two and turned off the camera. No badpixel.bin file was generated.
Does anyone have problems with this firmware version too?

Have a look to this post:
I'm trying to enable the DNG format on my Ixus 40 (SD300) v1.00k, but it keeps throwing my the error:
...
I've run the badpixel.lua script three times now, and confirmed that a badpixel.bin file actually does exist in the CHDK folder.  The script reports 0 bad pixels; and the resultant badpixel.bin file is 0 bytes long.
Trawling the forums and google doesn't reveal any solutions other than running the script -- which I've done...
If you're running a Windows system you can create the badpixel.bin file manually with ewavr's show_bad_b.exe: CHDK wikia: Badpixel_removal.

Since the show_bad_b zip package includes the C source code, you should also be able to compile it on other operating systems like Mac OS, e.g. with the GCC...

Re: Ixus 40 / SD300 v1.00k - beta version available :)
« Reply #99 on: 09 / June / 2009, 09:16:52 »
The CRW problem:
Use a card reader; check all folders on your SD card, dependent from your CHDK settings the RAW files are stored in a different folder as the JPGs (e.g. 100CANON or 000CANON);
Used a card reader to check the filesystem on the card and to search for *.CRW. Found nothing.

it's adjustable in the CHDK RAW menu, menu item "RAW File in Dir with JPEG".
Tried toggling this option. No effect.



And the DNG problem:
I'm trying to enable the DNG format on my Ixus 40 (SD300) v1.00k, but it keeps throwing my the error:
...
I've run the badpixel.lua script three times now, and confirmed that a badpixel.bin file actually does exist in the CHDK folder.  The script reports 0 bad pixels; and the resultant badpixel.bin file is 0 bytes long.
Trawling the forums and google doesn't reveal any solutions other than running the script -- which I've done...
If you're running a Windows system you can create the badpixel.bin file manually with ewavr's show_bad_b.exe: CHDK wikia: Badpixel_removal.

Since the show_bad_b zip package includes the C source code, you should also be able to compile it on other operating systems like Mac OS, e.g. with the GCC...
I used the show_bad_b and it showed 0 bad pixels on all my CRW files and created the 0-bytes long badpixel.bin.
I created the 0-bytes long badpixel.bin file in CHDK directory. Now it says it cannot load the "CHDK/badpixel.bin" file while the file itself exists.
« Last Edit: 09 / June / 2009, 12:22:19 by EforeZZ »

 

Related Topics