Ixus 860... - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Ixus 860...

  • 16 Replies
  • 4516 Views
*

Offline ano

  • *
  • 32
Ixus 860...
« on: 05 / August / 2008, 10:49:55 »
Advertisements
Hello,

I just got an Ixus 860. It has GM1.00C firmware.
I got CHDK from Index of /chdk/.

My card looks like:
# fdisk -l /dev/sdg

Disk /dev/sdg: 31 MB, 31129600 bytes
4 heads, 32 sectors/track, 475 cylinders
Units = cylinders of 128 * 512 = 65536 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdg1   *           1         475       30374+   4  FAT16 <32M

and contains the diskboot.bin from the zip.

I start the camera by pressing play.
The menu does NOT have the firmware update option.
What am I doing wrong?

Kind regards,
Ano

Re: Ixus 860...
« Reply #1 on: 05 / August / 2008, 11:21:01 »
The menu does NOT have the firmware update option.
What am I doing wrong?

Nothing, it does not support the firmware-update method.

Just lock your card and it should work OK.


David

*

Offline ano

  • *
  • 32
Re: Ixus 860...
« Reply #2 on: 05 / August / 2008, 11:26:56 »
Yes, DryOS method as well as the bootdisk hexedit?
At least now I did see a CHDK banner flash by...

Thanks!

*

Offline fe50

  • ******
  • 3123
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Ixus 860...
« Reply #3 on: 06 / August / 2008, 03:35:04 »
Hi ano,

you should use the latest Autobuild version, many issues are solved now (touch icons, boot time, multi partition support...)  & new features (e.g. video settings) are included !

You can also try the Juciphox build with many new enhancements, works fine on the SD870 (thx jucifer, PhoX & the others) !


*

Offline ano

  • *
  • 32
Ixus 860 and Linux...
« Reply #4 on: 07 / August / 2008, 12:25:24 »
The new version works well, even on 8GB SDHC with dual partitions.
Tahnks.

Remaining problem is connecting the Ixus 860 to a Linux machine. dmesg says me:
usb 1-4: new high speed USB device using ehci_hcd and address 21
usb 1-4: configuration #1 chosen from 1 choice

when I attach the camera.
gphoto2 doesn't detect a cam.

What needs more configuration?
« Last Edit: 07 / August / 2008, 12:26:58 by ano »

*

Offline Hacki

  • ****
  • 358
  • SX100
Re: Ixus 860...
« Reply #5 on: 07 / August / 2008, 13:51:22 »
USB remote is enabled by default. That means CHDK prevents the camera from getting 'used' over the PTP protocol.

Go to the CHDK menu in your camera, open Scripting parameters, go to Remote paramteres, and unselect the "Enable Remote" stuff. (Possible that in trunk theres no "Remote parameters" submenu, but the Enable remote will be directly in the scripting parameters menu). Then turn your cam off, connect it to USB and start it in playback mode. Should work now, at least it did for me.


*

Offline ano

  • *
  • 32
Re: Ixus 860...
« Reply #6 on: 08 / August / 2008, 08:47:29 »
Thanks for the reply.
Enabling the Remote makes the dmesg infos (when i attach the camera) disappear.
They do come again when I disable the remote.
For the rest it still doesn't work.
lsusb doesn't show the cam either.
Any ideas?

*

Offline Hacki

  • ****
  • 358
  • SX100
Re: Ixus 860...
« Reply #7 on: 08 / August / 2008, 09:27:34 »
Oh, well. Normally it should work if usb-remote stuff is disabled.

Which application are you using to access the cam? Does it spit out some error messages? Does PTP even work without CHDK? Normally it should not interfere with the PTP stuff, as long as USB remote is disabled..






*

Offline fe50

  • ******
  • 3123
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Ixus 860...
« Reply #8 on: 08 / August / 2008, 11:21:41 »
ano,
on which version  ?
Juciphox has also scriptless USB support, this must be disabled, too !

*

Offline ano

  • *
  • 32
Re: Ixus 860...
« Reply #9 on: 09 / August / 2008, 00:17:43 »
ano,
on which version  ?
Juciphox has also scriptless USB support, this must be disabled, too !

I use allbests's build.
Do I need specific Linux kernel modules for being able to access the Ixus?

Now I connect the cam and turn on play mode. no usb device becomes visible in `lsusb`
Only these
usb 1-7: new high speed USB device using ehci_hcd and address 38
usb 1-7: configuration #1 chosen from 1 choice

« Last Edit: 09 / August / 2008, 01:18:16 by ano »

 

Related Topics