Startup sound freezes S2 IS (Juciphox build) - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Startup sound freezes S2 IS (Juciphox build)

  • 4 Replies
  • 2189 Views
Startup sound freezes S2 IS (Juciphox build)
« on: 13 / August / 2008, 13:31:49 »
Advertisements
Hi,

Enabling the startup sound in the latest 'Juciphox' builds locks up my S2 IS.

I also tried to use to play the different sounds via a script command, but with the same result.

Is this a known error ?

Greetings from Amsterdam

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Startup sound freezes S2 IS (Juciphox build)
« Reply #1 on: 13 / August / 2008, 15:13:42 »
which firmware of the s2is you got exactly? maybe i extracted the wrong adresses (of the sound function) from the firmware dump

Re: Startup sound freezes S2 IS (Juciphox build)
« Reply #2 on: 13 / August / 2008, 15:23:17 »
FYI: it is FW 100e

Freeze =  lens retracks & camera stops.
Enabling the startup sound is more inconvenient as this setting is saved and CHDK won't startup...

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Startup sound freezes S2 IS (Juciphox build)
« Reply #3 on: 13 / August / 2008, 16:53:40 »
my bad, wrong adress extracted from the firmware.

attached is a new build, will check in the code so that the autobuild will have the new adress as well.

please report if it works.


Re: Startup sound freezes S2 IS (Juciphox build)
« Reply #4 on: 14 / August / 2008, 01:00:26 »
Goodmorning,

Tada! I'm glad:
the new build produces the proper sounds on the S2IS.

Thanks & best regards from Amsterdam

 

Related Topics