A550 Porting... - page 3 - General Discussion and Assistance - CHDK Forum

A550 Porting...

  • 95 Replies
  • 39574 Views
Re: A550 Porting...need help
« Reply #20 on: 25 / January / 2008, 13:02:33 »
Advertisements
Hi all, I've been away from this forum for a while, and now I no longer understand what's happening...
The last thing I did was to modify files as muttley said, and in the end my camera swithced off every time I started the firmware upgrade. Now I've seen the post where muttley said that chdk was working, but on the wiki there's "porting process is blocked". Do somebody know what to modify in capt_seq.c to run the chdk??

Re: A550 Porting...need help
« Reply #21 on: 25 / January / 2008, 13:17:14 »
<snip>
Do somebody know what to modify in capt_seq.c to run the chdk??
</snip>

Thats what I'm looking for also, I got to the same point that you have, except I have no camera to test on right now, and capt_seq.c seems very confusing to me.

Muttley said:
"THANK ROSSIG, for all support !!"

Maybe we need to find who ROSSIG is?
« Last Edit: 28 / January / 2008, 10:23:33 by JTLG »

Re: A550 Porting...need help
« Reply #22 on: 26 / January / 2008, 04:27:57 »
I'm an A550 user and I'd be glad to help test out. Unfortunately, I don't have any experience in coding or compiling so please post some of your compiled work and I can try it out.

Re: A550 Porting...need help
« Reply #23 on: 26 / January / 2008, 14:46:28 »
http://rapidshare.com/files/86842785/Archive.zip

I highly doubt that this will work, due to not having the capt_seq.c issue taken care of, but its worth a shot, let me know what you get, until my camera gets back, I cant test any progress I may make.

Thanks, the .fir file may have to be renamed to match what the camera looks for.


Re: A550 Porting...need help
« Reply #24 on: 26 / January / 2008, 17:39:10 »
I've tested ...camera switched off. No led blinking ...nothing. Not working.

Re: A550 Porting...need help
« Reply #25 on: 26 / January / 2008, 18:12:34 »
NOW CHDK RUN!!  :D :D :D

...the problem was capt_seq.c, nobody say me it's necessary for start...and there isn't doc that say this!

THANK ROSSIG, for all support !!

now...another problem: i can't enter in ALT mode...eheheh, is there a function o part of code that i can view for resolve problem? 

Can someone include this file and recompile?

I believe problem with this file is only its absence, all needed is to "include" it somewhere and recompile. Or put it at the boot. Whatever...

btw god knows what "ALT mode" is...

Re: A550 Porting...need help
« Reply #26 on: 26 / January / 2008, 23:11:11 »
ALT mode is the mode you're in when CHDK is in effect. You open it by pressing the print button (blue led on A550) which opens up a bunch of menus where you can do all the adjustments. Apparently, Muttley was able to get CHDK running but couldn't enter ALT mode which is practically the main part of CHDK. Booting it doesn't seem to be a problem anymore but the actual operation of CHDK.

*

Offline muttley

  • **
  • 51
  • + pilu x tutti!
    • A550 Porting
Re: A550 Porting...need help
« Reply #27 on: 27 / January / 2008, 13:48:56 »
WWWAOOOooooo!!!!!!

The comunity is alive!!   :D  :D

...i had starting to think that a550 porting don't interesting anyone!

There are still "good people"!! ...but not good programmers  :P  ...I hope good testers!!

Sorry guys, but i was busying with my work...

I see your hard work for take to end the porting !

...I hoped someone of folk (programmer had just porting) said me how to resolve ALT-mode problem...
And Rossig help me again!!

Now you have to help me for find all problems, bugs and strange behaviors of Canon with my CHDK porting...and there are many!

I'll make just some revision and coming soon I'll post binary on ZShare!


Re: A550 Porting...need help
« Reply #28 on: 27 / January / 2008, 18:00:23 »
Hell yeah!  :D :lol :xmas

Dude, you rock.

Thank you. Great.  :)

Re: A550 Porting...need help
« Reply #29 on: 27 / January / 2008, 22:10:25 »
but not good programmers

I'm definitely not a good programmer lol.
I can manage to fix what prevents me from compiling something, but thats about it.

Glad to see you're making progress, my cam will be back tomorrow, waiting for that binary to test!
« Last Edit: 28 / January / 2008, 10:25:53 by JTLG »

 

Related Topics