supplierdeeply

A590IS porting...

  • 948 Replies
  • 166618 Views
  • Publish
    Re: A590IS porting...
    « Reply #120 on: 22 / October / 2008, 19:23:47 »
    Advertisements
    Thanks. Will try it out tonight and see how it goes.

  • Publish
    Re: A590IS porting...
    « Reply #121 on: 22 / October / 2008, 20:05:43 »
    Many Tnx!
    After this i have ordered my new A590 ;)
    see you on HwUpgrade Forum

    *

    Offline harpman71

    • *
    • 16
    • Happy when it rains
  • Publish
    Re: A590IS porting...
    « Reply #122 on: 22 / October / 2008, 21:09:54 »
    Hi, I am testing this great software. Here I put the file with the translation into Spanish language. 8)

  • Publish
    Re: A590IS porting...
    « Reply #123 on: 22 / October / 2008, 21:52:50 »
    Just tried on a 1.01b camera -- having problems with the RAW files. Gimp tried with both dcraw and ufraw plugins gives me problems, whether used as plugins or command-line tools (Linux: Ubuntu Hardy Heron, BTW)

    ufraw reports: unsupported file format
    dcraw reports: Cannot decode file (filename)

    I'm using the default RAW options from the a590is-101b-0.6.2-full version, which I believe is the latest.

    I can upload a sample RAW if someone else would like to have a go at it;

    --------------

    UPDATE: Hardy Heron comes with dcraw 8.80, which is too old to process the RAW files from this camera.

    I downloaded  dcraw 8.88 (from the dcraw homepage: Decoding raw digital photos in Linux) and built it, and it's working fine! WOOHOO!
    « Last Edit: 22 / October / 2008, 22:28:34 by 5MeoCMP »


  • Publish
    Re: A590IS porting...
    « Reply #124 on: 23 / October / 2008, 03:20:47 »
    Greetings,

    Trying out 0.6.2 on my 101b A590is .. everything I've tried so far appears to be working.  dcraw 8.88 can handle the .CRW raw images as 5MeoCMP has stated above .. I'm experiencing an odd behaviour, though..

    I currently lack a card reader at home, so I'm plugging the camera directly in via USB.  I realise this in itself may be causing the oddity [and honestly, WHY did Canon omit a plain USB storage device mode!?].  What happens is .. plugging the camera in [in 'play' mode] usually shows only the JPEG images stored on the card.  Successive power on/off and plug/unplugs will get it to show some or all of the RAW images as well.  It appears to be random as to what it's going to let you see. 

    I know I can avoid this altogether by using a card reader, I'm just curious to see if anyone else is experiencing the same thing.

    Kudos to all involved in this project, and THANK YOU, thank you thank you for helping turn my $135CAD bargain camera into a raw-capable unit! 

  • Publish
    bracketing ?s
    « Reply #125 on: 23 / October / 2008, 03:46:23 »
    Maybe I have some settings wrong, but I am having no luck with bracketing.  The first shot seems to hang the camera.  I don't know if this has to do with the image checking that occurs with normal 590IS use when holding the shutter button, but I am only able to shoot one image when I try to bracket.

    Thanks in advance for any help.  (101b version)

    *

    Offline 73113

    • *
    • 25
    • Canon Powershot A590 IS
  • Publish
    Re: A590IS porting...
    « Reply #126 on: 23 / October / 2008, 04:16:29 »
    Wow this thread has suddenly exploded :D It's good to see!
    Time to start messing around with chdk, will post if I find something useful

    Great work!

    (hehe us 101b's outnumber 1e's 3 to 1 :P )
    « Last Edit: 23 / October / 2008, 04:23:33 by 73113 »
    getting started with chdk Basic articles

  • Publish
    Re: A590IS porting...
    « Reply #127 on: 23 / October / 2008, 04:58:44 »
    Thanks to everyone involved in this.

    One question. Is aperture override available or have I missed something obvious?

    Thanks again

    In the manual, the option is shown... but I couldn't find it in the menu


    *

    Offline ma_jk

    • **
    • 60
  • Publish
    Re: A590IS porting...
    « Reply #128 on: 23 / October / 2008, 06:14:13 »
    Thanks to everyone involved in this.

    One question. Is aperture override available or have I missed something obvious?

    Thanks again


    In the manual, the option is shown... but I couldn't find it in the menu

    Its disabled for the moment. Someone should report if this camera has iris diaphragm and/or ND Filter..

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: A590IS porting...
    « Reply #129 on: 23 / October / 2008, 06:26:03 »
    @ma_jk

    Quote
    Its disabled for the moment. Someone should report if this camera has iris diaphragm and/or ND Filter..

    i'm not sure if this actually means A590 has an iris diapfagm, but searching the trings in the 100e dump i found this:

    Quote
    ....
    0010A7D4   0010A7D4      0   FocusLensController.c
    0010A7F8   0010A7F8      0   FocusLens
    0010C0B8   0010C0B8      0   IrisController.c
    0010D488   0010D488      0   MechaDeviceController.c
    0010DEE8   0010DEE8      0   MechaShutterDriver.c
    ....

    edit: there's references to NDFilter as well, but no '.c' file reference for NDFilter

    wim


    edit2: forget this -- the newer ixus dumps have IrisController.c as well, even though ixuses don't have iris
    « Last Edit: 23 / October / 2008, 06:38:25 by whim »

     

    Related Topics