A590IS porting... - page 63 - DryOS Development - CHDK Forum supplierdeeply

A590IS porting...

  • 968 Replies
  • 397699 Views
*

Offline mngc

  • ***
  • 113
  • a590is fw 1.0.1b & sx110is fw 1.0b
Re: A590IS porting...
« Reply #620 on: 10 / June / 2009, 01:24:43 »
Advertisements
A590 has good record and playback zebra, (for example, when half press sutter button), histograms, The zebra is blinking, if set to blink. I not sure, your problem this, but test it, disable zebra, disable histogram. The problem exist? 

thanks reyalp!

build a590-101b-0.9.8-772 : I thing some bugs with OSD display- while half pressing the shutter, the OSD flashes on and off, as well the original firmware's 2:3 grid lines. The problem more obvious with build a590-101b-0.9.8-770 (after half-pressing the shutter multiple times). This also occurs with build 758 & 769

Already reported in Bugs Report thread. http://chdk.setepontos.com/index.php/topic,265.105.html

*

Offline mngc

  • ***
  • 113
  • a590is fw 1.0.1b & sx110is fw 1.0b
Re: A590IS porting...
« Reply #621 on: 10 / June / 2009, 08:37:12 »
Some more exist problem on a590 is, fw 1.0.1b:

- in video mode, bitrate setting not working, adjustable, but no effect (approx. same size video record)
- in video mode, quality setting not working, adjustable, but no effect (approx. same size video record)
- in video mode, af key set to "set" and try it, not working, no refofus

Testing questions, dof calculator is ok? I think not ok, comment another users? i don't understand all labels, what is it a subject distance? Near limit? Far Limit? But, set manual focus mode, and focus to 5cm, i see all dof messages, S/R1/R2 .104/.100/.108 dof/hyp .008/2.51

Re: A590IS porting...
« Reply #622 on: 11 / June / 2009, 17:38:56 »
Quote
This cannot be correct, I haven't changed anything related to screen updating.

Yeah it was my mistake. It also happens with ur build. I notice this thing happen when shooting DNG.. In normal shooting (non-RAW) it doesn't occur

Quote
A590 has good record and playback zebra, (for example, when half press sutter button), histograms, The zebra is blinking, if set to blink. I not sure, your problem this, but test it, disable zebra, disable histogram. The problem exist? 

No, it has nothing to do with zebra setting. When shooting RAW, the 2:3 grid is blinking (the one i enabled in canon setting menu)..
« Last Edit: 11 / June / 2009, 17:45:07 by 3belas »

*

Offline reyalp

  • ******
  • 14085
Re: A590IS porting...
« Reply #623 on: 11 / June / 2009, 19:11:57 »
Quote
This cannot be correct, I haven't changed anything related to screen updating.

Yeah it was my mistake. It also happens with ur build. I notice this thing happen when shooting DNG.. In normal shooting (non-RAW) it doesn't occur
No, it has nothing to do with this. It's unpredictable.
Don't forget what the H stands for.


Re: A590IS porting...
« Reply #624 on: 28 / June / 2009, 13:39:13 »
I'm new here, I have an 590IS with 1.01B firmware.

Maybe, only I'm who have this problem, but my RAW files are 1/4 size of the original 8Mpixels pictures. (half X and half Y -> 2Mpixel )
I tried to change settings in RAW menu, but I can't find any option related to RAW resolution.

The correct CHDK version is on the SD card. ( unpacked a590-101b-0.9.8-779-full.zip )

My RAW files are 10341600 Bytes size. I think, for 8M it would be 4x size of this, somewhere in the 40MB range.

The newest IrfanView can decode CRW files, it reports 1649x1236 and 24 bits per pixel and shows a 2Mpixel size picture.
The newest UFRaw reports 3298x2472 for the CRW file, but can't show the picture in 1:1 size, 1:2 (50%) is the maximum. The zoom button simply doesn't work over 50% in UFRaw for me.
The jpg files at the same time has 8Mp (3264 x 2448) resolution.

For detailed macros, unfortunatelly the 8M jpg's are better (in some aspect) than 2M raw :(

Hope, somebody can help me ! (sorry for my bad english)
Anyway the the solution exist or not, thank you for the tremendous work !!!  ::)
« Last Edit: 28 / June / 2009, 14:59:42 by Aklankrisz »

*

Offline reyalp

  • ******
  • 14085
Re: A590IS porting...
« Reply #625 on: 28 / June / 2009, 16:35:11 »
Maybe, only I'm who have this problem, but my RAW files are 1/4 size of the original 8Mpixels pictures. (half X and half Y -> 2Mpixel )
No, the raw is the correct size. What you are missing is that raw pixels are individual bayer filter elements, not RGB pixels. When the camera demosaics it interpolates this to an 8 million RGB pixel image. The raw is exactly the same data that the canon firmware uses to create the JPEG.

Some programs display the raw with a less sophisticated method, just taking 4 raw pixels and converting it to a single RGB pixel. Then you see a 1/4 resolution image.
Don't forget what the H stands for.

*

Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: A590IS porting...
« Reply #626 on: 29 / June / 2009, 07:15:06 »
They have about 2 megapixels, compared to 8 megapixels in the jpeg files. I do not think it's a probem of "Raw Photo Processor",
Many viewers / image processing tools shows either 1/2 the image or only a small thumbnail of RAW files by default due to performance/faster response...e.g. in XNView: "Camera RAW: half size / full size / thumbnail only"

Re: A590IS porting...
« Reply #627 on: 01 / July / 2009, 04:59:52 »
Thank You for replies, UFRAW seems to show only 1/2 size, but saved files are full resulution images.
Yes, IrfanView shows half size as a default option. (Options/Properties-Settings/Plugins/ "load half size image"

And just for FUN, the number of unique colors on the same image with different Interpolation:
UFRaw Bilinear - 1.533.763
UFRaw PPG - 1.411.701
UFRaw AHD - 1.400.081
UFRaw VNG - 1.330.111
UFRaw VNG four Color - 1.294.759
Photoshop Lightroom 2.4 (auto WB) - 1.025.349
JPG by Camera highest quality - 493.835

It seems, that the A590IS makes sharpening and remove the color fringing quickly before encode it to jpg...


*

Offline dvip

  • ****
  • 451
Re: A590IS porting...
« Reply #628 on: 11 / July / 2009, 00:18:26 »
When using CHDK (a590-101b-0.9.8-783-full.zip) after 60+ images
or so my A590IS (4GB) crashes. The only way to bring it back
is by removing the batteries. Without CHDK It can take all
the pictures I want but I need RAW and all the cool CHDK things.
Any solution?

*

Offline reyalp

  • ******
  • 14085
Re: A590IS porting...
« Reply #629 on: 16 / August / 2009, 23:34:44 »
I've added full multi-partition support. See http://chdk.setepontos.com/index.php/topic,2798.15.html

This will be on the autobuild shortly, version 789 or later. Since I don't have this camera, I'm relying on a590 users to report if this breaks something horribly.

This is not related to dvips post. Not sure what's going on there, would be good to know if any other a590 users have seen the same issue.

Don't forget what the H stands for.

 

Related Topics