A590IS porting... - page 68 - DryOS Development - CHDK Forum supplierdeeply

A590IS porting...

  • 968 Replies
  • 397690 Views
*

Offline dvip

  • ****
  • 451
Re: A590IS porting...
« Reply #670 on: 27 / October / 2009, 18:16:29 »
Advertisements
@whim, the same, the camera won't turn on with it.

*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A590IS porting...
« Reply #671 on: 27 / October / 2009, 19:28:39 »
@whim, the same, the camera won't turn on with it.

That truly weird - is this only the last 2 versions i posted ? I mean, does yesterday's 6-6 still work ? Does the cam boot
'normal Canon style' if you remove write lock ?
Me, i just copied the diskboot.bin over previous version and have just retested it booting in both play & shoot mode;
i've also verified the time stamp, Oct 27, 22:47

keep me posted,

wim

*

Offline dvip

  • ****
  • 451
Re: A590IS porting...
« Reply #672 on: 27 / October / 2009, 20:47:18 »
Whim,
Yes, it's weird. Even 6-6 from yesterday doesn't work now
either.

I tested all of them again and even deleted Cchdk.cfg and
badpixel.bin to see if that was the problem but nothing.

The cam works fine 'normal Canon style', no problem there. And
I installed CHDK a590-101b-0.9.8-822-full back again and it
works fine too.

It just doesn't want to turn on and boot with the diskboot.bin we
are testing. Feel free to send another one or let me know if I
need to delete or reset something with the new diskboot.bin.


*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A590IS porting...
« Reply #673 on: 27 / October / 2009, 21:55:59 »
@dvip

maybe check your card in CardTricks, if it's still bootable, or try a fresh format ?
off to sleep now, maybe that brings more ideas ...

later

wim


*

Offline dvip

  • ****
  • 451
Re: A590IS porting...
« Reply #674 on: 27 / October / 2009, 22:07:01 »
@whim,
I'll give that a try. But if it was a boot problem
it wouldn't boot and work with the a590-101b-0.9.8-822-full.zip
at http://mighty-hoernsche.de/
It works with that one without problems.

Good night!


*

Offline reyalp

  • ******
  • 14085
Re: A590IS porting...
« Reply #675 on: 27 / October / 2009, 22:56:34 »
I get 10 pixels top border, 12 pixel right border, 36 pixels left border 0 pixels bottom border.

Method: covert image to 8 bit with new tool. Open 8 bit as raw in photoshop (gimp should work too). Zoom way in, use the selection tool to select the border, look in the info window for height or width of selction.

So i think:

#define CAM_ACTIVE_AREA_X1 12
#define CAM_ACTIVE_AREA_Y1 10
#define CAM_ACTIVE_AREA_X2 3330
#define CAM_ACTIVE_AREA_Y2 2480

edit: i sux at teh maths

From the DNG spec:
Quote
ActiveArea
...
Default
0, 0, ImageLength, ImageWidth
...
Description
This rectangle defines the active (non-masked) pixels of the sensor.

Tool will be added to trunk tools.

edit:
attached a build for 101b, please report if this looks correct.
« Last Edit: 28 / October / 2009, 20:30:32 by reyalp »
Don't forget what the H stands for.

*

Offline dvip

  • ****
  • 451
Re: A590IS porting...
« Reply #676 on: 28 / October / 2009, 10:09:07 »
@reyap,
It boots fine and it looks better.

For it to work in my A590IS0-101b it still needs this trim to
make the borders disappear:

4 Pixels @left, 3 Pixels @Top, 6 Pixels @right

I think a bigger trim is needed for whim's A590IS0-101b, so we can go
with his because it will work with mine as well.


*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A590IS porting...
« Reply #677 on: 28 / October / 2009, 11:05:32 »
Quote
I think a bigger trim is needed for whim's A590IS0-101b, so we can go
with his because it will work with mine as well.

no need to worry, for the few pics i ever postprocess i'll live with whatever magic RawTherapee applies, borderwise
reyalp's version appears fine for me - no black borders. Also, all that programs like PS (or even GIMP)
do for me is make me ill - i can think of more fun things to do with my time

what interests me is why my builds failed to work on your cam, while they work fine on mine - i'll do some more
checking (like downloading them of the drop, and then trying, etc.) Will post if i 'succeed' to make it fail  :D
reyalps' is compiled with GCC 3.4.6 BTW, mine with GCC 4.4.0

cheers,

wim
« Last Edit: 28 / October / 2009, 11:08:12 by whim »


*

Offline dvip

  • ****
  • 451
Re: A590IS porting...
« Reply #678 on: 28 / October / 2009, 11:35:08 »
@whim, feel free to post more until we figure out
what the problem is... we'll see If it is the compiler or what...
I can always test them at night.

*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A590IS porting...
« Reply #679 on: 28 / October / 2009, 12:21:48 »
@dvip

download still works like a charm for me, compiler version also seems unlikely - Autobuild also uses 4.4.0
here's 2 x trunk824, modified with reyalp's CAM_ACTIVE_AREA's, and compiled with 346 and 440:

[links removed, files too]

cheers,

wim
« Last Edit: 28 / October / 2009, 19:06:40 by whim »

 

Related Topics