SX100 IS - page 11 - Firmware Dumping - CHDK Forum

SX100 IS

  • 276 Replies
  • 129662 Views
*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: SX100 IS
« Reply #100 on: 05 / July / 2008, 04:15:12 »
Advertisements
OMG, I forgot something....
File re-uploaded.

*

Offline bether

  • *
  • 28
  • SX100 IS
Re: SX100 IS
« Reply #101 on: 05 / July / 2008, 04:28:09 »
WOW!!!!
Now works :)
Pretty long time shoot!!!
Great RAW shoot!!!
Now I will testing macro photo with F16 aperture for bigest DOF and long (64sec.) night shoots:)

PS.
Sorry, I can't repeat for You a karma action without waiting 10 hours.
« Last Edit: 05 / July / 2008, 08:31:58 by bether »

*

Offline Hacki

  • ****
  • 359
  • EOS 80D
Re: SX100 IS
« Reply #102 on: 05 / July / 2008, 08:43:49 »
Nicely done. Bracketing works now, too. Games work too  :P

i'll take the cam with me later, test a little more..

Thanks so far! (to both, ewavr and flar)


Re: SX100 IS
« Reply #103 on: 05 / July / 2008, 09:17:39 »
...Great RAW shoot!!!
What app(s) are you using for raw?  I just tried UFraw and it didn't recognize the format.  dcraw commandline version sees the file as generated by A720, but I'd rather not use that.


Re: SX100 IS
« Reply #104 on: 05 / July / 2008, 09:36:56 »
Just came up with one answer to my own question.
Used dng4ps2
DNG4PS-2 - CHDK Wiki
to convert to DNG, then opened with GIMP.  (I'm a Windows XP user.)

Still would like to hear what apps others are using.

*

Offline bether

  • *
  • 28
  • SX100 IS
Re: SX100 IS
« Reply #105 on: 05 / July / 2008, 09:45:49 »
I use Raw_Therapee.
here:
Download RT v2.3
« Last Edit: 05 / July / 2008, 11:15:06 by bether »

Re: SX100 IS
« Reply #106 on: 06 / July / 2008, 14:12:36 »
May I point out some problems with the build, no offense intended?

--The display of the zoom value seems to be based on the 720. The focal length is displaying between 5.8 and 34.8, or 6X.  Likewise, the EFL maxes out at 210mm rather than 350. I went through the source trying to find where the conversion is done, but couldn't.  Is it in assembly code somewhere?

--The miscellaneous exposure values aren't being updated with each half-press of the shutter button (if you have the display set to "always"). I see that there's a call to gui_osd_calc_expo_param that's commented out down near the bottom of gui_osd.c.  Could that be the problem?

--When you do a half-press before shooting, the focus indicator is erased after a fraction of a second.

--Similarly, after a half-press, the exposure values at the bottom of the display are wiped out.

--The OSD misc values are not removed when the camera goes into read (picture viewing) mode. That makes it hard to see the photo, or to read the settings if in detailed display mode.

I'm still looking at the code to try to find where these problems occur, but they may be obvious to someone who has worked with CHDK for a while.

Again, a thousand thanks to flar and ewavr.

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: SX100 IS
« Reply #107 on: 06 / July / 2008, 15:13:38 »
--The display of the zoom value seems to be based on the 720. The focal length is displaying between 5.8 and 34.8, or 6X.  Likewise, the EFL maxes out at 210mm rather than 350. I went through the source trying to find where the conversion is done, but couldn't.  Is it in assembly code somewhere?

platform/sx100is/main.c, focal length table fl_tbl[]. Somebody must make shots for each zoom step , read focal length for EXIF data, and update this table. I cannot perform this without camera.

Quote
--When you do a half-press before shooting, the focus indicator is erased after a fraction of a second.

--Similarly, after a half-press, the exposure values at the bottom of the display are wiped out.

Maybe, zebra makes this. Try turn off it.

Quote
--The OSD misc values are not removed when the camera goes into read (picture viewing) mode. That makes it hard to see the photo, or to read the settings if in detailed display mode.

Maybe detecting of play/record mode is wrong - in platform/sx100is/main.c mode_get() function. Somebody must observe behavior of playrec_mode variable in play and record modes and correct this function.


[/quote]


*

Offline Hacki

  • ****
  • 359
  • EOS 80D
Re: SX100 IS
« Reply #108 on: 06 / July / 2008, 15:33:01 »
Focal Length        |6,0 mm                                                   
Focal Length        |6,7 mm                                                   
Focal Length        |7,3 mm                                                   
Focal Length        |8,2 mm                                                   
Focal Length        |9,1 mm                                                   
Focal Length        |10,3 mm                                                   
Focal Length        |11,5 mm                                                   
Focal Length        |14,4 mm                                                   
Focal Length        |16,1 mm                                                   
Focal Length        |20,1 mm                                                   
Focal Length        |22,4 mm                                                   
Focal Length        |28,1 mm                                                   
Focal Length        |34,9 mm                                                   
Focal Length        |38,9 mm                                                   
Focal Length        |46,6 mm                                                   
Focal Length        |51,1 mm                                                   
Focal Length        |60,0 mm                                                   

Are these values Possible?

*

Offline bether

  • *
  • 28
  • SX100 IS
Re: SX100 IS
« Reply #109 on: 06 / July / 2008, 16:59:00 »
Quote
platform/sx100is/main.c, focal length table fl_tbl[]. Somebody must make shots for each zoom step , read focal length for EXIF data, and update this table. I cannot perform this without camera.

I added four last values.
________________________________________________________________________________________
static const int fl_tbl[] = {5800, 6420, 7060, 7700, 8340, 9950, 11550, 13160, 14750, 17150, 19570, 22760, 26750, 30750, 34800, 40600, 46400, 52200, 58000};
_________________________________________________________________________________________
OSD now show the focal length to 10x but EFL still show 35mm-210mm instead 35mm-350mm :(
maybe to change this?:
___________________
#define CF_EFL 60345
___________________

_

 

Related Topics