SX100 IS - page 14 - Firmware Dumping - CHDK Forum supplierdeeply

SX100 IS

  • 276 Replies
  • 128638 Views
*

Offline Hacki

  • ****
  • 359
  • SX100
Re: SX100 IS
« Reply #130 on: 09 / July / 2008, 10:16:34 »
Advertisements
http://mighty-hoernsche.de/chdk/sx100is-100c.tar.bz2

New build & Source

- Added MODE_SCN_INDOOR
- zoom_busy / focus_busy variables corrected

Thanks a lot to ewavr  :)

Now, i dont know what still needs to be done, as i cant find anything not working at the moment.

However, i cant find any options concerning the video override settings. Are those not yet included in allbests build?  :blink:


*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: SX100 IS
« Reply #131 on: 09 / July / 2008, 10:42:19 »
Now, i dont know what still needs to be done, as i cant find anything not working at the moment.

How about USB remote switch?

Quote
However, i cant find any options concerning the video override settings. Are those not yet included in allbests build?  :blink:

Wait for one or two days  ;)
If you wish, you can test how multipartiton support works.

*

Offline Hacki

  • ****
  • 359
  • SX100
Re: SX100 IS
« Reply #132 on: 09 / July / 2008, 12:31:27 »
Quote
How about USB remote switch?

Tried that, reacts on ~3.5V as if i plugged it into a computer - cam switches to play-mode and does not react on input through the keyboard. (Maybe i connected the wrong cables.. ? I just hope i wont damage it.. Fried my A410 by accidently connecting it to a 9V power supply.. )

Quote
If you wish, you can test how multipartiton support works.

You mean multiple partitions on the SD card? I'm not exactly sure how to test that.. CHDK would use the second partition, if it were working?


*

Offline bether

  • *
  • 28
  • SX100 IS
Re: SX100 IS
« Reply #133 on: 09 / July / 2008, 15:43:12 »


*

Offline Hacki

  • ****
  • 359
  • SX100
Re: SX100 IS
« Reply #134 on: 09 / July / 2008, 16:11:47 »
USB remote is working. Needed to replace

#define USB_MASK (0x200000)

with

#define USB_MASK (0x40000)

But still need to run a script waiting for a 'click' - is it intended to be like that?



*

Offline bether

  • *
  • 28
  • SX100 IS
Re: SX100 IS
« Reply #135 on: 09 / July / 2008, 16:25:12 »
Thanks Hacki,
No problem to use with this small script:
_______________________
@title Remote button
:loop
wait_click 1
is_key k "remote"
if k=1 then shoot
goto "loop"
end
_______________________

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: SX100 IS
« Reply #136 on: 10 / July / 2008, 07:57:24 »
1.00C in trunk now (with last Hacki corrections).

Re: SX100 IS
« Reply #137 on: 10 / July / 2008, 08:19:12 »
What about 1.00B ?!

Do you think it's impossible to take a 1.00C firmware dump and "overwrite" the 1.00B firmware of a camera (i.e. using a firmware dump as a firmware upgrade)?!

Conversely, how hard could it be to port from 1.00C to 1.00B? Does somebody have links on how to do it? I don't think I'll be able to do it, but maybe it could be useful to gather some infos on how to go from 1.00c to 1.00b ...

Regards, and thanks a lot to everybody who's working on this project ...
fiamazo


Re: SX100 IS
« Reply #138 on: 10 / July / 2008, 08:53:17 »
1.00C in trunk now (with last Hacki corrections).
What do you mean? Can anyone elaborate, please?

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX100 IS
« Reply #139 on: 10 / July / 2008, 09:00:33 »
Hi cegg1,

1.00C in trunk now (with last Hacki corrections).
What do you mean? Can anyone elaborate, please?

This mean: The source code is now in the "official" source code tree (the "trunk"), so everybody can download the sources and can compile it.

With this, the SX100 1.00C will be soon (some hours - 1 day) in the Autobuild (=automatically generated CHDK files) available for download.

So --> the SX 100 with firmware 1.00C is "official" & successfully ported !

 

Related Topics