SX100 IS - page 7 - Firmware Dumping - CHDK Forum supplierdeeply

SX100 IS

  • 276 Replies
  • 126571 Views
Re: SX100 IS
« Reply #60 on: 28 / June / 2008, 13:50:11 »
Advertisements
Ok, it seems that CHDK keyboard hooks working, but i don't understand how to call menu.

If anyone can find any magic sequence of operations that call CHDK main menu - i'll be glad to hear how you do it  :)


OK, I've been hitting buttons like a monkey, and have been in the main menu, and used the text file reader and the calendar, and even, sort of, have had it in zebra + histogram mode (although it blinks out like every second)!!!

The sequence is something like this, but I can't always get it to repeat, so I think there's a timing problem:
1. Power up in play mode (splash screen displays)
2. Tap shutter to switch to record mode.
3. Press and release print button
4. Quickly press Play button.  "Multipurpose BracketingT>" displays at bottom of screen.
5. Hit Menu button to open CHDK menu.

Whooohooo!!  We're actually seeing functionality now!!!

Re: SX100 IS
« Reply #61 on: 28 / June / 2008, 14:03:27 »

Hi Flar! I have discovered a way to access the ALT mode, CHDK menus, etc... using the current diskboot.bin you provided.

As for testing, I have tested the Zebra mode and the histogram and they are working in my camera.
However, the "Auto ISO Shift" command (which I had assigned to the PRINT button, is not responding properly now).

Here it goes:

1) Copy diskboot.bin onto a bootable SD card (used bootable.exe), lock card and insert it in camera.
2) Start camera in Play mode.
3) Wait for CHDK blue welcome screen.
4) Press PRINT button (nothing happens, but you have to do this, otherwise it won't work).
5) Now press SHUTTER button halfway (as when you focus).
6) Lens extends and you are now in shooting mode (nothing special happens).
7) Now press PLAY (as if you want to go back to Play mode).
8) You are back in Play mode, you can see the blue ALT sign in the screen, CHDK works. If you now press MENU, you can access the CHDK menu, and if you press FUNC/SET you access the CHDK script manager.
9) If you press the SHUTTER button halfway again, you go back to Shooting mode, and (surprise!) CHDK now works in Shooting mode (only histogram and zebra tested so far).

10) NOTE: If you now press PRINT (to exit ALT mode and access the regular photo adjustments), the blue ALT symbol goes away but it cannot be recovered by pressing PRINT again. To do this, you can go back to Play mode, repeat the sequence above, and you'll eventually get the ALT mode back.


That's where the bug is, the blue ALT letters only appear if you press print AND change modes, whereas it should appear just by pressing PRINT. In Shooting mode, sometimes you have to press PRINT several times to exit the ALT mode. (Maybe it's interfering with the "Auto ISO shift" command I have assigned to the PRINT button, any ideas about this?)


I hope this info is helpful and that it makes sense to you.

Re: SX100 IS
« Reply #62 on: 28 / June / 2008, 14:35:46 »
So, I think the secret is hitting Print followed, at some point, by Play. 

I set my Print button back to no definition so that wasn't complicating things.

I'm having a lot of issues with the on-screen display items clashing with the basic elements on the SX100 screen, but maybe that's a basic trait of CHDK?

I'm reallllly happy.  Thanks, Flar!   :)

Re: SX100 IS
« Reply #63 on: 28 / June / 2008, 17:37:23 »
Hi Newstech!


I'm having a lot of issues with the on-screen display items clashing with the basic elements on the SX100 screen, but maybe that's a basic trait of CHDK?


In my camera, only zebra and histogram appear to work. Most of the other functions, like RAW, EV bracketing, battery indicator, etc... don't work. Even the games give an error. Actually, I can't see any of the CHDK display items on the screen except the blue <ALT> sign and the menu.

What "on-screen display items" can you see?


My firmware is "Canon Powershot SX100 IS; P-ID:315E NT D; Firmware Ver GM1.00C".
« Last Edit: 28 / June / 2008, 17:46:15 by cegg1 »


Re: SX100 IS
« Reply #64 on: 28 / June / 2008, 23:27:20 »
I can only see display items when the shutter button is pressed halfway.  When I have zebra mode turned on and tell it to display zebra on top of OSD, I can see the power indicator, space indicator, DOF info and zoom info. But just turning on OSD by itself doesn't do anything.  I've also found that I can display custom grids, but again only in half-press mode, which doesn't make sense. I wish I had access to a camera with a version of CHDK that's been debugged, so I could compare. Obviously there are some functions that are pretty much standalone, and some that are dependent on identifying SX100 hooks (such as RAW and custom shutter speeds, to name just a couple) that haven't been worked out yet.

*

Offline flar

  • *
  • 13
  • sx100is fw100c
Re: SX100 IS
« Reply #65 on: 29 / June / 2008, 05:55:20 »
Newstech, cegg1 - thank you.

I haven't seen histogram before, you helped me to see it  :) So, now i've seen the battery and space indicators after instructions from Newstech.

Obviously there are some functions that are pretty much standalone, and some that are dependent on identifying SX100 hooks (such as RAW and custom shutter speeds, to name just a couple) that haven't been worked out yet.
As you see, I haven't yet worked on it. But I thought that RAW address I had found. Though i had not tested it.

I think everything will be, but don't know when.

mvi_0818.avi - 85.98MB - i've made this video yesterday.
mvi_0818.avi - 1.85MB - the same video, but i've change size :)
« Last Edit: 29 / June / 2008, 09:56:04 by flar »

*

Offline bether

  • *
  • 28
  • SX100 IS
Re: SX100 IS
« Reply #66 on: 29 / June / 2008, 07:21:39 »
Hello this is my first post on this forum.
My suggestion, maybe compare to A720 IS CHDK for copy working funkctions?
Can It?

Re: SX100 IS
« Reply #67 on: 29 / June / 2008, 08:02:58 »
Let's give it up for Flar!!  Click that Applaud button!!!!  :D


Re: SX100 IS
« Reply #68 on: 29 / June / 2008, 08:39:34 »
A question for you, Flar:  Did you start your work with any particular build?  If so, which one?  This might guide us with respect to special features.

*

Offline flar

  • *
  • 13
  • sx100is fw100c
Re: SX100 IS
« Reply #69 on: 29 / June / 2008, 08:48:54 »
Did you start your work with any particular build?
Yes

If so, which one?
trunk, revision 416. I think it's allbest branch of CHDK development.

My suggestion, maybe compare to A720 IS CHDK for copy working funkctions?
Can It?
I am doing porting based on A720IS. So keyboard port from S5IS, but everything else based on A720IS.
« Last Edit: 29 / June / 2008, 09:07:54 by flar »

 

Related Topics