Disable preflash (ettl) with chdk? - General Help and Assistance on using CHDK stable releases - CHDK Forum

Disable preflash (ettl) with chdk?

  • 5 Replies
  • 3067 Views
Disable preflash (ettl) with chdk?
« on: 06 / October / 2008, 01:54:08 »
Advertisements
I tried searching the forums for this but didn't see anythign regarding it so I'm guessing it hasn't really been explored.

Basically my problem is that when trying to trigger optical slaves the preflash thats fired because of the ETTL sets off the slave before the picture is actually taken. Would there be any way to disable this and just set the flash manually?

I'm trying to come up with a total DIY studio kit with slaves made from disposable camera flashes, if I could get this to work through CHDK you could have a multistrobe setup for under $20 easily.

Hopefully I'm just blind and missed an option that is already in CHDK.

Any info would be greatly appreciated.

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Disable preflash (ettl) with chdk?
« Reply #1 on: 06 / October / 2008, 02:27:18 »
what camera you got? most cameras offer manual mode, in these you can set the flash to manual power - thus disabling preflash (should work in av mode as well).

Re: Disable preflash (ettl) with chdk?
« Reply #2 on: 09 / September / 2009, 04:31:54 »
Sorry I've been absent from this forum for awhile and I know the thread is a little dated but I'll reply anyway ;)

At the time I was using an SD1000, right now I've got an SD1100.

All Canon cameras that have a built in flash use this pre-flash and even my 40D did not offer the ability to disable this pre-flash. I have a 5DMKII and professional lighting, this is just for fun. I'd be nice if a guy could bring along a point and shoot and a few manual flashes (that have optical slaves) and get some nice shots with off camera lighting.

Right now the only way to trigger optical slaves with digital cameras that use this pre-flash is to drop $80 on a Wein "digital peanut" which essentially ignores the first pulse.

I tried using the "force manual flash" and setting the flash power but it still flashes twice (and yes I disabled redeye reduction ;)

It might be that its just baked into the code that when the flash is called this pre-flash will always fire but if not it could open up some neat avenues for people on a budget.

If anyone knows any updates to my problem please reply.

Thanks again!

Re: Disable preflash (ettl) with chdk?
« Reply #3 on: 09 / September / 2009, 05:16:04 »
Ok looks like I have to eat my words, I just tried it again with my nikon SB-600's set to slave and it works. I could have sworn I saw two flashes when I first tried it so I didn't bother actually trying to trigger the slave with it.

This means my initial project of making cheap slave strobes out of disposable camera flashes is back on the table. Plus its just cool to be able to trigger off camera flashes with my point and shoot, just for fun I might do a full out fashion/glamour shoot with my SD1100 ;)

Thanks PyrePhox and sorry I doubted you!


*

bugmenot

Re: Disable preflash (ettl) with chdk?
« Reply #4 on: 09 / September / 2009, 12:19:03 »
guys, try using Topaz Denoise

it works wonders. With my Canon a710  I can even use ISO 800 now because of it.


Re: Disable preflash (ettl) with chdk?
« Reply #5 on: 09 / September / 2009, 13:06:06 »
guys, try using Topaz Denoise

it works wonders. With my Canon a710  I can even use ISO 800 now because of it.



I think you responded to the wrong thread...

 

Related Topics