OSD Menu characters get messed up (SD500) - General Discussion and Assistance - CHDK Forum

OSD Menu characters get messed up (SD500)

  • 3 Replies
  • 1770 Views
OSD Menu characters get messed up (SD500)
« on: 08 / October / 2008, 03:50:01 »
Advertisements
Hi all,

I'm very new here. Just started trying to use CHDK. Yesterday I played a bit with the CHDK menu to try bracketing, and suddenly the words in the CHDK menu were messed up. With this, I mean that about 60%-70% of the characters in the menu had been replaced by apperently random characters. It felt a bit like data was stored over the strings that make up the menus.

Is this a known phenomenon with CHDK? I wasn't able to find similar issues in the forum... I am using ixus700_sd500-101b-0.5.5-529.

Thanks for all the work you guys have put into this! It is really amazing what has been accomplished.

TheJez

*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: OSD Menu characters get messed up (SD500)
« Reply #1 on: 08 / October / 2008, 15:55:38 »
Hm actually I forgot to report this, but I the same thing happened to me when I tried the new edge overlay a while back on some juciphox build (or maybe one of the first new-trunk checkouts) on my a570is 1.00e.

Haven't tried it since or actually even upgraded CHDK, and this was before reyalp's RAM optimizations and could very well be related to lack of memory.

Re: OSD Menu characters get messed up (SD500)
« Reply #2 on: 09 / October / 2008, 03:34:31 »
Thanks for the response. I did play with the edge overlay function as well. I don't exactly recall when this string mutilation started. I will try to reproduce it when I have some time to play with it again... I don't mind too much if the menu is goofed up, but if the strings get overwritten, what else can get overwritten? I can imagine that other things may start going wrong as well.

TheJez

Re: OSD Menu characters get messed up (SD500)
« Reply #3 on: 12 / October / 2008, 17:36:42 »
Hi,
This also happened to me occasionally when testing edgeoverlay using the juciphox build on an A720is and A570is.  It never happened to me using edgeoverlay on the allbest build, and I have used this very often.  Strange.

Jon


 

Related Topics