Build 531 crashes A650IS at startup - CHDK Releases - CHDK Forum supplierdeeply

Build 531 crashes A650IS at startup

  • 15 Replies
  • 8211 Views
*

Offline vit40

  • ****
  • 276
Build 531 crashes A650IS at startup
« on: 10 / October / 2008, 14:05:50 »
Advertisements
If camera is started in record mode, it crashes at startup. It can be started in review mode and then switched to record mode.
Versions 524 and 527 worked fine. Used cfg file from previous version, didn't try from scratch

I can confirm that "first raw timestamp zero" bug is corrected for this camera, as written in timeline

*

Offline hotvedt

  • ***
  • 106
  • A540/SX110IS/350D
Re: Build 531 crashes A650IS at startup
« Reply #1 on: 10 / October / 2008, 14:57:25 »
This also happens with my A540, but not every time. I have not seen this problem before #531

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Build 531 crashes A650IS at startup
« Reply #2 on: 10 / October / 2008, 16:17:44 »
i think i know the reason, i forgot to add a check. will update during the next minutes.

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Build 531 crashes A650IS at startup
« Reply #3 on: 10 / October / 2008, 16:36:26 »
should be fixed now ( in Changeset 532 - chdk - Trac)
wonder why it crashed the cam though, i guess i need to add some kind of delay.


*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Build 531 crashes A650IS at startup
« Reply #4 on: 10 / October / 2008, 16:43:27 »
should be fixed now

core_spytask(){
...
gui_init(); // --->  if (conf.zoom_override) shooting_set_zoom(conf.zoom_override_value);
....
clear_values(); //--->    if (conf.clear_zoom_override) conf.zoom_override = 0;
...
}

Maybe, must be in reverse order (clearing and using of conf.zoom_override)?
« Last Edit: 10 / October / 2008, 16:50:34 by ewavr »

*

Offline reyalp

  • ******
  • 13673
Re: Build 531 crashes A650IS at startup
« Reply #5 on: 10 / October / 2008, 19:27:06 »
evar:
Hmm, that might not be the only thing either, although conf_restore is called earlier, which should at least load defaults for everything. In fact, conf_restore should probably call clear_values.

shooting_set_zoom probably shouldn't be called on startup either, since we might be in play mode.

Fortunately, the previous checkin will prevent this from actually trying to zoom in playback mode, but it won't get set either. This should be done in capt_seq (actually shooting_expo_param_override) like the other overrides.

edit:
checked in. Moved clear_values, and commented out the shooting_set_zoom for now, since it doesn't really make sense there.
« Last Edit: 10 / October / 2008, 19:54:09 by reyalp »
Don't forget what the H stands for.

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Build 531 crashes A650IS at startup
« Reply #6 on: 11 / October / 2008, 08:24:04 »
well i added the check for rec/play mode so i didnt need to worry about it someplace else.
the zoom override isnt finished yet, and has two functions: on camera start, set zoom to specified value (on some cameras zooming takes a while, so people might not wanna wait to zoom when they press the shutter) and override the zoom during normal shooting and bracketing. will look into capt_seq, thanks for the tips.

*

Offline vit40

  • ****
  • 276
Re: Build 531 crashes A650IS at startup
« Reply #7 on: 11 / October / 2008, 09:26:34 »
Seem to be ok now, tried several times without problems.

This zoom override could be useful (I implemented it in my zoom video script, before zoom option was implemented in video mode), although "C" mode also saves current zoom position and that is probably enough for most users

Now, after solving "first raw zero timestamp" bug, are there any chances of solving "sporadic raw images" bug, that is much bigger (raw isn't saved if I press the shutter fully without prefocusing)


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Build 531 crashes A650IS at startup
« Reply #8 on: 11 / October / 2008, 10:39:07 »
well there are cameras that dont have a C mode. saving/restoring the zoom setting would be just one setting of a lot more that people want to be saved/restored. this is having to do with the "save/load camera settings via chdk" feature request. this would benefit also these people that DO have the C mode, because a) you could save different sets of settings (i.e. macro, sports, etc) and b) because you can save even settings that the camera normally forgets when you reboot it (despite C mode), for example continuous mode.
i thought the sporadic raw stuff was already solved somewhere?

*

Offline vit40

  • ****
  • 276
Re: Build 531 crashes A650IS at startup
« Reply #9 on: 11 / October / 2008, 11:08:21 »
Yes, I forgot about cameras without "C" mode  :-[   and I agree that this feature can be useful because it isn't limited to C mode

Nope, sporadic raw images bug isn't solved - at least not for A650. When I prefocus with half-press of the shutter and then take a shot, raw is saved. When I fully pres the shutter at once (without waiting the camera to focus), raw isn't saved. Raw is also always saved in MF mode (as expected, since there is no prefocus in that case). Tryed switching IS on and of, no difference.

A620 doesn't exhibit this problem
« Last Edit: 11 / October / 2008, 11:11:48 by vit40 »

 

Related Topics