the sx10 porting thread - page 15 - General Discussion and Assistance - CHDK Forum supplierdeeply

the sx10 porting thread

  • 613 Replies
  • 276816 Views
*

Offline fe50

  • ******
  • 3134
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: the sx10 porting thread
« Reply #140 on: 23 / March / 2009, 07:10:31 »
Advertisements
Hello & welcome, pianoplayer88key !

There's only one CHDK version available for the SX10, you'll find the DL link on the CHDK Wikia Download page.
The latest CHDK version includes all standard features.

CHDK for the SX10 works with all card sizes, you can start it manually from 8 or 16GB cards.
The autostart feature works with a FAT16 formatted SD card with max. 4GB.
With bigger cards a special setup (a small start partition + a big data partition) is needed, the card can be prepared with CHDK, see my earlier posts in this thread.

If you're running MS Windows, read also this post.

Yes, each card must be prepared since CHDK is not a permanent update...

Quote
Or should I make a new thread to ask this, or is posting at 2:55am PDT not the time when ppl are on here reading the board?
LOL - CHDK never sleeps...you'll find more informations about CHDK in the Wikia,
SX10 related issues should be posted here, general CHDK questions or problems should be posted in an own thread / other related threads  :)

Re: the sx10 porting thread
« Reply #141 on: 23 / March / 2009, 07:40:22 »
Thanks fe50. :)
Don't know if I'll get around to installing it today, but I see the part about the 8/16GB cards.  Also read the faq about using multiple partitions, and the post about it not working in windows.  (If necessary, I could boot Ubuntu and use its partition manager to make the partitions, that is if it'll recognize my SD card.)  Also, my current external multi-format card reader, when plugged in under Windows XP, will only recognize one type of card at a time (and I have to insert the card, THEN plug in the card reader for it to recognize the proper one).  I can't find drivers for this one, so is it time for a new reader?  I can read/write SDHC cards just fine, otherwise I would have already bought a new one.

Is the Wikia you linked a good place to go to learn more about how to use CHDK one it's installed, or are some things somewhat self-explanatory on-camera?

Re: the sx10 porting thread
« Reply #142 on: 23 / March / 2009, 15:58:36 »
I have 1.0c firmware. What can i do to speedup creation of CHDK for this version of firmware (except write it myself)? As far as i can see this is oldest version of camera. I noticed some info missing in wiki so i added it. :)

Firmware version 1.02B
« Reply #143 on: 23 / March / 2009, 21:09:22 »
I just received my SX10, with firmware version 1.02B, which is apparently not on your list.

Here's the information with vers.req:

Canon PowerShot SX10 IS
P-ID: 318D NT D
Firmware Ver: GM1.02B
NoError
Jan  9 2009  15:10:11

Adj Ver.019.013

Total Shoot: 8
Zoom Retry Count: 0
Mecha Condition: 0x00000000

I will try to figure out how to get a dump.

----------------------------------------------------------------

Mmm, I don't think I will be able to get a dump.  CardTrick does not work on my Vista PC.

It asks me to select a drive, but when I do, it just re-display the dialog, and will not quit whether I click OK or Cancel.  I have to re-start the PC to get out of the loop.
« Last Edit: 23 / March / 2009, 21:30:18 by JonathanF »


Re: the sx10 porting thread
« Reply #144 on: 24 / March / 2009, 01:17:50 »
Well I seem to be getting started running it.  One basic thing though... what do I need to do to actually use the exposure (shutter, aperture, ISO) overrides?  Also is there a quicker way to select the options rather than using the left/right?  The scroll wheel scrolls to the different menu items, and doesn't scroll through the options available in each item.

Also, Canon's low battery indicator didn't even show until my CHDK battery indicator showed 0%.  (Not a prob, just an observation)

Also where's a good place to look for some good scripts to try?
« Last Edit: 24 / March / 2009, 01:23:02 by pianoplayer88key »

Re: the sx10 porting thread
« Reply #145 on: 24 / March / 2009, 02:51:31 »
Hello, CHDK works fine on my sx10. I've tested RAW (as DNG) and was a bit disappointed, for dynamic range it's such a small improvement from JPG that for me it's not worth it. For high ISO, in my tests jpg+neatimage is slightly better than raw+neatimage.
I guess it's a good news: from my testing, canon JPG engine is extremely good :-)

I'm however interested in the iso3200 mode with iso override to get 3-4pps. I tried it: on the pictures and on the display it is written iso160 and iso500 when i set iso override to 100 or 300, and also the exposition times appear to reflect such an ISO (much slower than if it was real 3200). However the very strong iso3200 noise reduction appears to be applied anyway, which gives a picture almost as bad as real iso3200. am i doing something wrong?
i didn't force flash on if it's the reason, i'm afraid that firing flash so quickly could cause it to overheat and get damaged.

PS: a bit over 12.000 bad pixels on my cam, but i'm happy of the JPG pictures, i guess it's OK.
« Last Edit: 24 / March / 2009, 05:01:53 by emmanuel »

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: the sx10 porting thread
« Reply #146 on: 24 / March / 2009, 06:11:57 »
However the very strong iso3200 noise reduction appears to be applied anyway, which gives a picture almost as bad as real iso3200. am i doing something wrong?

BTW, RAW resolution in ISO3200 mode is only 1248x938 (1.1MP), but it still 12-bit  :D.

Maybe Canon's 1600x1200 is interpolated.
« Last Edit: 24 / March / 2009, 06:16:08 by ewavr »

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Firmware version 1.02B
« Reply #147 on: 24 / March / 2009, 06:38:32 »
I just received my SX10, with firmware version 1.02B, which is apparently not on your list.

Well, he have SX10 with 1.00B, 1.00C, 1.01A, 1.01B, 1.02B firmware version (maybe 1.02A also exists).

True paradise for CHDK developer  :D.


*

Offline fe50

  • ******
  • 3134
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: the sx10 porting thread
« Reply #148 on: 24 / March / 2009, 08:05:22 »
Well, he have SX10 with 1.00B ? ???
...maybe Canon plans to slay us down with firmware versions  :D
« Last Edit: 24 / March / 2009, 08:08:14 by fe50 »

Re: the sx10 porting thread
« Reply #149 on: 24 / March / 2009, 08:11:11 »
Hi,

Well, I want to begin by a very big THANKS to all the developers team working on the SX10.
My SX10 is in 1.02B too (like JonathanF). I'm not a developer, so I can't help you directly but if you need a little donation or somethings else, i will be here.
I have a question : Is a downgrade possible ? I've seen that dumps are available, is there any way to put it in the camera to have the good firmware version ?
I'm a newbie so...sorry if this question is a little bit simple......
Thanks a lot one more time for all your work.

 

Related Topics