the sx10 porting thread - page 48 - General Discussion and Assistance - CHDK Forum supplierdeeply

the sx10 porting thread

  • 613 Replies
  • 219936 Views
Re: the sx10 porting thread
« Reply #470 on: 02 / July / 2009, 16:30:08 »
Advertisements
Wow. Thank you Cormac!! I have been checking this thread religiously since back in December waiting for 1.00C. You and everyone else that has helped just made my week.

My osd and preferences don't seem to be staying between boots. I looked over the manuals because it was probably just a setting but I couldn't find anything.

Re: the sx10 porting thread
« Reply #471 on: 02 / July / 2009, 16:30:56 »
On another note... When I browse files I'm seeing the 11.3 format so I see COUNTD~1.LUA.

Is this a CHDK option I need to change, or a firmware change I need to make?

Re: the sx10 porting thread
« Reply #472 on: 02 / July / 2009, 16:39:21 »
Wow. Thank you Cormac!! I have been checking this thread religiously since back in December waiting for 1.00C. You and everyone else that has helped just made my week.

My osd and preferences don't seem to be staying between boots. I looked over the manuals because it was probably just a setting but I couldn't find anything.

You may want to try going into the CHDK menu,then Miscellaneous, and select reset options to default. If there is an odd setting it will clear it out.

*

Offline reyalp

  • ******
  • 12159
Re: the sx10 porting thread
« Reply #473 on: 02 / July / 2009, 19:14:19 »
On another note... When I browse files I'm seeing the 11.3 format so I see COUNTD~1.LUA.

Is this a CHDK option I need to change, or a firmware change I need to make?
CHDK in dryos doesn't handle long names. Really all the examples etc should be 8.3

edit:
and any RET instruction should do for the nullsub stuff ;)

edit again:
random thought: It would make more sense to make a new macro like NULLSUB(name), hand have that point at an empty function rather than entering an address :/
« Last Edit: 02 / July / 2009, 19:22:56 by reyalp »
Don't forget what the H stands for.


Re: the sx10 porting thread
« Reply #474 on: 02 / July / 2009, 20:24:24 »
Thanks for the long file name answer. It saves me work looking at trying to fix it.

Any ret would probably work, but as it current stood it was pointing off into nowhere, hence the crash when set_zoom_speed was referenced. The location of nullsub_1 is probably static across all versions so far... it maps to a BX LR, essentially a ret instruction.

The NULLSUB macro would make more sense. I'll take a look at changing that, but I'm going to be pretty busy for the next two weeks.

« Last Edit: 02 / July / 2009, 20:26:03 by cormac »

Re: the sx10 porting thread
« Reply #475 on: 02 / July / 2009, 23:21:59 »
Cormac, thanks for getting us the latest beta build for 1.00C, I'll admit that I'm a newbie to CHDK but finally being able to play with the advanced features is great.  I've been real excited to try bracketing with RAW images but may have found a possible bug?  My SX10 chokes just after taking the second shot when I'm shooting RAW in bracket mode.  I tried with both the SX10's built in bracket modes and with the CHDK's.  I have to remove the batteries to recover.  Shooting in bracket mode still works fine when shooting JPG.

I'm I the only one seeing this?

Thanks,

Re: the sx10 porting thread
« Reply #476 on: 03 / July / 2009, 00:29:26 »
cormac I have no problem with bracketing with RAW. With the first 1.00c you put up.
sx10is eos 50d eos 1Ds Mark II eos 5D Mark II

*

Offline reyalp

  • ******
  • 12159
Re: the sx10 porting thread
« Reply #477 on: 03 / July / 2009, 00:33:45 »
cormac I have no problem with bracketing with RAW. With the first 1.00c you put up.

Could you please check this with the most recent autobuild: http://mighty-hoernsche.de/

Any ret would probably work, but as it current stood it was pointing off into nowhere, hence the crash when set_zoom_speed was referenced.
Yes appears to have been copied from an FFC base address camera. I probably should have noticed this when I merged ;)

Quote
The NULLSUB macro would make more sense. I'll take a look at changing that, but I'm going to be pretty busy for the next two weeks.
No worry, it's a generic CHDK issue.
Don't forget what the H stands for.


Re: the sx10 porting thread
« Reply #478 on: 03 / July / 2009, 00:52:54 »
reyalp would it be ok to check it later i need some sleep?
Steve
sx10is eos 50d eos 1Ds Mark II eos 5D Mark II

*

Offline reyalp

  • ******
  • 12159
Re: the sx10 porting thread
« Reply #479 on: 03 / July / 2009, 01:10:09 »
reyalp would it be ok to check it later i need some sleep?
Steve
Of course. If anyone else wants to check in the meantime, that would be great too.
Don't forget what the H stands for.

 

Related Topics