the sx10 porting thread

  • 613 Replies
  • 162472 Views
*

Offline reyalp

  • ******
  • 10835
Re: the sx10 porting thread
« Reply #610 on: 08 / May / 2011, 18:27:51 »
Advertisements
Hi,

I'm hoping someone might be able to help me.  I actually had not planned on trying this yet, but my camera got a little wet and started having some lens errors.  The lens now seems to be retracting OK, but the camera whenever I turn it on either with the play button or on/off button shows a clock.  From there I can now go into photo and playback mode but most of the buttons don't do anything and the zoom is nonfunctional.  Something is clearly wrong.  Is there a way to "get it back to normal?"  Thanks for any advice and apologies for posting it here but I can't find any other reference to this issue anywhere else and seems no one but you guys would have any idea how to help.
Your camera has hardware damage, so this isn't really on topic to this thread, and CHDK won't be able to fix it.

The clock showing might be an indication it thinks some of the buttons are down all the time. It would not be surprising if water damage caused this. You might be able to transplant a keypad from another camera (check ebay for ones that are damaged in other ways, e.g. broken screen, lens etc).  It's also possible that the keys haven't been damaged but are just stuck or have some crud from the water preventing them from functioning. In that case, taking it apart and cleaning it might sort things out.

It's up to you to decide if you are capable of performing any physical repairs. These cameras are quite delicate and not made to be easily user serviceable, but you can find tear down instructions for many on the net. You might want to see how much Canon service would want to deal with it instead.
Don't forget what the H stands for.

*

Offline msl

  • *****
  • 1212
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: the sx10 porting thread
« Reply #611 on: 04 / January / 2015, 05:13:27 »
Maybe there is a problem with the overrides and bracketing function. In German forum was reported, that these functions do not work with version 1.3/1.4 (SX10 102b).

With version 1.2 rev. 3770 is all fine.

May it possibly be due to the rework of the camera-dependent part (code-gen)?

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

*

Offline philmoz

  • *****
  • 3018
    • Photos
Re: the sx10 porting thread
« Reply #612 on: 04 / January / 2015, 05:32:25 »
Maybe there is a problem with the overrides and bracketing function. In German forum was reported, that these functions do not work with version 1.3/1.4 (SX10 102b).

With version 1.2 rev. 3770 is all fine.

May it possibly be due to the rework of the camera-dependent part (code-gen)?

msl

Can you try this patch please (for 1.3).

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

*

Offline msl

  • *****
  • 1212
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: the sx10 porting thread
« Reply #613 on: 04 / January / 2015, 14:21:26 »
Thanks, with this patch is all fine.

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!


 

Related Topics