Dark Pictures from SD700IS - Can CHDK Help? - page 2 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

Dark Pictures from SD700IS - Can CHDK Help?

  • 17 Replies
  • 6164 Views
*

Offline jonno

  • *
  • 11
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #10 on: 28 / October / 2008, 13:12:52 »
Advertisements
Ok I found out how to view the EXIF data in XP and added that to the post above. Hopefully it helps somehow.

*

Offline Hacki

  • ****
  • 359
  • SX100
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #11 on: 28 / October / 2008, 13:25:34 »
Interesting. It appears to me as if the image with the ND filter ACTIVE is brighter. Possible that the ND filter mechanism is damaged, and not working as it is supposed to.

You could try to override the ND filter with chdk, and see if its influencing the image brightness or not. If not, you know where the problem is.


*

Offline jonno

  • *
  • 11
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #12 on: 28 / October / 2008, 13:28:51 »
Sorry if this is a dumb question but how do you know the ND filter is active?

*

Offline Hacki

  • ****
  • 359
  • SX100
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #13 on: 28 / October / 2008, 13:35:59 »
The aperture value. Ixus / SD* series cameras do not have a variable iris. Means, "Aperture" f/2.8 = No ND filter, f/5.6 = ND filter.



*

Offline jonno

  • *
  • 11
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #14 on: 28 / October / 2008, 14:16:03 »
Ok now I'm trying to use CHDK and of course I can't hardly get it to do a dark picture.
Whenever the screen is light the CHDK displays the aperture as f/2.8
I did get it to do a dark picture with CHDK loaded once and I THINK that was when the aperture value read f? I didn't take the picture to find out what it would put in the EXIF data.
This was while the CHDK ND state was set to Off (which I presume means don't override since the other options are in & out).
None of this makes much sense to me yet so I'll keep trying things and let you know.

*

Offline jonno

  • *
  • 11
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #15 on: 28 / October / 2008, 14:48:50 »
Ok I managed to get some better data using CHDK.
Whenever I get the dark picture CHDK shows f/2.8 (as does the EXIF data).
Whenever I get the light picture CHDK shows f? and the EXIF data shows f/5.6
I tried setting the ND filter to In & Out while setting the ISO to 80 but both times I got the same effect as ND off (dark picture, f/2.8).
This really makes no sense to me. Hopefully it does to someone else.

*

Offline jonno

  • *
  • 11
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #16 on: 28 / October / 2008, 16:02:50 »
Ok I'm gonna try to summarize one more time.
There seem to be 2 situations broadly once I turn the camera on.
1. All pictures turn out normally (light)
2. Pictures in Auto mode (or Auto ISO mode) and low ISO values turn out dark and high ISO values turn out light.
In case 1. I see the following combination of ISO-aperture-speed (light/dark)
80-f/2.8-1/50 (light)
100-f/2.8-1/60 (light)
200-f/2.8-1/125 (light)
400-f/2.8-1/250 (light)
800-f/2.8-1/400 (light)
In case 2. I see:
80-f/2.8-1/250 (dark)
100-f/2.8-1/320 (dark)
200-f/2.8-1/640 (dark)
400-f/5.6-1/320 (light)
800-f/5.6-1/640 (light)

Comparing equal ISO settings it makes sense that I would get darker pictures with such fast shutter speeds right? But why would my camera choose to set the speed so fast? How would you expect a 100-f/2.8-1/320 picture to compare to 400-f/5.6-320 in terms of light level?

What is the process the camera uses to set the shutter speed and use of ND filter when I manually set the ISO?
Does it sense the light level and then choose a combination of aperture (filter on/off) and shutter speed or does it sequentially decide on the filter and then sense what shutter speed to use?


*

Offline jonno

  • *
  • 11
Re: Dark Pictures from SD700IS - Can CHDK Help?
« Reply #17 on: 29 / October / 2008, 12:02:28 »
Seems to me like all the photos in 1. turned out as they should - roughly the same exposure level.
All those in 2. SHOULD have had roughly the same exposure level although for some reason much darker than in 1.
So there are 2 questions:
A. Why did my camera decide to set the exposure level so dark in 2. compared to 1.?
B. Why did the pictures in 2. not all turn out roughly the same darkness?

I think I'll open the camera up again and try to blow out any dust with compressed air unless that's a really bad idea.


 

Related Topics