How to disable default script in Alt mode - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

How to disable default script in Alt mode

  • 6 Replies
  • 7299 Views
How to disable default script in Alt mode
« on: 31 / October / 2008, 12:30:58 »
Advertisements
I have loaded CHDK onto my S3 IS, and have tried to invoke Raw format by holding the S (settable) key and Func key, plus other combinations, but photos are still jpegs.  I also have not been able to see the CHDK menu.  Clearly there is something I am missing here.  The CHDK firmware update seems to have happened OK.

Thanks.

--jdn

How to disable default script in Alt mode
« Reply #1 on: 31 / October / 2008, 12:47:38 »
I just installed CHDK on my S3 IS and am finally able to get the CHDK menu to appear and, I think, go into Raw mode.  But when I press the shutter button, I get a message that reads: "This is a default script.  Scripts run when the shutter is pressed in ALT mode.  I can't seem to stop this and just take a photo (hopefully in raw mode).

How do I disable or fix this script action?

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: How to disable default script in Alt mode
« Reply #2 on: 31 / October / 2008, 12:50:49 »
merged your posts.

*

Offline reyalp

  • ******
  • 13394
Re: How to disable default script in Alt mode
« Reply #3 on: 31 / October / 2008, 21:41:14 »
CHDK firmware usage - CHDK Wiki

You need to leave ALT mode to shoot. On S3, the alt button defaults to shortcut.
Don't forget what the H stands for.


Re: How to disable default script in Alt mode
« Reply #4 on: 31 / October / 2008, 23:20:01 »
Thanks.  That worked.

Re: How to disable default script in Alt mode
« Reply #5 on: 04 / October / 2010, 03:59:14 »
It's not working for me. Whenever I shoot a picture, in the alt mode or outside it, it runs the latest script I selected when in Alt mode. I'm using a G9

Cheers

JJ

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: How to disable default script in Alt mode
« Reply #6 on: 04 / October / 2010, 07:15:50 »
Quote
Whenever I shoot a picture, in the alt mode or outside it, it runs the latest script I selected when in Alt mode. I'm using a G9

First, in the script parameters menu, set "Script Autostart" to "Off"

If the "lower pane" does not show 'Default Script', you can force this in any of 3 ways:
   - select the default.bas script 
   - select any file that has 0 length
   - select any file that does not fit available memory (a camera JPG does the job for me)

See also: function 'void script_load(const char *fn, int saved_params)'  in /core/script.c

HTH,

wim

 

Related Topics