CarLapse - LUA Script for timelapse out of a driving car - page 2 - Completed and Working Scripts - CHDK Forum supplierdeeply

CarLapse - LUA Script for timelapse out of a driving car

  • 37 Replies
  • 30336 Views
Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #10 on: 09 / January / 2009, 15:49:22 »
Advertisements
hmm..I can't seem to get this to work. I just got the camera not too long ago and I've read pages here for days and did some fiddling so I'll bet it's something small that I did. When I try to run it, it has the message

"uBASIC:1 Unk stat"

I thought the 1 might be a line number, but its the same --[ that you have on each of your versions. I also accidentally put the mem card without locking it, which seems to have changed all the settings to defaults and I got the same message. fb-lib.lua is in /lua/

btw, in my first post I gotta say thanks to everybody who's put in a lot of effort to get this all where it is now. I'm not great at programming but I think I can edit/organize a lot of the wiki pages to make things easier to find (once I know what I'm doing that is)

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #11 on: 09 / January / 2009, 15:55:06 »
@munk_e

Welcome to the forum !

It looks like you saved the script as {something}.bas, rename it to {something}.lua and it should work ...

hope that helps,

wim

*

Offline fe50

  • ******
  • 3136
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #12 on: 09 / January / 2009, 15:55:26 »
"uBASIC:1 Unk stat"
It's a Lua script, not uBasic - you must save it with .lua filename extension ! (on MS Windows make sure the name is not .lua.txt  ;) )

*

Offline reyalp

  • ******
  • 13502
Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #13 on: 09 / January / 2009, 18:39:30 »
FWIW, that the camera will treat *any* extension other than .lua as ubasic.
Don't forget what the H stands for.


Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #14 on: 09 / January / 2009, 21:33:14 »
Perfect! Thanks :)

Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #15 on: 13 / February / 2009, 10:49:19 »
Hi all,

I'm having the same problem as munk_e, ie when I try to run this script it says: uBASIC:1 Unk stat.  Thing is, the file is saved as a .lua extention (not a .lua.txt either).  I did load the file in vista though.  Is there a known problem?  Notepad also had a few options for encoding, is it possible I chose the wrong one?  This was all done on a friend's computer so I can't give more exact details.  Does anyone know what I should do?

Thanks!



*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #16 on: 13 / February / 2009, 12:43:31 »
Does anyone know what I should do?

Upgrade CHDK?

Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #17 on: 18 / February / 2009, 23:08:30 »


Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #18 on: 18 / February / 2009, 23:38:44 »
Update:
I've tried to load other scripts to see if I could figure out what I'm doing wrong with the carlapse.  Every script ending with .lua ends with :1: An unexpected sumbol nearn 'n' while all the scripts that require entering as .bas files bring up the uBASIC:1 Unk stat again.  Am I missing some important step in loading the scripts?

Forgive the dumb questions everyone, I'll start trying to write my own scripts once I can figure out how they work.  I've got a few ideas.

*

Offline reyalp

  • ******
  • 13502
Re: CarLapse - LUA Script for timelapse out of a driving car
« Reply #19 on: 19 / February / 2009, 00:34:53 »
Are you sure you are saving the scripts as plain ANSI text (not unicode or wordpad rtf or anything like that) ?
Don't forget what the H stands for.

 

Related Topics