SD 950 IS card lock does camera does not start - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum
supplierdeeply

SD 950 IS card lock does camera does not start

  • 4 Replies
  • 2343 Views
SD 950 IS card lock does camera does not start
« on: 14 / November / 2008, 00:35:39 »
Advertisements
Ok So I have a a new SD 950 IS... and I am completely lost at this point...

When I started I press the playback button and then the "func set" and "disp" button it would tell me a lot of data including a a firmware version of 1.0.0.0G and then I went through this process

    *  Go to the Disk Utility. Select your SD card from the list at the left, and click Informations to get the disk identifier (example: disk4s1). Use this in the steps below
    * Using Disk Utility, unmount (don't eject!) your SD card.
    * Open a Terminal window and type: dd if=/dev/disk4s1 of=BootSector_G9.bin bs=512 count=1. This copies a sector of the SD card to your Mac's hard disk.
    * The BootSector_G9.bin file in your Home directory contains your SD card's boot sector. Make a backup of it in case anything goes wrong.
    * Open BootSector_G9.bin with 0xED. Keep in mind that, if you do not see FAT12 or FAT16 around 0x36 (decimal 54) in the hex editor, you probably picked the wrong drive. Do not overwrite anything in that case.
    * If the file is correct, select the Overwrite writing method (Command+Shift+O).
    * Go to offset hex 40 (decimal 64) and press Tab. Type BOOTDISK. Save and quit.
    * In your Terminal window, type: dd if=BootSector_G9.bin of=/dev/disk4s1 bs=512 count=1. This copies the modified file to the boot sector of your SD card.
    * Using Disk Utility, mount the card.
    * Copy the file DISKBOOT.BIN to the SD card. Make sure to use the correct version for your model of Canon camera.
    * Eject the SD card. Slide the tab to the LOCK position


Every time I would try to book CHDK with the locked card I would press the playback button and nothing would happen after that I would have to pull the battery to and switch the "lock" off of the card for the camera to come back on.

Now after having gone through this anytime time I press the "func set" and disp button it just says a firmware version of 1.0.0.0.

I have never gotten CHDK to boot yet.

Any thoughts and ideas would be great and appreciated.

Wyly

*

Offline whim

  • ******
  • 2024
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: SD 950 IS card lock does camera does not start
« Reply #1 on: 14 / November / 2008, 04:32:09 »
Hi !

Since your main problem seems to be making your card bootable, and considering that
theoretically you only have to do that once, why not just have a Windows user make
your card bootable for you using CardTricks (see my signature)  ?

wim

*

Offline zeno

  • *****
  • 889
Re: SD 950 IS card lock does camera does not start
« Reply #2 on: 14 / November / 2008, 04:40:01 »
Wyly

you made a mistake in obtaining the firmware version - it is NOT (and cannot be) 1.0.0.0G. Take another look at the instructions on how to get it here FAQ - CHDK Wiki

CHDK is available for 1.00d - it's possible your camera has a different version (which would explain why CHDK won't work).
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: SD 950 IS card lock does camera does not start
« Reply #3 on: 14 / November / 2008, 10:05:20 »
Sorry it is 1.00D as the firmware.




Re: SD 950 IS card lock does camera does not start
« Reply #4 on: 14 / November / 2008, 10:34:51 »
Whim! Awesome tool! worked first time on my windows install (parallels)  on my mac. Thank you

Wyly

 

Related Topics