Bug Reports against Recent Builds -- Report bugs here - page 28 - CHDK Releases - CHDK Forum supplierdeeply

Bug Reports against Recent Builds -- Report bugs here

  • 281 Replies
  • 78631 Views
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #270 on: 11 / December / 2014, 05:51:45 »
Advertisements
I have an issue with build a3100-100d-1.3.0-3787-full running on a Power Shot A3100 IS regarding the Purge Raw option.

When I enter File Browser, go to A/DCIM, highlight the folder where the images are, press the left button ("mountain") and choose Purge Raw, instead of deleting all raws in that folder, it gives the following message:

"Purge Raw feature does not apply to this item"

Currently, the folder where the raws are is A/DCIM/133___12/

According to srsa_4c, this is because 'Purge Raw' will only work on directories that are named xxxCANON (the fourth character has to be 'C') (http://chdk.setepontos.com/index.php?topic=12105.msg118996#msg118996
Canon A3100IS - 100d
CHDK a3100-100d-1.2.0-3643-full_ALPHA

*

Offline srsa_4c

  • ******
  • 4025
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #271 on: 11 / December / 2014, 16:34:21 »
Replying here.

The easiest 'fix' would be to extend the directory name check to allow '_' (underscore) too. Would that be correct? (AFAIK date based dir names always have an underscore as 4th char).
(I'm asking other devs, not necessarily @oneaty).

*

Online philmoz

  • *****
  • 3128
    • Photos
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #272 on: 11 / December / 2014, 17:34:44 »
Replying here.

The easiest 'fix' would be to extend the directory name check to allow '_' (underscore) too. Would that be correct? (AFAIK date based dir names always have an underscore as 4th char).
(I'm asking other devs, not necessarily @oneaty).

That would fix it; but having just looked at the 'purge' code all I can say is WTF :'(

Serious re-write needed here.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

*

Offline rick

  • *
  • 11
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #273 on: 02 / January / 2015, 06:30:10 »
I can't use stick to download chdk. So I followed method 3(http://chdk.wikia.com/wiki/Prepare_your_SD_card) to go on.
I use A1200 and  downloaded a1200-100a ,a1200-100b,a1200-100c from http://mighty-hoernsche.de/
From stick,I knew the firmware version of my camera is 100a.
When everything is done,I can open the camera with chdk successfully.
However,the build info shows FW Vers:100b !
Could someone confirm this problem?
What's the problem if I continues to use 100b?

Thanks


Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #274 on: 02 / January / 2015, 10:46:54 »
From stick,I knew the firmware version of my camera is 100a. When everything is done,I can open the camera with chdk successfully. However,the build info shows FW Vers:100b ! Could someone confirm this problem?What's the problem if I continues to use 100b?
Some version of Canon firmware are essentially identical (at least from a CHDK port requirement).  When that happens, we only make one actual version  of CHDK and then rename it so it will match the available firmware versions.   In the case of the A1200,  the 100a and 100b versions are done that way.   So you will see 100b as the firmware version even though your camera has 100a.  It will work fine that way.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline rick

  • *
  • 11
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #275 on: 02 / January / 2015, 10:58:58 »
From stick,I knew the firmware version of my camera is 100a. When everything is done,I can open the camera with chdk successfully. However,the build info shows FW Vers:100b ! Could someone confirm this problem?What's the problem if I continues to use 100b?
Some version of Canon firmware are essentially identical (at least from a CHDK port requirement).  When that happens, we only make one actual version  of CHDK and then rename it so it will match the available firmware versions.   In the case of the A1200,  the 100a and 100b versions are done that way.   So you will see 100b as the firmware version even though your camera has 100a.  It will work fine that way.
Thank you so much!
I have tried it. It does work fine just like you said! :)

*

Offline srsa_4c

  • ******
  • 4025
CHDK file browser vs. exFAT
« Reply #276 on: 27 / February / 2015, 16:58:28 »
Just a note. It was mentioned in the German forum that the CHDK file browser has problems on exFAT cards: it's not possible to return from a subdirectory. My guess is that this happens because exFAT doesn't have .. (and .) directory entries. Can somebody with an appropriate card confirm this?

*

Online philmoz

  • *****
  • 3128
    • Photos
Re: CHDK file browser vs. exFAT
« Reply #277 on: 27 / February / 2015, 18:27:53 »
Just a note. It was mentioned in the German forum that the CHDK file browser has problems on exFAT cards: it's not possible to return from a subdirectory. My guess is that this happens because exFAT doesn't have .. (and .) directory entries. Can somebody with an appropriate card confirm this?

Should be fixed in revision 4036 (trunk) and 4037 (1.3).

If no ".." entry is returned from fs_readdir, I add it to the directory list (except for the root directory).
Tested on G1X on exFat and Fat32 cards.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)


*

Offline srsa_4c

  • ******
  • 4025
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #278 on: 20 / March / 2015, 16:33:04 »
compilation with OPT_EXPIRE_TEST is broken for touchscreen cameras in trunk
edit:
... and 1.3
Code: [Select]
gui.c:(.text+0x106e): undefined reference to `gui_reset_alt_helper'
« Last Edit: 20 / March / 2015, 17:07:11 by srsa_4c »

*

Online philmoz

  • *****
  • 3128
    • Photos
Re: Bug Reports against Recent Builds -- Report bugs here
« Reply #279 on: 20 / March / 2015, 19:13:10 »
compilation with OPT_EXPIRE_TEST is broken for touchscreen cameras in trunk
edit:
... and 1.3
Code: [Select]
gui.c:(.text+0x106e): undefined reference to `gui_reset_alt_helper'

Fixed in revision 4102.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

 

Related Topics