A1000IS porting... - page 11 - DryOS Development - CHDK Forum

A1000IS porting...

  • 297 Replies

Offline EyP3

  • *
  • 46
Re: A1000IS porting...
« Reply #100 on: 08 / January / 2009, 09:40:08 »
you already can have shutter priority, custom ISO, ubasic scripting and a lot more. Please check the previous messages to get an idea what's already implemented by Diablo.

continued progress? trouble with raw
« Reply #101 on: 05 / February / 2009, 14:53:15 »
Hi folks, I stumbled across this a few days ago and have stumbled through the CHDK installation. Many thanks to the many who have worked this out. 

Not all of it works straighforwardly, however. For example, the 12/8 DISKBOOT.BIN (most recent I think) doesn't work in my camera (camera won't turn on; firmware 1.00b), but the 12/2 version does work. I'm also having trouble with the raw files. I see that some work was ongoing for this in December, but don't see that anything has occurred since. I can't find any program that will open the files (although some see the files, I've tried Lightbox, ufraw, Picasa3, PS Elements 6, Raw Therapee, XnView, Fast Stone viewer, dcrawui), and the dng4ps2 program doesn't load the files either. I'm not a coder, but is there something I can do to check this out or help the process along?

again, thanks for all the work so far!

Re: A1000IS porting...
« Reply #102 on: 06 / February / 2009, 19:17:30 »
Hey everyone! Another newbie here, bought my first digital camera yesterday. An A1000 IS, of course :) I installed CHDK right away. I have FW version 1.00b.

I noticed the same thing Mattock did - the 12/08 build wouldn't boot up my camera, 12/08 works fine. I guess we should make an FW dump and compare it to the one Diablo worked with, to see if it's just some glitch or Canon changed the firmware recently.

Mattock, I'm having the same problem with dng4ps2: it wouldn't list the files, and i can't set up the color profile. I'm guessing the version we see now (beta 19) is different from the one Diablo used (beta 16) and isn't working so well. Could someone post the beta 16 version for us? pretty please? :)

I don't think any other program is supposed to read the .CRW file generated by CHDK - this isn't an actual CRW file, as CRW files have defined headers and data structures, this file doesn't. From what I could figure out, it's just a heap of sensor data, 10 bits per pixel, w/o Bayer interpolation. I haven't played around with RAW readers, but if none of them can be persuaded to read this kind of file, I could maybe work out a conversion algorithm in Free Pascal, to convert these files to 16-bit RAW that can be read with Photoshop or other imaging software capable of reading RAW. That is, if I can figure out this Bayer interpolation thingy. I know very little about digital imaging.

Anyway, many thanks to all the people who are developing CHDK, and especially to Diablo, our own community hero :) I just hope you'll be back soon...
« Last Edit: 06 / February / 2009, 19:19:23 by tybofborg »

Re: A1000IS porting...
« Reply #103 on: 07 / February / 2009, 18:33:33 »
Hey, to answer tybofborg and mattock's question, the 12/08 version that Diablo made is for the 1.00a firmware. Stick to the 12/02 version if you have 1.00b firmware. :)

As far as dng4ps2 working with these raw files, I remember having a similar problem where it wouldn't detect any files. I also remember making a new camera profile, but the files it created still weren't readable by any programs that can read raw. I don't think raw is fully implemented yet.

And you're right tybofborg, the CRW from CHDK is just a dump from the image sensor.

As far as the development goes, I'm not sure. Diablo hasn't posted here in a while. I hope everything is well with him.  :-[
« Last Edit: 09 / February / 2009, 00:30:22 by tyrantt23 »

Re: A1000IS porting...
« Reply #104 on: 09 / February / 2009, 13:00:31 »
Thanks, tyrantt23, I missed that bit about the 1.00a firmware for the 12/8 download.

And tybofborg, I found a link to the dng4ps2 beta 16 here:
http://code.google.com/p/dng4ps2/downloads/detail?name=dng4ps2-0.2.3-beta16.exe&can=2&q= (from a google search on the file name)

While Diablo may have gotten some results with it, I can't get this version to recognize the raw files, same as the current versions.

Re: A1000IS porting...
« Reply #105 on: 18 / February / 2009, 00:35:18 »
Very little experience w/cameras and it's been 20 years since I coded anything

Loaded the 12/2 binary. Took some time to get "BOOTDISK" text into the SD mbr - hadn't seen that one before and was confused when setting "bootable" in the format apps and partitioners didn't work.

CHDK works more or less (an hour of so of fiddling), except:

1) The two partition scheme outlined in the "Bootable SD" page here doesn't seem to work as advertised. The A1000 just uses the small first partition instead of loading from that and then using the large second partition for storage. Does anybody know what logic is supposed to cause the camera to open the 2nd partition? What the process is? W/out knowing anything about the process, it's hard to figure if something I'm doing causes the problem.  The card is a 4GB card. The partitioner I used refused to format anything less than 16 MB w/FAT16; the size of the first (small) partition size is about 24MB. I tried using FAT12, but I think I hadn't got the mbr right at that time. I might try that again, see it shrinking the partition to 2 or 3 MB helps. If not I'll just use FAT16 w/one big partition; just figured I'd see what happens in case I went to bigger cards.

2) Getting out of the ALT mode doesn't seem real consistent. Sometimes the DISP does it, sometime the MENU does it, sometimes ALT does it, sometime SHOOT does it (though last try at that started the stub script). Maybe I just haven't figured it out yet, but I did think the FAQ said that ALT was the way out of that mode.

3) CHDK doesnt want to clear the screen b4 a rewrite - or maybe that's the Canon software?. Others have noted this. It confuses the menus a bit and makes using the OCD editor something of a guessing game.

#1 is the

Anybody know if Diablo uploaded source code? It looks like he may have gotten diverted into other paths for now - maybe burned out a little by that fantastic sprint he put on last year. <g>

Cheers, Rufus


Offline reyalp

  • ******
  • 14037
Re: A1000IS porting...
« Reply #106 on: 20 / February / 2009, 19:52:56 »
I am aware of the screen not refreshing issue. The function "RefreshPhysicalScreen" is not working at all.
Calling or not calling it has no effect. I compared it with disassembly of A720 and G9. For A1000, the method is slightly different. But I made sure that the caller and callee are matched with other cameras. So for now, refreshing can be done by half pressing shoot button.
Don't know if you are still working on this, but I encountered a similar thing on the SD990. It appears to me that there are a pair of functions, one of which looks a lot like what we call "RefreshPhysicalScreen" on other cameras. You have to call both for the update to happen. They are probably intended to wrap the screen access (you can see from the callers they are called in pairs), but just calling them in vid_bitmap_refresh is semi-functional.

On the SD990, these functions refer to strings "ScreenLock" and "ScreenUnlock". ScreenUnlock is what I initially took to be RefreshPhysicalScreen. On SD1100 and a720, the corresponding functions refer to
with the second being identified as RefreshPhysicalScreen.

Note that RefreshPhysicalScreen is called with an argument (1) but on these cameras, it doesn't actually use it.
Don't forget what the H stands for.

Re: A1000IS porting...
« Reply #107 on: 26 / March / 2009, 06:30:30 »
Just got the A1000 IS, and I'd be pretty thrilled if I could get CHDK working on it. I downloaded Diablo's firmware and followed the instructions in the FAQ for putting it on the card, but as far as I can tell, there's no noticeable difference in the interface when I turn the camera on.

There are two things I'm suspicious of that may or may not be relevant (I don't really know what I'm doing here). The first thing is when I check the firmware version after touching a "ver.req" file, all I get is "Firmware Ver." and not the detailed information the A1000IS wiki page says I should get. So not knowing whether I have version 'a' or 'b', I tried both firmware versions, both with the card locked and unlocked. No dice.

Another thing I'm suspicious of is when I went to make the partition on my SD card bootable with "cfdisk /dev/sdc", I got the error "FATAL ERROR: Bad primary partition 0: Partition ends in the final partial cylinder". So I used fdisk instead, which didn't seem to have any problem.


Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A1000IS porting...
« Reply #108 on: 26 / March / 2009, 07:04:58 »
Another thing I'm suspicious of is when I went to make the partition on my SD card bootable with "cfdisk /dev/sdc", I got the error "FATAL ERROR: Bad primary partition 0: Partition ends in the final partial cylinder". So I used fdisk instead, which didn't seem to have any problem.

'bootable' in the context of CHDK is not the same as for PC OS's: you need to write a special bootflag in the cards'
sector 0. Read about it here: http://chdk.wikia.com/wiki/Bootable_SD_card

to summarise: you need to write 'BOOTDISK' to sector 0 @ offset 0x40



Re: A1000IS porting...
« Reply #109 on: 27 / March / 2009, 02:24:54 »
So definitely one of my problems was I was using FAT32 (I have an 8gb SD card). I created a small FAT16 partition as instructed in the FAQ, and touching a ver.req file on that allowed me to get the exact same firmware version information as is showed on the A1000IS wiki page.

Then I made the small FAT16 partition bootable the propper way, but I still couldn't get CHDK to boot. The camera always said "card locked" and "card full", which I assume is a good indication that CHDK did not boot. I tried recreating the partition table a couple times, and I also tried formatting the small partition on the camera (because I read somewhere that sometimes this needs to be done), but when the camera formats the card it wipes out my partition table and replaces it with one big FAT32 partition. Grrr :-P.


Related Topics