Delay the flash untill a button is pressed, during long exposure - page 3 - Script Writing - CHDK Forum

Delay the flash untill a button is pressed, during long exposure

  • 32 Replies
  • 15131 Views
*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #20 on: 28 / November / 2008, 05:39:54 »
Advertisements
Quote
rem flash setting
@title flash
@param a off or on
@default a 1
set_prop 16 a

a = 1 -> Flash on. a = 2 -> Flash Off. a = 0 -> Flash Auto.

this script is working on my s3is in non-movie mode. so it *should* work on your digic3 when you replace the 16 with the 143, no?
thats correct, original canon osd still shows flash off, but flash fires
to change back i have to set original flash setting to off

Maybe the behaviour i described above is because of the flash is not full charged

thanks

*

Offline fe50

  • ******
  • 3131
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #21 on: 28 / November / 2008, 06:12:24 »
...This script makes sense only for S series for picture shooting in video mode...

Do you mean: ...because they don't have a dedicated video button ?
Or is there a further difference to the other models, e.g. to the SD series ?

On the newer Ixus models you can attach Rec. movie to the Print button and use it with a long press.

In still record mode then you get the remaining video time OSD and you can record a movie without changing the mode, recording starts directly & after stopping the movie recording you are back...so this seem to bee the same procedure as on the S-series with the dedicated movie button ?

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #22 on: 28 / November / 2008, 06:24:14 »
what happens when you press the shutter during such a video recording? i guess the recording stops? on s-series, a picture is taken, and the movie continues... see my video for example

*

Offline fe50

  • ******
  • 3131
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #23 on: 28 / November / 2008, 06:59:06 »
what happens when you press the shutter during such a video recording? i guess the recording stops? on s-series, a picture is taken, and the movie continues... see my video for example
Yes, recording stops...ok, that's the difference...thx


*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #24 on: 28 / November / 2008, 07:12:03 »
On the newer Ixus models you can attach Rec. movie to the Print button and use it with a long press.

In still record mode then you get the remaining video time OSD and you can record a movie without changing the mode, recording starts directly & after stopping the movie recording you are back...so this seem to bee the same procedure as on the S-series with the dedicated movie button ?

Thats also on ixus70
pressing shutter or let a script call shoot_full stops movie recording

i have edit my post above. after the scipt finished the flash fires itself?!?

Re: Delay the flash untill a button is pressed, during long exposure
« Reply #25 on: 28 / November / 2008, 08:00:29 »
Hi all,
first of all I must declare that I don't understand script writing.
As I uderstood the script ewar posted wait 1000 untill fire the fire.
I tested it on my g9 and it does nothing, nor in video mode nor in single shot mode.
I've changed the set_prop to 16, 79, 122, nothing in any case.
What else should I try?

This is the last script I've runned:

rem set flash mode to "off" before shoot
press "shoot_half"
sleep 1000
rem override flash mode to "on"
set_prop 79 1
press "shoot_full"
sleep 1000
release "shoot_full"
end

bye, and thanks to all :)
« Last Edit: 28 / November / 2008, 08:03:00 by bongo_bingo »

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #26 on: 28 / November / 2008, 14:58:00 »
Hi all,
first of all I must declare that I don't understand script writing.
As I uderstood the script ewar posted wait 1000 untill fire the fire.
I tested it on my g9 and it does nothing, nor in video mode nor in single shot mode.

This script is only for S-series with "picture shooting during video recording" built-in feature.

Re: Delay the flash untill a button is pressed, during long exposure
« Reply #27 on: 29 / November / 2008, 10:52:01 »
Sorry for the misunderstanding.
Is there something that can be done to control the flash during a long exposure shot?


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #28 on: 29 / November / 2008, 10:53:53 »
yes, the stuff from here
i will try that on my s3is.

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Delay the flash untill a button is pressed, during long exposure
« Reply #29 on: 29 / November / 2008, 17:10:08 »
awwrite, override of flash during video on s-series (and probably tx-1 as well) is in trunk now.
next project will be the manual firing of flash via script. thanks ewavr!

 

Related Topics