Fast intervalometer problems - Script Writing - CHDK Forum

Fast intervalometer problems

  • 3 Replies
  • 2991 Views
Fast intervalometer problems
« on: 09 / November / 2008, 14:44:06 »
Advertisements
Hello,

I need your help! I need an intervalometer to take pictures every 5 seconds. I'm using a Powershot 570IS and Allbest v51. I've wrote the following script:

Code: [Select]
@title KAP vpiorno 3.3
@param a Interval (Secs)
@default a 5

t=get_tick_count
if a<5 then a=5
d=a*1000

goto "shoot"

:shoot
if get_tick_count<t then goto "shoot"
t=t+d
shoot
goto "shoot"

end

I've tested it running it with the camera pointed to a stopwatch. The script works fine with intervals over 7 seconds, but I cannot get pictures every 5 seconds. The minimun interval I've got is around 6 secs. I've tried reducing image size (even though I need max resolution, just to try) and the results were the same.

Is there any problem with the code? Or is there any inherent camera limitation? I would greatly appreciate any suggestion.

Thanks!

*

Offline Hacki

  • ****
  • 359
  • EOS 80D
Re: Fast intervalometer problems
« Reply #1 on: 09 / November / 2008, 15:35:00 »
Works perfectly fine here. Try setting the review time to "Off" in the camera menu.

*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: Fast intervalometer problems
« Reply #2 on: 09 / November / 2008, 15:42:56 »
And make sure RAW is OFF, they take a while to save.

Re: Fast intervalometer problems
« Reply #3 on: 09 / November / 2008, 18:38:49 »
Problem solved!

I've set review time to off, and now I can get intervals under 4 seconds.

Many thanks, fudgey and Hacki!!



 

Related Topics