TX1 No flash on video - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

TX1 No flash on video

  • 5 Replies
  • 2247 Views
TX1 No flash on video
« on: 30 / November / 2008, 22:17:41 »
Advertisements
Camera TX1  101B
Found the following when updating to CHDK 603. GREAT new features.
No added menu items for flash on video and no flash when video running.
At least from trunk530 to trunk608(latest), the following line seems to be missing in "camera.h" in the include directory.

" #define  CAM_HAS_VIDEO_BUTTON       1 "  in the TX-Series section.

Added it and nothing appears amiss, now have the added menu items and video button recognized.
The flash on video works great.
I'll have to try the latest FM script to see if that now works. It yelled about no video button.
Should have hit the camera properties key sooner (in CHDK_Shell) as it showed CAM_HAS_VIDEO_BUTTON = 0
Now it shows a 1.
Also winexplorer shows diskboot.bin = 259KB, ps.fir = 260KB, for rev.608.
Without the line added, it's 249KB and 250KB.       

Thanks to All.  George

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: TX1 No flash on video
« Reply #1 on: 01 / December / 2008, 02:50:50 »
thats odd, i thought all the time the tx-1 has this #define already.
will add it.

Re: TX1 No flash on video
« Reply #2 on: 01 / December / 2008, 07:23:14 »
I thought it odd also. There must not be many TX1 users, too bad. Fudgeys fast MD script dated 80914,now works fine. All adds from rev.603 now work great. Thank you for all your work and fast response.
Is petheads timestamp in the future?

Thanks again,  George

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: TX1 No flash on video
« Reply #3 on: 01 / December / 2008, 07:28:06 »
the timestamp will be integrated, yes. i dont know when though.


Re: TX1 No flash on video
« Reply #4 on: 04 / December / 2008, 16:47:21 »
Can the flashlight be hacked with CHDK in order to use it as a spotlight (continuously lit) when shooting videos?

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: TX1 No flash on video
« Reply #5 on: 05 / December / 2008, 01:11:35 »
i dont think this is possible. it would draw way to much power, would thus become too warm and will likely break something.

 

Related Topics