IXUS 860 IS - Firmware version request cannot be performed, please help :) - page 2 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

IXUS 860 IS - Firmware version request cannot be performed, please help :)

  • 16 Replies
  • 6321 Views
*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Advertisements
well, if it was the wrong firmware the cam still would try to boot it but would not succeed and get stuck.

I guess that leaves only few possibilities:

1) wrong diskboot.bin - are you sure you got it from an ixus860_sd870-100c.zip ?
2) you are the (unlucky) owner of a different firmware
3) try -if possible- a different card, preferably 2 Gb or less, some cards
     don't allow writing to their bootsector (that's rare though)

PS: just thought of sth, if you formatted after make bootable, you'll need to do it again.
      so:  format -> make bootable -> copy diskboot.bin to card

Thanks whim, my replies as follow
1) I got the diskboot.bin file from allbest-ixus860_sd870-100c-51-485 so i guess that is the right one
2) Dang :(
3) Ok, I'll try it with another card, mine is a Toshiba 2GB card.
And yes I do make the card bootable after every FAT16 formatting

nrchy,

...what sd card do you use (capacity/type) ? - you need a non-SDHC card with <= 4GB, for SDHC cards with >4GB the card have to be prepared for multi partition support...

Try it with the sd card shipped with the camera (16/32MB), with cardtricks format it, make it bootable, copy the (fresh downloaded) diskboot.bin to the root of your card, lock the card...

*EDIT:
 :) Oh, hi wim, you were faster...
Quote
2) you are the (unlucky) owner of a different firmware
hmmm - then the cam would crash, but as i understood it boots up as normal, so this seems not to be the problem...

fe50,
Alright I'll give it another go with the original card that came with the cam. And as for the cam it booted normal after i put in the diskboot.bin SD card.

Thank you for all your help guys, really appreciate this. Will report back with the tests  8)
It does make sense that the SD card is at fault since i couldn't even do the firmware request.
Back to work!

LATEST UPDATE:
Problem did lie in the SD card, after i used the stock SD card CHDK loaded just fine! Firmware check works too!
So the lesson i learned here is to not get anymore Toshiba SD cards! ehehe

Thanks so much for the help guys, time for some CHDK goodness!  :xmas
« Last Edit: 21 / August / 2008, 11:09:47 by nrchy »

Guys,

Another question. What SD cards would you guys suggest that is compatible for use with CHDK? Brand?

*

Offline dzsemx

  • ****
  • 302
  • [SX40HS][A650][A630]
for me every cheap sd card worked with chdk :)


*

Offline fe50

  • ******
  • 3119
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Guys,

Another question. What SD cards would you guys suggest that is compatible for use with CHDK? Brand?

A good choice is always Transcend, good in support & warranty...i also use Corsair (no problems yet) and Ultron (only the HiSpeed ones, cheap, some mechanical issues like cracks after long extensive usage)...

Re: IXUS 860 IS - Firmware version request cannot be performed, please help :)
« Reply #15 on: 03 / December / 2008, 17:27:53 »
I've gotten all the way to this step, and no further:
"- While still in PLAYBACK MODE press your camera's "Menu" button to open Canon's Menu
- Scroll to the bottom of the menu to the "Firm Update" option which should now be available. If by chance that you fail to see the "Firm Update" menu option try pressing your Playback button twice. You might have to wait 2 seconds between presses."

Nothing shows for me.

I am an SD750 user with Firmware Vers. GM1.02A

Any ideas?

Thanks.

rick

*

Offline fe50

  • ******
  • 3119
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: IXUS 860 IS - Firmware version request cannot be performed, please help :)
« Reply #16 on: 04 / December / 2008, 03:27:15 »
--> Load Firmware doesn't show in MENU after install  ***pls. no double posts !***

 

Related Topics