supplierdeeply

Can't get CHDK to load on SD1100 IS

  • 5 Replies
  • 1678 Views
Can't get CHDK to load on SD1100 IS
« on: 13 / December / 2008, 23:40:33 »
Advertisements
I followed the newbie guidance, formatted, made bootable, loaded the version for my firmware (1.01b) and when the camera is powered up - all it says is that the card is locked - no changes have happened to any menus nor is there a CHDK firmware splash.  I get the same thing starting the camera in both record and play modes. 

I've also tried a manual boot (with the card lock off) per directions, and still nothing works.  The directory of the card shows the appropriate files. 

Any ideas?



*

Offline reyalp

  • ******
  • 11514
Re: Can't get CHDK to load on SD1100 IS
« Reply #1 on: 13 / December / 2008, 23:57:00 »
Most likely one of
haven't correctly made the card bootable,  haven't got DISKBOOT.BIN in the root directory, or the card isn't formatted FAT16
Don't forget what the H stands for.

Re: Can't get CHDK to load on SD1100 IS
« Reply #2 on: 16 / December / 2008, 16:10:28 »
I've had the same problem. I've tried to use it for the first these last few days. I am using an SD1100 IS with firmware version 1.01a.

My status:
1. I formatted my 2GB sd card in the camera, so I know it's formatted correctly.
2. Using gparted in Ubuntu, I made sure the "boot" flag was selected for the sd card, so it's bootable.
3. DISCBOOT.BIN is in the root directory of the card.
4. I locked the card and put it in my camera.
5. I turned my camera on

Bug: Displays "Card is Locked" whether in play or record mode. Pressing print button does not open Alt mode.

I don't know what else is to be done.

*

Offline Hacki

  • ****
  • 358
  • SX100
Re: Can't get CHDK to load on SD1100 IS
« Reply #3 on: 16 / December / 2008, 16:22:26 »
Quote
2. Using gparted in Ubuntu, I made sure the "boot" flag was selected for the sd card, so it's bootable.

Which is wrong. Nowhere here its said that you can use the boot flag. Canon cameras check for a string ("BOOTDISK") at offset 0x40, which is not a FAT standard.

Do it like described here: http://chdk.wikia.com/wiki/Bootable_SD_card#Linux: and you'll be fine..


*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Can't get CHDK to load on SD1100 IS
« Reply #4 on: 16 / December / 2008, 16:54:10 »
Quote
3. DISCBOOT.BIN is in the root directory of the card.

also, mind the spelling: it's DISKBOOT.BIN  ;)

wim
« Last Edit: 16 / December / 2008, 17:16:00 by whim »

Re: Can't get CHDK to load on SD1100 IS
« Reply #5 on: 16 / December / 2008, 20:21:16 »
Quote
2. Using gparted in Ubuntu, I made sure the "boot" flag was selected for the sd card, so it's bootable.

Which is wrong. Nowhere here its said that you can use the boot flag. Canon cameras check for a string ("BOOTDISK") at offset 0x40, which is not a FAT standard.

Do it like described here: http://chdk.wikia.com/wiki/Bootable_SD_card#Linux: and you'll be fine..

Ok, thanks! I did the one using hexedit, and it boots now!

 

Related Topics