Curious results when deleting images via a uBASIC script - General Discussion and Assistance - CHDK Forum supplierdeeply

Curious results when deleting images via a uBASIC script

  • 1 Replies
  • 1415 Views
*

Offline zeno

  • *****
  • 885
Curious results when deleting images via a uBASIC script
« on: 14 / December / 2008, 11:54:22 »
Advertisements
I've been playing with my string-enhanced uBasic today. I added a function to obtain the name of the last image taken, as well as one to delete a named file. I managed to get both to work - the CHDK 'remove' function does remove the file from the card. However the camera still thinks the images are there when you switch to play mode. The deleted images are not displayable - the camera reports "Unidentified Image" instead. If the card is removed and replaced everything is fine.

I presume that the 'image database' on the card is not updated when 'remove' is invoked, so it still has entries for the images that were deleted. Presumably when a card is inserted the camera checks the consistency of the database and removes bad entries.

Does anyone know how to invoke the 'consistency check' function programatically?
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

*

Online reyalp

  • ******
  • 12111
Re: Curious results when deleting images via a uBASIC script
« Reply #1 on: 14 / December / 2008, 19:34:08 »
No, but if you can find it, that would make make quite a few of us happy. You get the same result deleting from the file browser or using lua os.remove()

This issue also affects USB transfer.

Don't forget what the H stands for.

 

Related Topics