S2 IS Complete Failure - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

S2 IS Complete Failure

  • 4 Replies
  • 2567 Views
*

jkd159

S2 IS Complete Failure
« on: 14 / December / 2008, 18:20:25 »
Advertisements
Hi folks,

I've got an S2 IS which is exhibiting total failure.  When I turn it on, the orange power light comes on and it wiggles the lens a bit, then gives three beeps and fails.  Nothing on the LCD or viewfinder, no error message, no E18.  When I turn it on in playback mode, the green power light comes on, but nothing appears on the LCD or viewfinder.  I've tried brand new batteries.  I've tried removing the coin cell and leaving it out for a few minutes.  I've tried holding down MENU when starting the camera.

Any ideas?

Just to be clear, this happens with CHDK or a blank SD card.  So I don't think it is a CHDK problem.  Just thought I'd ask here because you are all experts, and I've been using CHDK for long enough that if it is known to cause some sort of long term failure then that might be the problem.

Thanks!

*

databoy

Re: S2 IS Complete Failure
« Reply #1 on: 14 / December / 2008, 22:13:42 »
The CHDK developers are quite brilliant with software development. Don't expect camera servicing technical advice; that is a specialised field with specialised tools in a dust free laboratory.

Try reading this page:

Repair help (Service mode?)

and this page:

Canon Talk Forum: Digital Photography Review

If you have the technical experience and think that you can repair your camera think twice. There is a 99% chance it will end up as as an expensive fishing sinker.

I have over 30 years servicing experience, so I posses a small amount of technical knowledge of how things work, and when not to tamper with equipment. My advice is to take it to a Canon service centre and have the Canon labs recondition it for you. If it costs you half the amount of a new camera you will have a reconditioned camera. If you are not prepared to spend the money, purchase a new camera and take out a 5 year extended warranty.   

*

jkd159

Re: S2 IS Complete Failure
« Reply #2 on: 14 / December / 2008, 22:27:21 »
Thanks for the quick response.

Yes, I agree that if the problem is hardware, then I don't want to fix it myself.  However, I think the problem might be software related since the camera exhibits the same failure in both photo and replay mode.  When I have seen Canon cameras with some sort of hardware failure (i.e. stuck lens) the playback mode still works fine.  This camera fails to boot (for want of a better term) in any mode.  So I'm hoping that someone has seen this sort of symptom before and can recommend a possible fix.

Thanks!

*

Online reyalp

  • ******
  • 13826
Re: S2 IS Complete Failure
« Reply #3 on: 14 / December / 2008, 22:43:29 »
However, I think the problem might be software related since the camera exhibits the same failure in both photo and replay mode. 
Since this happens without CHDK, even a "software" problem would be firmware, which would still require factory service.

I'd guess it was hardware myself, just not something record specific like the lens mechanics. Beeping with no display suggests that either the display controller doesn't work, or it can't get far enough into the boot process to activate the display.

One other thought is that it's just not getting enough power to boot up, perhaps caused by a loose connection or corrosion on the battery contacts. Have you tried an external power supply ?
Don't forget what the H stands for.


*

jkd159

Re: S2 IS Complete Failure
« Reply #4 on: 14 / December / 2008, 23:06:07 »
The battery contacts look pristine.  I'll see if I can get hold of an external power supply and give that a try.

Thanks!

 

Related Topics