Video bitrate for S5 exists, but doesn't work... Is it a bug ? - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

Video bitrate for S5 exists, but doesn't work... Is it a bug ?

  • 18 Replies
  • 5430 Views
*

Offline reyalp

  • ******
  • 12793
Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #10 on: 23 / January / 2009, 22:12:57 »
Advertisements
One issue is if I set it to quality and set the quality to 99, it crashes after recording a few seconds and the camera shuts off (pre-emptively, so the lens stalls).
You've set the quality beyond what the processor or SD card can keep up with. Solution: Don't do that.
Don't forget what the H stands for.

Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #11 on: 23 / January / 2009, 23:39:01 »
I figured as much, but thought I'd report it anyways.
________________________
Jim Manning
Canon Powershot S5 IS (1.01b)

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #12 on: 24 / January / 2009, 04:15:01 »
so you reported a bug, but you forgot the most important thing: it DOES work, doesnt it? besides the 99 thing, you can set to any quality and bitrate (up to the speeds the card can handle)? and the resulting files turn out smaller/bigger than usual?

Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #13 on: 24 / January / 2009, 08:18:25 »
Wow! It really works. Thanks alot! :)

My test results:
I'm using 4GB SDHC card, class 6.
In the bitrate setting, i'm able to get to 3x with no problem with about 5500KB/sec.
In the quality setting, 99% seems too much for the camera and it fails to operate like said before.
The maximum possible quality is 96%.
97% starts to build up the buffer on the screen until it becomes red and stops the recording.

I have some questions:
1. The squares on the right building up until becoming red is the warning buffer right?
2. What's the fast video control setting ?
3. In the ZIP package there is a PS.FI2. Does it mean i can run CHDK on my 16GB card using "firm update" mode? (and not by bootable card)



*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #14 on: 24 / January / 2009, 08:30:03 »
1. correct
2. ability to pause/resume video, doesnt work on a lot of cameras
3. correct :)

Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #15 on: 24 / January / 2009, 08:56:30 »
Further tests:

Using the PS.FI2 i was able to run CHDK on my 16GB card for the first time! No more 4GB barrier!!!  :D

With 16GB card (class 6) i was able to get to 98 and 97 quality for few min. Maximum bitrate in that modes - 7MB/sec for a temporary time, and then the camera shuts off.
Quality 99 crashes after short time.

Still, quality 96 is the maximum stable one - with 6MB/sec.
Bitrate 3x mode yields 5.5MB/sec.

Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #16 on: 24 / January / 2009, 08:59:59 »
Another question:
How do i pause the video using "fast video control" setting ?

Re: Video bitrate for S5 exists, but doesn't work... Is it a bug ?
« Reply #17 on: 24 / January / 2009, 15:19:07 »
Yes, it does work and there are differences in the size of the video files corresponding to the bitrate/quality settings. Awesome work!
________________________
Jim Manning
Canon Powershot S5 IS (1.01b)


*

Offline ewavr

  • ****
  • 1057
  • A710IS

 

Related Topics