trouble booting a650is from 4GB card, os x formatted - General Help and Assistance on using CHDK stable releases - CHDK Forum

trouble booting a650is from 4GB card, os x formatted

  • 8 Replies
  • 2799 Views
trouble booting a650is from 4GB card, os x formatted
« on: 20 / December / 2008, 03:54:39 »
Advertisements
I have a 4GB SDHC card that i'm trying to use to boot an a650is. i'm running os x 10.5.6.

I can successfully format the card as FAT16. An a570is can boot from this card. however, the "make bootable" function in chdk doesn't allow it to autoboot with the card.

i suspect that the problem is that i don't understand quite where to put the boot file name. i have gotten this to work with smaller cards.

the info from hexedit before and after modification is included in the text file. seems like the forum doesn't like previewing that info.

any suggestions?

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: trouble booting a650is from 4GB card, os x formatted
« Reply #1 on: 20 / December / 2008, 04:30:03 »
CHDK routine somehow didn't write it properly ?

Try hex-editing: it now says BOO"ir.K at offset 0x40

Change that into BOOTDISK and it should work ...

Unless of course the card's sector 0 is foobar'ed ...

hth,

wim

edit: you might also want to do a string search in your CHDK binary to see if BOOTDISK string is corrupted
« Last Edit: 20 / December / 2008, 05:05:42 by whim »

Re: trouble booting a650is from 4GB card, os x formatted
« Reply #2 on: 20 / December / 2008, 11:21:15 »
>>Change that into BOOTDISK and it should work ...

nope, if i set it with hexedit that still happens. i'm really not sure why its getting overwritten.

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: trouble booting a650is from 4GB card, os x formatted
« Reply #3 on: 20 / December / 2008, 11:49:41 »
Is this a vanilla autobuild CHDK, or did you compile your own ?

on a practical note: consider formatting your card test-wise on somebody's Winblows w/ CardTricks,
just to exclude card malfunction.

edit: another idea: compile from source your own bootable.exe under MacOS

wim

« Last Edit: 20 / December / 2008, 11:52:11 by whim »


Re: trouble booting a650is from 4GB card, os x formatted
« Reply #4 on: 20 / December / 2008, 11:52:14 »
vanilla autobuild

i think card malfunction is ruled out by the fact that the a570 can boot, just not autoboot.

yeah, i'll try formatting from windows when i have a chance. for now i need to turn my attention toward my soldering iron.

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: trouble booting a650is from 4GB card, os x formatted
« Reply #5 on: 20 / December / 2008, 11:56:59 »
Quote
i think card malfunction is ruled out by the fact that the a570 can boot, just not autoboot.

wouldn't be so sure about that - it's only the autoboot that looks at the string at 0x40 ....

what are you soldering, cam remote ?

wim

Re: trouble booting a650is from 4GB card, os x formatted
« Reply #6 on: 20 / December / 2008, 12:01:03 »
>>what are you soldering, cam remote ?

power off of camera via usb. arduino controller with opto-isolator.

i'll document everything as soon as it all works. almost certainly by the first.

Re: trouble booting a650is from 4GB card, os x formatted
« Reply #7 on: 21 / December / 2008, 20:05:59 »
wow, card tricks made easy work of that problem.

still, would be nice if i could could set this up on my mac.


*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: trouble booting a650is from 4GB card, os x formatted
« Reply #8 on: 21 / December / 2008, 20:52:04 »
BTW, found you this (by googling on "format as FAT16 under Mac OS"; the meat is in the 4th post)

Note that, as a windows user, i have obviously not tried this ...

cheers,

wim

 

Related Topics