Help with A590 - General Discussion and Assistance - CHDK Forum  

Help with A590

  • 15 Replies
  • 5694 Views
*

Offline JCW

  • *
  • 8
Help with A590
« on: 25 / December / 2008, 16:33:41 »
Advertisements
Can't get CHDK to boot on new A590 IS.
1. Verified firmware is GM1.01B
2. From CHDK-SVN Autobuild Download page downloaded "a590-101b-0.8.10-651-full.zip"
3. Used CardTricks to load SD.
4. Camera power-on gives "Card Locked!" message.

Notes:
CardTricks version 1.3.9.0 (latest for old PC running ME. Sorry, I'm normally a Mac user)
Small SD card (256 MB)
Also tried Small version of download, same result.

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Help with A590
« Reply #1 on: 25 / December / 2008, 16:49:17 »
Hello & welcome JCW !

looks like you forgot to make the card bootable - click "Make Bootable" in CardTricks, then lock the card again...

*

Offline JCW

  • *
  • 8
Re: Help with A590
« Reply #2 on: 25 / December / 2008, 17:11:45 »
"Make Bootable" is grayed out. According to documentation on the Cardtricks Wiki a grayed out button indicates that the card is already bootable.

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Help with A590
« Reply #3 on: 25 / December / 2008, 17:27:40 »
"Make Bootable" is grayed out. According to documentation on the Cardtricks Wiki a grayed out button indicates that the card is already bootable.

Then you should see it in CT... "CHDK Autorun" should be "ON (BOOTDISK at 0x40) (see attached screenshot)

Can you format the card with CT ? (backup your images on this card first !)


*

Offline JCW

  • *
  • 8
Re: Help with A590
« Reply #4 on: 25 / December / 2008, 17:52:01 »
In CT, the" CHDK Autorun:" field is blank.

I had first started the process by clicking "Format as FAT" (no images on card). Nothing much seemed to happen except the vers.req file appeared on the card, I proceeded to check the camera's firmware version, etc.

I have started over a couple of times, clicking "Format as FAT". Again, nothing seems to happen, and all the CHDK files previously written have stayed intact. Looks like the card is not being formatted properly?

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Help with A590
« Reply #5 on: 25 / December / 2008, 18:04:08 »
Hmm - after pressing "Format" you should get a warn messagebox, then you should see a command window (dos box) for a short time...

You can also try doing it manually:
  • format the card manually in windows, e.g. in a dos box with 'format' or with rightclick to the card drive in an explorer window
  • start a dos box, goto the cardtricks directory, there you'll find the "bootable.exe"
  • run it with the drive letter, e.g.  bootable x:
  • (r)ead shows the current state, (w)rite writes the bootable flag - the return value then should be 0

The A590 can start CHDK only with the autoboot method, so the BOOTDISK flag on the card is needed; can you try another card (max. 4GB size) ?
« Last Edit: 25 / December / 2008, 18:08:54 by fe50 »

*

Offline JCW

  • *
  • 8
Re: Help with A590
« Reply #6 on: 25 / December / 2008, 22:34:25 »
1. Re-formatted the card manually in windows
2. Ran full scandisk, no errors.
3. In DOS window...c:/windows/desktop/cardtricks>bootable f:   (F=cardreader)
    (r) read or (w) write ?
    entered: <w>
    returned: return value = 3   (not 1)
4. Went ahead and loaded CHDK files. As before, in CT, the" CHDK Autorun:" field is blank.
5. No surprise, camera is not booting CHDK.

Will get & try another card...

*

Offline Hacki

  • ****
  • 358
  • SX100
Re: Help with A590
« Reply #7 on: 26 / December / 2008, 00:19:48 »
Quote
3. In DOS window...c:/windows/desktop/cardtricks>bootable f:   (F=cardreader)

The "BOOTDISK" flag for which the canon cameras are searching is not the same as the FAT "boot" flag.

Open the SD card directly with a hex editor and see if the BOOTDISK flag is at offset 0x40.




*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Help with A590
« Reply #8 on: 26 / December / 2008, 18:56:56 »
...The "BOOTDISK" flag for which the canon cameras are searching is not the same as the FAT "boot" flag.
...Open the SD card directly with a hex editor and see if the BOOTDISK flag is at offset 0x40.

That's what bootable.exe does, but regarding to the return value it can't write to the first 512 bytes of the card.
Maybe a software (e.g. virus scanner or other protection software) prevents it from writing to this area, maybe the card reader or the card is the problem...

*

Offline JCW

  • *
  • 8
Re: Help with A590
« Reply #9 on: 26 / December / 2008, 20:41:54 »
Wow. Getting nowhere fast. Very frustrating. Just want to take pictures.

1. Not the card. CardTricks performed EXACTLY the same way with a new SanDisk Ultra II 2GB as it did with the first card. Conclude, it's not the card.

2. Tried as Hacki suggests to: "Open the SD card directly with a hex editor and see if the BOOTDISK flag is at offset 0x40."
    ---  On Windows ME machine, couldn't get HDHacker to run..."HDHacker requires Administrator's Privileges to Start".  (but no admin in ME)

    --- On Mac tried to use hexedit in terminal window as suggested here: Getting CHDK working on the Canon S5 IS from Mac OS X | B. Mann Consulting (following instructions to use macports), but hexedit does not execute.

    --- Also on Mac tried suggestion here: Bootable SD card - CHDK Wiki:, which says to execute: :sudo newfs_msdos -F 16 -v SX100IS -O -b 4096 -c 128 /dev/disk2s1" in terminal mode. Substituted "A590IS" for "SV100IS" and used correct diskxxx, but to no avail.

Any suggestions welcome


 

Related Topics