SX110IS - howto start porting - page 27 - DryOS Development - CHDK Forum  

SX110IS - howto start porting

  • 573 Replies
  • 230879 Views
Re: SX110IS - howto start porting
« Reply #260 on: 25 / April / 2009, 15:08:37 »
Advertisements
Best guess is that the autobuild server is using the wrong keys for encrypting the image.
I also think so, because the Autobuild Server Version was stable. But after some updates the Autobuild Server Version isn`t stable anymore
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

Re: SX110IS - howto start porting
« Reply #261 on: 25 / April / 2009, 15:10:17 »
maybe a new bug:
If I turn on the camera (holding on/off about 2 secs), the lens goes out, but sometimes the cam turns itself off (black screen, and nothing more), and the lens stays out. If I try to turn on-off again, the lens don't goes correctly back, just half way. It is just with the latest version.

which Version Autobuild or latest?
For me this bug was only happen with the "old" (Autobuild) Version when you enable startup sound. But the newest Version fixed this.
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: SX110IS - howto start porting
« Reply #262 on: 25 / April / 2009, 15:35:52 »
the sx110 is not using d3enc, but a whole different key. thats why autobuild fi2 doesnt work.

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #263 on: 25 / April / 2009, 16:43:19 »
Thanks a lot chdkj
autofocus is now working :)

by the way.. instead of SET button.. can i use the Zoom button straightway?

like when i press zoom, it will zoom and auto focus both at the same time?
can zoom button be added in AF key[    ]?

Thanks a lot!

Hmmm, it looks to me that this should be possible. AF keys are hardcoded in gui.c. That means, this is not camera specific code, it is rather CHDK-core code. And therefore I'm not willing to change this code in some SX110-binaries (because we are leaving camera dependent code here).

@Main Developers
What are you thinking about?

Cheers!
« Last Edit: 25 / April / 2009, 16:48:44 by chdkj »
sx110


*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #264 on: 25 / April / 2009, 16:48:26 »
Works fine for me. Nice Work! Maybe you're able to add the following feature:
While shooting a video, you press a button wich toggles the AF-assist-beam (or AF-Light -- the red LED in front) on and off. So that you can shoot videos in dark areas (with at least a little bit light)

greetings
That's the same as http://chdk.setepontos.com/index.php/topic,2838.msg32903.html#msg32903.
@Main Developers
What are you thinking about?

Cheers.
sx110

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #265 on: 25 / April / 2009, 16:55:15 »
maybe a new bug:
If I turn on the camera (holding on/off about 2 secs), the lens goes out, but sometimes the cam turns itself off (black screen, and nothing more), and the lens stays out. If I try to turn on-off again, the lens don't goes correctly back, just half way. It is just with the latest version.
sounds foolish: are you really using the latest version? Battery state? I'm not sure that we are talking about a new bug.
Do you have more information about this?

Regards.
sx110

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #266 on: 25 / April / 2009, 17:11:28 »
Are you using the file attached to the post (latest) or the one from the autobuild server? - The autobuild one doesn't work, the attached one(s) does.

If version from autobuild server has a lot of errors, could it be removed (until it becomes stable)?

Best guess is that the autobuild server is using the wrong keys for encrypting the image.
I also think so, because the Autobuild Server Version was stable. But after some updates the Autobuild Server Version isn`t stable anymore
the sx110 is not using d3enc, but a whole different key. thats why autobuild fi2 doesnt work.

Puuuh...  it was not in my intent to release a new diff before fixing all bugs, but this is more a matter of personal view. You are right.

May I ask you to check in the attached diff (patch file)? It's based on r751.
Changelog
- fixed shooting overrides in capt_seq.c
- fixed optical zoom for record mode in movie_rec.c
- fixed AF scan during movie recording in movie_rec.c
- fixed PT_PlaySound in stubs_entry_2.S
- corrections for SX110 in camera.h
- minor changes in camera specific code (mainly clean up debug stuff and so on)

@PhyrePhoX: do we need a new category like d3enc_v2 or am I wrong?
EDIT: Attachment deleted (final version released on Autobuild already)
« Last Edit: 04 / November / 2009, 13:52:27 by chdkj »
sx110

Re: SX110IS - howto start porting
« Reply #267 on: 25 / April / 2009, 17:28:32 »
Works fine for me. Nice Work! Maybe you're able to add the following feature:
While shooting a video, you press a button wich toggles the AF-assist-beam (or AF-Light -- the red LED in front) on and off. So that you can shoot videos in dark areas (with at least a little bit light)

greetings
That's the same as http://chdk.setepontos.com/index.php/topic,2838.msg32903.html#msg32903.

No it isn't, look again at the two posts, one is asking for auto-focusing automatically when zooming, one is asking for an option to turn the AF-assist light on (semi-)permanently for shooting in the dark/low light.


*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #268 on: 25 / April / 2009, 17:47:30 »

No it isn't, look again at the two posts, one is asking for auto-focusing automatically when zooming, one is asking for an option to turn the AF-assist light on (semi-)permanently for shooting in the dark/low light.
Ok, I've to have express myself more precisely. Sorry for that.
AF assist light and AF rescanning while recording is not the same. What I meant is the need for change of CHDK-core code if one wants to use AF-assist light for shooting/recording (as same as for semi-automatically AF scan triggered by zoom lever - btw. a really nice idea...).
sx110

Re: SX110IS - howto start porting
« Reply #269 on: 25 / April / 2009, 19:11:38 »
Thanks a lot chdkj
autofocus is now working :)

by the way.. instead of SET button.. can i use the Zoom button straightway?

like when i press zoom, it will zoom and auto focus both at the same time?
can zoom button be added in AF key[    ]?

Thanks a lot!

Hmmm, it looks to me that this should be possible. AF keys are hardcoded in gui.c. That means, this is not camera specific code, it is rather CHDK-core code. And therefore I'm not willing to change this code in some SX110-binaries (because we are leaving camera dependent code here).

@Main Developers
What are you thinking about?

Cheers!


would be nice :)
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal