SX110IS - howto start porting - page 40 - DryOS Development - CHDK Forum  

SX110IS - howto start porting

  • 573 Replies
  • 228357 Views
*

Offline Frida

  • *
  • 16
    • Pixelbloggen | As I See It
Re: SX110IS - howto start porting
« Reply #390 on: 20 / May / 2009, 08:12:24 »
Advertisements
I have perhaps some stupid questions about camera black level.
Does this apply to all models using the chdk?
Is it for using the conversion to DNG in camera or does the DNG4PS2 program work with this change?
I use the DNG4PS2 because converting to dng in camera took to much time but I'm not always pleased with how the DNG-files comes out.
I have a PS S5IS firmware 1.01B

Re: SX110IS - howto start porting
« Reply #391 on: 23 / May / 2009, 11:30:46 »
I've the power on problem again. Sometimes in play mode too - using on/off or play button too.

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #392 on: 23 / May / 2009, 17:33:15 »
Does this apply to all models using the chdk?
No, it doesn't. Black level is set to 31 per default. But each camera might use an other value for it. S5is uses 31. Have a look at camera.h....
Is it for using the conversion to DNG in camera or does the DNG4PS2 program work with this change?
As far as I've understood Black Level is used as a threshold in RAW pictures and also will be written as descriptive value in DNG-file. It's definitly not a clear answer to your question but I don't know how DNG4PS works.
sx110

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #393 on: 23 / May / 2009, 17:36:17 »
I've the power on problem again. Sometimes in play mode too - using on/off or play button too.
Remember it but I'm to lazy to search for...Could you describe it in more details, please?
sx110


Re: SX110IS - howto start porting
« Reply #394 on: 24 / May / 2009, 13:07:31 »
when I try to turn on the camera sometimes it doesn't do...
pressing/holding "play" or "on/off" button too

the blue and the green led blinks but sometimes the camera turns off
in rec mode the objective comes out - camera off

Re: SX110IS - howto start porting
« Reply #395 on: 24 / May / 2009, 13:25:07 »
I never had this bug after the startsound fix...
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

Re: SX110IS - howto start porting
« Reply #396 on: 24 / May / 2009, 14:01:50 »
I've tried
- to turn off Canon menu - Power saving - Auto turn off
- to turn on Canon welcome screen
- to turn on CHDK welcome screen
all sounds were always disabled

next:
- I'll try to format SD card again (A-Data SDHC 4 Gb, Class 6)
- or try to turn ON chdk welcome sounds :]

I see black screen too but the screen turns off when I release the button (play, or on/off). (I can hold for minutes.)
« Last Edit: 24 / May / 2009, 14:10:20 by zodiac757 »

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #397 on: 24 / May / 2009, 14:16:56 »
Strange.
Are you using the latest CHDK version from autobuild?

Blue led means CHDK is starting up.
What happens if you are using regular Canon startup? Did you encounter similar problems?

First of all, I'm using firmware update method as default startup method. Camera will be started in normal Canon mode and I can decide if I'm using Canon or CHDK mode. I have some trouble with battery power but not generally with startup.


sx110


Re: SX110IS - howto start porting
« Reply #398 on: 24 / May / 2009, 14:25:14 »
I use SD Card protection mode and it is always starting...
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #399 on: 24 / May / 2009, 14:43:49 »
Yes, it's definitly independent from startup method. But I would give a hint to zodiac757 how to narrow down the problem. I think, fw update method could help, because Canon mode startup and CHDK startup will execute one after one. If the camera "dies" already in Canon mode, so it might be a hardware problem (and I think it is one but only if zodic757 uses the latest CHDK version).
sx110

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal