SX110IS - howto start porting - page 45 - DryOS Development - CHDK Forum

SX110IS - howto start porting

  • 573 Replies
  • 231564 Views
Re: SX110IS - howto start porting
« Reply #440 on: 08 / June / 2009, 13:24:46 »
Advertisements
is it possible to show ccd + optical temp only?
(by "all" we can see the false sensor value too)

No, it isn't. Otherwise it would require changes in camera independent code parts of CHDK.

Improving CHDK with "ccd + optical", "optical + battery", "ccd + battery" functions can be useful for the other cameras too. I think SX110 is not the only one camera that doesn't support all the 3 sensors.

What does the other cams write with 2 sensors in "all" mode? (Maybe in an another topic we can find.)

In jpeg with 9mp it's 36-360mm EFL. But in raw and nearly 10 mp? 34-340? Any tips? Or can we measure it? I will calibrate it with a Sony DSLR.
« Last Edit: 08 / June / 2009, 13:58:25 by zodiac757 »

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #441 on: 08 / June / 2009, 15:50:46 »
Improving CHDK with "ccd + optical", "optical + battery", "ccd + battery" functions can be useful for the other cameras too. I think SX110 is not the only one camera that doesn't support all the 3 sensors.
...nevertheless we have to avoid camera crashs due to erroneous  functions called by CHDK. GetBatteryTemperature is broken.
What does the other cams write with 2 sensors in "all" mode? (Maybe in an another topic we can find.)
Other cameras (could) have the same problem. But SX110 is the only one that crashs (as far as I know). The whole discussion is based on that...
GetBatteryTemperature returns with any camera dependent value even with no sensors in place. But not SX110.
In jpeg with 9mp it's 36-360mm EFL. But in raw and nearly 10 mp? 34-340? Any tips? Or can we measure it? I will calibrate it with a Sony DSLR.
You are right. Image dimensions influences focal length. I think it should be calculable.
sx110

Re: SX110IS - howto start porting
« Reply #442 on: 08 / June / 2009, 18:23:27 »
10xA=9x6
A=(9x6)/10
A=5,4

then we must multiply with 6 to get EFL (like 6.0-60.0mm -> 36-360mm)
5,4x6=32,4

32,4-324mm without cropping the outer black frame

BUT:
9mp is 3456x2592=8,957952
10mp (cropped) is 3684x2772=10,212048

so the right value is 31,579-316mm

Main Menu / OSD / Misc values / Adapter Lens scale 94 for RAW, 108 for JPEG

or not? I'm tired

maybe a script could to shot the 10mpixel photo direct to jpeg for faster use
or keybind to fast switch raw<->jpeg
« Last Edit: 08 / June / 2009, 18:59:43 by zodiac757 »

*

Offline nerdboy4200

  • *
  • 2
  • SX110 IS
Re: SX110IS - howto start porting
« Reply #443 on: 08 / June / 2009, 23:41:00 »
Hi,

Somebody might also want to post the color matrix corrections, such as below:

Code: [Select]
dcraw -v -r 1.6254 1 2.1871 1  CRW_1356.DNG

So that those who use dcraw, or any other program, and not the Windows programs can also do the raw conversion.
SX110 IS


Re: SX110IS - howto start porting
« Reply #444 on: 13 / June / 2009, 09:37:30 »
"on/off error" again, now most is play mode (95%)

*

Offline chdkj

  • ***
  • 140
Re: SX110IS - howto start porting
« Reply #445 on: 13 / June / 2009, 14:23:44 »
@zodiac757

Hardware failure?
It seems that you are the only one with this problem (at least no one mentioned it after the bug-fix).
sx110

Re: SX110IS - howto start porting
« Reply #446 on: 13 / June / 2009, 20:15:17 »
Maybe the "on/off error" solved (again:)
I've deleted the empty folders in "\dcim", and their .ctg files, in "\dcim\canonmsc".
No errors after it.
That could be the reason that there wasn't any problems for a few weeks after formatting the card.

I've made a mistake by calculating EFL, so the right values are about 33-330mm. I'm gonna crazy.
So Main Menu / OSD / Misc values / Adapter Lens scale is 100 for RAW, 108 for JPEG.
It was wondering why need to modify Lens scale to 108 and why 33mm is the default. Now we know it.
« Last Edit: 13 / June / 2009, 20:35:37 by zodiac757 »

Re: SX110IS - howto start porting
« Reply #447 on: 14 / June / 2009, 12:51:05 »
A note on the ALT button ISO shift bug:

If I set the ALT button to FACE from PRINT, this seems to disable the ALT button in CHDK when I turn the camera off and back on. This makes it so I can't excess the CHDK menu anymore.

My solution is to have a 1GB card for doing special photography with CHDK and a 2GB card for when I need ISOSHIFT which is a lot since I do a lot of shooting in the woods etc.

The display features and power-on into Playmode are still present though.


Re: SX110IS - howto start porting
« Reply #448 on: 14 / June / 2009, 12:53:06 »

Re: SX110IS - howto start porting
« Reply #449 on: 14 / June / 2009, 16:30:41 »
Hi flohack,
raw is exactly the data that the CCD gets from the light - without cropping ("wide mode"), without noise filtering, color modifications, and compression. I think its not a bug.
« Last Edit: 14 / June / 2009, 16:33:06 by zodiac757 »

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal