New here need some help - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

New here need some help

  • 20 Replies
  • 5615 Views
New here need some help
« on: 26 / December / 2008, 20:01:23 »
Advertisements
I have a Canon S3IS and just installed the CHDK for the camera however, when I import my images into either iPhoto or Aperture 2 neither program recognizes the format or the images. What do I need to do to get these programs to recognize these images??? Is there some setting in the camera I need to change???

Anyone???

Thanks Lou
« Last Edit: 26 / December / 2008, 20:04:51 by Chumlord »

*

Offline fe50

  • ******
  • 3117
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: New here need some help
« Reply #1 on: 27 / December / 2008, 07:46:13 »
I have a Canon S3IS and just installed the CHDK for the camera however, when I import my images into either iPhoto or Aperture 2 neither program recognizes the format or the images. What do I need to do to get these programs to recognize these images??? Is there some setting in the camera I need to change???

Hello & welcome, Lou !
- the JPEGS are unchanged, they are always the same, with/without CHDK
- the RAW images (with DNG support disabled) needs to be converted with DNG4PS-2 into the DNG format
- if you have enabled the DNG support in CHDK, the RAW images are still saved in the DNG format, maybe you have to rename them to .dng.

*EDT: if the images are already in DNG format, this information may be helpful:
...DNG files (both from the camera and DNG4PS) are 10 bits per pixel. It appears that not all DNG applications support this format. You can try importing with one that does, and converting it to 16bpp.
« Last Edit: 27 / December / 2008, 07:50:01 by fe50 »

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: New here need some help
« Reply #2 on: 27 / December / 2008, 09:37:24 »
DNG files (both from the camera and DNG4PS) are 10 bits per pixel.
After DNG4PS2 DNG files are 16 bits per pixel.

Re: New here need some help
« Reply #3 on: 29 / December / 2008, 07:11:48 »
Thanks for the responses.

I tried to enable??? DNG in the menu under RAW parameters, DNG Format, but when I try to enable DNG Format I get this error message: Cannot load CHDK/badpixel.bin Please run CHDK/SCRIPTS/TEST/badpixel.lua

Additionally I could not exactly figure out how to download and get the converter running.

I am also wondering if I will need to convert the images prior to using Aperture or iPhoto??

Thanks again Lou


*

Offline fe50

  • ******
  • 3117
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: New here need some help
« Reply #4 on: 29 / December / 2008, 07:50:38 »
I tried to enable??? DNG in the menu under RAW parameters, DNG Format, but when I try to enable DNG Format I get this error message: Cannot load CHDK/badpixel.bin Please run CHDK/SCRIPTS/TEST/badpixel.lua

--> run the script badpixel.lua, it's included in the complete download package, you'll find it in the CHDK/SCRIPTS/TEST/ folder
--> goto the CHDK script menu, select "load script from file...", goto the TEST sub folder & select "badpixel.lua"
--> then start the script with the shutter button - the script will take 2 shoots, the screen is black for some seconds, then press SET to save the badpixel file as stated in the display...

Quote
Additionally I could not exactly figure out how to download and get the converter running.
I am also wondering if I will need to convert the images prior to using Aperture or iPhoto??
If you enable the DNG support, you don't need to convert the images, most apps could open the DNG files directly.

Re: New here need some help
« Reply #5 on: 29 / December / 2008, 08:07:03 »
My scripts folder is empty I do not believe I put everything on the sd card just the two required files so should I put everything there and do it again??

*

Offline Hacki

  • ****
  • 358
  • SX100
Re: New here need some help
« Reply #6 on: 29 / December / 2008, 08:10:36 »
My scripts folder is empty I do not believe I put everything on the sd card just the two required files so should I put everything there and do it again??

You can wait until they occur there magically. Or just use the full zip package and extract it to the sd card..

Re: New here need some help
« Reply #7 on: 29 / December / 2008, 08:12:19 »
Well I have waited three days for them to appear magically is that long enough???


*

Offline fe50

  • ******
  • 3117
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: New here need some help
« Reply #8 on: 29 / December / 2008, 08:18:37 »
Well I have waited three days for them to appear magically is that long enough???        :lol

Re: New here need some help
« Reply #9 on: 29 / December / 2008, 08:24:30 »
I put the files on my SD card however I did it from my Mac the files are there I have gone into the test folder and there are two bad pixel files one is _badpixel.lua and the other BADPIXEL.LUA I tried to select and run each but niether does anything as described ... taking two shoots etc. I had to load all this stuff from a PC before perhaps that is the problem???

 

Related Topics