Empy directories in File Browser

  • 18 Replies
  • 3863 Views
Empy directories in File Browser
« on: 17 / January / 2009, 13:50:29 »
Advertisements
I have a Canon A590SI with 1.01B firmware and I'm running the latest (Jan16, 2009) CHDK 1.01B file: a590-101b-0.9.2-680-full.zip
For some reason I am not able to see any files in the CHDK File Browser, only the empty directories. I have verified that there are files, such as the readme.txt in the /books/ directory on the flash card itself.
This is also preventing me from running any scripts, since when I attempt to "Load script from file" I can not see any scripts.
I am also unable to see either of the subdirectories called examples and test within the /scripts directory.
I can see these files and directories on my PC, but not on my camera.

Any clue as to what is wrong?

-sd

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Empy directories in File Browser
« Reply #1 on: 17 / January / 2009, 13:54:46 »
did you perhaps install multiple partitions on your card?

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Empy directories in File Browser
« Reply #2 on: 17 / January / 2009, 14:18:55 »
Just checked this (got same cam) --> works OK for me ... (on the Canon 32 Mb card)

wim

*

Offline reyalp

  • ******
  • 11496
Re: Empy directories in File Browser
« Reply #3 on: 17 / January / 2009, 16:53:47 »
examples 9 chars. AFAIK dryos only displays short names ?
Wow, I R SMRT  :D
« Last Edit: 17 / January / 2009, 16:57:28 by reyalp »
Don't forget what the H stands for.


*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Empy directories in File Browser
« Reply #4 on: 17 / January / 2009, 17:01:37 »
@reyalp

that's true, but it will still show them - in true DOS short filename fashion, using ~
as I posted above, it must be sth else: i checked trunk680 on the exact same 590 / 101b
and it works as advertised, i see all files (with ~ where required)

wim

Re: Empy directories in File Browser
« Reply #5 on: 17 / January / 2009, 19:01:38 »
I do have two partitions on my 8GB flash card. I have a 2MB bootable partition, formatted fat12 via the SDM installer and the remainder of the card formatted FAT32 for image storage. The camera boots off the CHDK partition and is able to store images in the large FAT32 partition.
my CDHK version is CDHK 0.9.1-678 (jan 13, 2009)
When I use the CDHK File Browser to look at my files, in the root directory I see the CHDK directory (no files or sub directories deeper than the first level; scripts, books, fonts, etc) and a DCIM directory where my pictures are saved (in the A/DCIM/100CANON directory). Now I CAN see the jpg files with File Browser, just no files on the 2 MB boot partition.

The problem is not with the camera, I am able to see directories deeper than the second level and files on a 32MB flash card with the exact same copy of the software. This problem is specific to the dual partitioned 8GB flash.

Thanks for your interest in helping me, I really appreciate it.

-sd
« Last Edit: 17 / January / 2009, 22:01:53 by sleepydog »

Re: Empy directories in File Browser
« Reply #6 on: 17 / January / 2009, 22:13:57 »
I have a Canon A590SI with 1.01B firmware and I'm running the latest (Jan16, 2009) CHDK 1.01B file: a590-101b-0.9.2-680-full.zip
For some reason I am not able to see any files in the CHDK File Browser, only the empty directories.

Same situation here, though with 679. 16GB SDHC card, 8MB FAT12 boot partition, remainder is FAT32; all setup performed with Linux tools.

PhyrePhoX, I take it this is a known issue? I haven't been able to turn up any information on it besides this thread. Is there documentation on this somewhere?

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Empy directories in File Browser
« Reply #7 on: 17 / January / 2009, 22:36:09 »
@skunk

even PhPh sleeps sometimes, i guess ...

since it works OK on my 590 / 101b on a small card, i suppose the bug must be in the multi-partition support code ...

wim

edit: spelling, time for bed for me as well ... 4:37 here ...
« Last Edit: 17 / January / 2009, 22:38:09 by whim »


Re: Empy directories in File Browser
« Reply #8 on: 18 / January / 2009, 00:59:21 »
since it works OK on my 590 / 101b on a small card, i suppose the bug must be in the multi-partition support code ...

I came across a couple of threads mentioning problems with multi-partition support on the A590IS. However, as far as it is described, the problem seemed to be that CHDK would not save photos to the second/larger partition at all.

I am able to save to the second partition; I took four RAW shots and downloaded over 40MB of files afterward. So CHDK is using the second partition correctly. My problem (and sleepydog's, presumably) is that, for whatever reason, it's not seeing most of the files in the first partition---in fact, the only actual file I can see *anywhere* is CCHDK.CFG.

I'm not understanding how "missing files" and "multiple partitions" are related, so any enlightening links/info would be appreciated....

*

Offline frank

  • *
  • 23
Re: Empy directories in File Browser
« Reply #9 on: 18 / January / 2009, 01:38:07 »
I had the same problem, that the file browser doesn't show all files. I copied all the data from the card on the pc. Then I formatted the card very normal with windows. After that I put back the files and I can see now all of the files. Maybe you don't have to format the card, maybe it's windows, that changes something when copiing...
Camera: A570IS      Firmware: 1.01a

 

Related Topics