Porting the ixus70_sd1000 ver 102a to CHDK - page 2 - General Discussion and Assistance - CHDK Forum

Porting the ixus70_sd1000 ver 102a to CHDK

  • 82 Replies
  • 33439 Views
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #10 on: 20 / January / 2008, 03:06:26 »
Advertisements
I'm having issues compiling CHDK. It seems to be hanging on:
boot.c -> stubs_auto.S

I have the SD1000 dump named primary.bin in the 102a folder. Am I missing a step?

I'm very excited at the idea of porting CHDK, because I have a SD1000

*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #11 on: 20 / January / 2008, 03:20:45 »
Hi

Which firmware version to you have?

If you have also 102a i can upload DISKBOOT.BIN and PS.FIR for this camera so you can test, if you have other version like 101b you have to modify every file in platform sub dir depending on your camera.

greetings quietschi

Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #12 on: 20 / January / 2008, 03:24:44 »
I have 102a. I think those stubs files are supposed to be generated by IDA. Do you have the full set of .S files?

I'd love to try your BIN and FIR files.

Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #13 on: 20 / January / 2008, 03:47:33 »
Ok the part in the make file that generates the stubs_auto.S is hanging. I would suspect that it's my compiling environment. I think I'll try to generate it manually.


*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #14 on: 20 / January / 2008, 04:01:45 »
Hi

here are the files for testing, note not everything is working

http://www.zshare.net/download/6696735fe6295a/

quietschi

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #15 on: 20 / January / 2008, 04:05:56 »
I'm not sure wich values to use

Maybe, third value:

shooting: Exxx -> 1110(other bits)
movie:    Fxxx -> 1111(other bits)
play:       Bxxx -> 1011(other bits)

so, mode= (physw_status[2]&0x4000) ? MODE_REC: MODE_PLAY;

Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #16 on: 20 / January / 2008, 04:45:20 »
actually, it seems as though a lot of things work. Histrogram, raw save, zerba.

*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #17 on: 20 / January / 2008, 05:18:36 »
Hi

I guess detection record/play mode of camera works, I can now only start games in play mode.
Something I found out is still not working.
in OSD
Zoom value [EFL] from 35mm to 86mm (should be 35mm to 105mm)
Real ISO I-R:0

in RAW
RAW file in dir with JPEG ( no difference when selected or not )

thanks quietschi


Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #18 on: 20 / January / 2008, 05:27:22 »
Shutter speed and ISO value overrides don't work.
Scripts that issue Shoot command don't work.

Btw, I fixed my stubs issue. I just needed to update cygwin.

I still can't get a succesful build. Are you using the grand branch?

*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #19 on: 20 / January / 2008, 05:38:07 »
Hi

No i'm using the trunk r263

 

Related Topics