Porting the ixus70_sd1000 ver 102a to CHDK - page 6 - General Discussion and Assistance - CHDK Forum supplierdeeply

Porting the ixus70_sd1000 ver 102a to CHDK

  • 82 Replies
  • 34809 Views
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #50 on: 23 / January / 2008, 19:55:13 »
Advertisements
Just an FYI. If you haven't already tried this, I successfully cranked out the SD1000's ISO to 6400. It at least appears to work. For those who might read this and don't already know, the SD1000 is only supposed to go to 1600. There is definitely a lot more noise at the higher levels. The image becomes more yellow, but I think that's just a matter of white balancing and lighting.

Take a look. http://picasaweb.google.com/jon.gentsch/ISOTests

If you haven't used Google's image storage before, you can view the EXIF info on the right by clicking the More Info button.

I'm scared to go any higher. :P
I did set it to 4000, and to my surprise the picture turned out red.
« Last Edit: 23 / January / 2008, 19:57:57 by chaynlynk »

*

Offline whoever

  • ****
  • 280
  • IXUS950
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #51 on: 24 / January / 2008, 05:33:13 »
Hi whoever
I think that the keyboard is very different to mine.
Maybe it's better you try values you get from a more similar camera like ixus850_sd800.
I copied my from the a570 and all are the same exept right and down were changed.

quietschi

Thanks quietschi, I now got it right. In fact, the keyboard in ixus950_sd850 turns out to be the same as yours, but I, meaning to use your kbd driver, accidentally copied the one for ixus800_sd700, where of course everything is different. Sorry for the confusion.

*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #52 on: 24 / January / 2008, 05:53:34 »
Just an FYI. If you haven't already tried this, I successfully cranked out the SD1000's ISO to 6400. It at least appears to work. For those who might read this and don't already know, the SD1000 is only supposed to go to 1600. There is definitely a lot more noise at the higher levels. The image becomes more yellow, but I think that's just a matter of white balancing and lighting.

very good, how you did this?
i tried to get iso overwrite, but it didn't work for me. I can only get iso til 1600.
btw shutter speed overwrite works - tested from 30" to 1/20000. av overwrite i'm a little confused, because it's only possible to get open and close aperture values like 2.8 and 8.0 for 35mm, all other values meens the apterure is getting closed to 8.0. (select 4.0 get 8.0).
For me it looks like there is no other aperture physical

Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #53 on: 24 / January / 2008, 08:10:22 »
I used the propcase script http://chdk.wikia.com/wiki/UBASIC/Scripts:_a_property_case_value_tester. I just set the propcase values manually. I also made sure i was in manual mode.

Do you think you could upload a newer copy of your source code? I'm sure yours is more complete.


Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #54 on: 24 / January / 2008, 08:39:23 »
Welcome IXUS fellows,

to understand what aperture override does on IXUS/SD cameras, read on...

Hello AllBest,

please include a new 3-value menu entry for the SD and a560 cameras on the next build (as a replacement for the removed Av override):

ND-Filter override: off / in / out

use the +5 Av overide as the "in" value
use the MIN Av overide as the "out" value

Av override has been verified working this way on the SD700 with your build 11, for more info see
http://chdk.wikia.com/wiki/SD700_CHDK_Porting

Thank you


Look into platform/ixus800/shooting.c, there you will find the associated aperture_sizes_table[].
Maybe all newer IXUS cameras are created equal and you can simply copy it over to your shooting.c.

Cheers
  nirschi
« Last Edit: 24 / January / 2008, 08:56:01 by nirschi »

Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #55 on: 24 / January / 2008, 09:06:18 »
One more hint. There may be another problem depending on what release your port is based...

Hi AllBest,

Again, congrats on a great build! Tv Bracketing indeed works on my SD700!

I also tried the other features, you & EWAVR sure push this forward!

My solution to the Tv bracketing issue was different, you might consider it:

It turns out the M-Mode in the SD700 is just marketing-speak for a P-Mode, so I went to:

platform/ixus800_sd700/main.c

And modified: "    { MODE_M,                  32772 },"
To become: "    { MODE_P,                  32772 },"

It solved the the Tv bracketing issue, but removed Av setting (?). Actually, for SD cameras, it seems an ND-Filter setting is more appropriate, since the Av is tied to the zoom. See http://chdk.wikia.com/wiki/SD700_CHDK_Porting for a small discussion.

Thanks,
mkmenuts

Look into the Tv bracketing code in shooting.c. Using MODE_P will probably prevent future trouble.

Cheers
  nirschi

« Last Edit: 24 / January / 2008, 09:14:38 by nirschi »

Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #56 on: 24 / January / 2008, 12:58:56 »
I updated http://chdk.wikia.com/wiki/PropertyCase to include the DIGIC III property cases that were already in the source and the ones we found.

*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #57 on: 24 / January / 2008, 18:22:13 »
hi
i tried alot with tv, av and iso overwrite, also with braketing. What i can say now is
tv overwrite and bracketing works from the chdk menu
av overwrite and bracketing (each other value than min aperture gives max aperture not sure if helpful)
iso overwrite and bracketing don't work correct.
when using script propcase.bas iso 3200 works, other iso values above 1600 makes funny color picture also iso 1000 etc.
from chdk menu iso overwrite - more than iso 1600 is not possible (exif data report iso 160 on each value) - in propcase 149 the value changed to 0 (AUTO-ISO)

So what we need now is somebody how knows how we can overwrite out of chdk the propcase 149 value 0 to the value we want to use eg 3200.

About all other stuff. IMO everything works as far as i can see. Scripts for this camera have to be updatet, because of the different keyboard layout. Maybe some of the developers like EWAVR can add support for this camera to the chdk source.

after all i will test a few days more than i upload my files again

bye quietschi


*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #58 on: 29 / January / 2008, 07:41:20 »
Hi

Here is an actual version of my porting based on trunk r272. The PS.FIR and DISKBOOT.BIN is in /bin folder.
Please can someone add the files to the trunk.
Hope you enjoy testing

quietschi

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Porting the ixus70_sd1000 ver 102a to CHDK
« Reply #59 on: 29 / January / 2008, 08:23:52 »
Please can someone add the files to the trunk.

...adding...wait....

upd: One question:

platform/ixus70_sd1000/main.c :

static struct {
....
 modemap[] = {
    { MODE_AUTO,               32768 }, // PROPCACE 49
 
But mode_get()   uses PropertyCase #0. 

#0 or #49 ? Or both are equal?
« Last Edit: 29 / January / 2008, 09:00:43 by ewavr »

 

Related Topics